Showing results for 
Search instead for 
Did you mean: 


Journeyman III

AMD Radeon 6600xt restart pc when screen timeout is turned on?

Anyone else having issues with this card causing pc to crash once monitor turns off for power saving through windows?

have tried everything, at the moment just have the pc running with no power saving features on what so ever and no problems now.

1 Solution

Yep, fixed in 22.5.2 guys! 

View solution in original post

98 Replies

Did you install it correctly?

Journeyman III

Hi people,

After many days of research and investigation this solution seems to be working for me. I have Gigatybe x570 motherboard. Here are the steps that I have taken with fresh Windows 11 installation. The entire issue seems to be related to ULPS feature of Radeon RX 6600 XT that somehow conflicts with Power Saving modes (display off/sleep/hibernate) and forces to reboot the PC. Here are the steps that I have taken:  

  1. No need to disconnect internet.
  2. Download/Install all latest required Windows Updates
  3. Download/Install latest AMD Chipset drivers. 
  4. Download/Install latest "Radeon Software Adrenaline" with "Factory Reset" option checked from Gigabyte website.
  5. From "Radeon Software Adrenaline" go to "Settings->System" and check for latest updates. A newer version will be offered which is not available on Gigabyte website. Install it. 
  6. Fix Radeon RX 6600 XT "restart PC on display off" issue. Execute following steps.
    1. open regedit.
    2. open Edit->Find.
    3. search for "EnableUlps".
    4. for each "EnableUlps" match found, change its value from "1" to "0". There will be multiple match found. In case regedit prevents from updating the value then retry it by re-opening the regedit.  Restart the PC if necessary.
    5. from "Control Panel" open "System and Security->Power Options".
    6. switch "Power Plan" from "Balanced" to "High Performance".
    7. navigate to "Choose what the power buttons do"
    8. switch sleep button to "Do nothing"
    9. uncheck "turn on fast startup". Save Changes
    10. navigate to "Change settings for the plan: High Performance->Change advanced power settings".
    11. expand "sleep" option and set everything to "Never/Off/Disable".
    12. set "Turn off the display" to 1 min and confirm the PC doesn't restart after the display turns off.
    13. Windows Updates offers "Advanced Micro Devices, Inc - Display - *******" as an optional update.  Let it sit there. DO NEVER INSTALL IT!!!

Hope that helps other as well. 

I'm glad it worked out for you, enjoy!!

Adept I

new drivers 22.3.1 and no fix, I can't believe this is still happening, they took 5 months to release a recommended patch, I created an account here to express my anguish since I've been following this thread for a long time, I can't believe it.


not the answer you want, but I returned the 6600xt and got an RTX 3060 and no issues since..


of course, it's a **bleep** problem with the amd drivers, and no one from the company knows about the problem, it makes me hate it. i have no problems with the drivers that windows installs, but i have no access to the gpu features, how can they perpetuate an error like this for so many months?


Did you try SergiuL's solution?, disable the EnableUlps through register, restart computer and should work. 


No, I don't want to mess with system stuff and registers... it could lead to a major problem.


Just turn the screen saver off...sorted

Adept I

I am having this same issue. I thought it was the "Virtual Super Resolution" setting but I turned that off and it is still doing it. I have the AMD Radeon RX 6600 XT. I really hope they fix this. I may have to turn off the sleep option too. Before I updated the driver to the current ones, when I woke it up again, everything I had open would be closed. So I had better saved! I am usually working in WordPress.
It also says to do a Factory Reset of the Drivers? Or Software. Has anyone done this? And has it helped? I got scared and chose not to do it. It said something about possibly changing the BIOS if I did that, and I have already returned the PC for a new one once. Seeing all these responses, it seems it may have been the graphics card that is the problem all along.   Was looking here to see if there was a fix or a work around. 

Thanks for any help!


The post just before mine gives a work around for this problem! If I had kept reading, I would have seen it! 


Same here with Sapphire Pulse 6600XT. Permanant black screen when windows goes powersaving, hard reset necessary. Disabling ULPS "solves" the problem. I have this problem since driver "non-whql-radeon-software-adrenalin-2020-21.12.1-win10-win11-64bit-dec3" (!!!), not before... I did send bug report after every new driver installation - no progress

Hey AMD!!!! There are alreaedy two threads!



if you use the drivers that install windows update 30.0.13023.4001 this problem does not happen, but sacrificing the amd software, but not only that, the system looks more stable, more fluid and I have no problems with the hardware acceleration of chrome as I have with drivers + software, in world of warcraft every time a video starts or ends on youtube on my second monitor I have drops of 5 fps in the game. I suspected that maybe the version of the Bios Agesa that gives so many problems as I read in portals could be a cause of not feeling that my computer is giving the size, so I reverted the bios to the b, before the change of tpm was made for computers that want to upgrade to w11, as I do not plan to use it and continue in w10 until I put back the drag and drop. but i can confirm that amd software breaks the rx 6600xt, nothing feels fluid, crash with ulps, and stuttering caused by chrome



the problem persists in 22.5.1


Yeps, the problem still persist with the new drivers.

Another ticket to AMD...

luckily is the "disable ulps" solutión....


Hey ya'll, 

I'm hopping over from a different thread... WHEA Logger Event ID 18 - Page 2 - AMD Community

In the off chance that something else might work.  I've RMA'd the CPU, but restarts just keep happening.

The EnableULPS fix didn't work for me.

Just adding to the knowledge!

Ryzen 7 5800X, 3801MHz
MSI AMD Radeon RX 6600 XT MECH 2X 8G OCV1 -- Adrenaline 22.5.1
ASUS TUF GAMING X570-PRO (WI-FI) -- BIOS 4403(beta, but the previous didn't work either)
2x16Gb OLOY OWL DDR4 3600MHz PC4 28800
Windows 10 Build 19044


for the moment I left the monitor timeout in "never" I feel that changing the ulps in the registry the drvier and the graphic did not have the proper stability, for now everything working perfect in the 22.5.1, I hope that at some point amd will solve this problem of reboot, it is very annoying, I will continue doing the follow-up on each driver.

Adept I

the problem persist after update may 2022 preview

Journeyman III

I also had that problem and found a solution in a forum... It was to turn off the Auto source detection or something similar to that in the Monitor OSD settings... And it worked for me too!!!