Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Ryzen 9 7950 X3D uses all cores while gaming

Issue with 2 CCDs on the 7950x3d.

Game: COD MW3 and MW2
Specs: R9 7950X3D
2x32GB 6000mhzCL30 EXPO kit
X670E Tomahawk
Samsung 990 Pro 2TB

Problem: When logging into the game, it initially boots into MW3, and everything runs smoothly with C9-C16 in the PARKED position. Only the CCD with x3d cache is used, and the result is optimal without stuttering when switching between CCD0 and 1 (IMAGE 1).
BUT... when switching/selecting the MW2 game, the game will soft restart, and during booting, all cores, including CCD0 and CCD1, are used. No cores are PARKED (IMAGE 2), especially CCD1 without x3d cache. In fact, the game tends to run mostly on CCD1 without x3d cache.

I've tried using Process Lasso, but it always gives an error (IMAGE 4).
However, when Process Lasso is activated in MW3, everything is fine (IMAGE 3).
Should I manually disable CCD1 in the BIOS every time I play a game? This would result in it being more like a 7800x3d.
Is there a solution, bro?


1 Solution
Community Manager

Try bringing up game bar when MW2 is running, and select remember this is a game. Save and restart MW2.

View solution in original post

2 Replies
Adept III

In the meantime, there are a couple of things you can try:

  1. Manually disable CCD1 in the BIOS.
  2. This will make your CPU perform more like a 7800X3D, but it will also give you the best performance in MW2.
  3. To do this, consult your motherboard manual for instructions.
  4. Use a third-party program like Process Lasso to disable CCD1 while playing MW2.
  5. This may not work with all games, but it's worth a try.
  6. Wait for a patch from AMD or Activision.
  7. This is the most likely solution, but it's unclear when it will be available.

Which solution is best for you depends on your needs and preferences. If you need the best possible performance in MW2, then disabling CCD1 in the BIOS is the way to go. However, if you want to be able to play other games without having to disable CCD1, then you may want to try Process Lasso or wait for a patch.

Here are some additional notes:

  • It's possible that the game is not optimized for the Ryzen 9 7950X3D.
  • This is why the game may be using all cores, including CCD1 without x3d cache.
  • It's also possible that there is a bug in the game.
  • This is why the game may be soft restarting when you switch to MW2.
  • AMD is aware of this issue and is working on a fix.
  • However, it's unclear when the fix will be available.

I hope this helps!

Community Manager

Try bringing up game bar when MW2 is running, and select remember this is a game. Save and restart MW2.