Showing results for 
Search instead for 
Did you mean: 


Adept II

Ryzen 7900X3D: Game Mode causes severe stuttering in FIFA 23

Hello everyone.

I have a Ryzen 7900X3D, and I noticed that I'm facing severe stuttering when running FIFA 23.

I followed all the instructions here:

Latest versions of everything installed:

  • Windows 11: 22621.1413
  • BIOS: 1004 (Asus ProArt X670E)
  • Chipset:
  • Xbox Game Bar: 5.823.3261.0
  • Graphics: GeForce Game Ready 531.41

For some reason, FIFA 23 stutters. I realized that if I turn Game Mode off in Windows settings, the stuttering goes away completely. My concern is that with Game Mode off, core parking won't function correctly.

I'm not sure what the issue is, and it seems to only affect this one title. No issues in Valorant, Hogwarts Legacy.

Any ideas what the issue could be?

11 Replies
Adept I


I've this issue too! 

With my 7950X3D, and Game Mode on, the game is almost unplayable. Breaks, lag, stuttering.... When I turn Game Mode to off, the game is nice and smooth 

for you, it also only happens with FIFA 23?

Adept II

Just as an update. I tried this with the latest Asus X670E BIOS 1101 for my motherboard, which claims to "improve system performance and stabilize AMD Ryzen 7000 X3D series processors".

But the stuttering still happens in FIFA 23.

Journeyman III

Same issue is happening with me when i am playing games gta 4 obb.I aslo trying to find the solution but can't.


Have you tried with SAM disabled?

Have you tried with fTPM disabled in BIOS?

Have you tried disabling USB sleep settings?

Those are the typical counters to help with stuttering .. might help .. might not

ThreeDee PC specs

Besides Valorant and Hogwarts Legacy, I have since tried a bunch of other games. Forza Horizon 5, Microsoft Flight Simulator, Cyberpunk, Jurassic World Evolution 2, Spider-Man (Remastered and Miles Morales), Surviving the Aftermath, COD:MW2 to name a few, none exhibit stuttering.

FIFA 23 is the only title that does.

With regards to your suggestions, there is no change, thankfully, because it would be a major inconvenience to turn fTPM and SAM off every time I want to play FIFA. fTPM is required by other games like Valorant.

USB Sleep settings. Not sure why it would cause stuttering, but I just tried it. No difference.

BTW, I didn't have any issues with stuttering in FIFA 23 when I was on a Ryzen 7700X. It's only happening on the 7900X3D. And yes, I did a fresh Windows install when I upgraded.


I didn't think they'd help your particular scenario .. but they have helped at least reduce stuttering in some setups

Yours seems more of an issue with how FIFA 23 deals with core parking ... maybe

Hopefully a game update will correct that

ThreeDee PC specs
Journeyman III

At first sorry for my poor english. My configuration:

MSI 670E Carbon

AMD 7900 X3D

Gigabyte 4070 Ti

Gskill Trident z5 ddr5-6000 Cl30 32gb 

I play only 3 games, Fifa 23 , Skyrim AE Ultra modded and Dying light 2 .

I had the same problem, but turn the game mode off (at win 11), fixes all. 

Adept II

I have a triple-display setup (a 1440p ultrawide flanked by two 1080 displays in portrait).

Out of curiosity I tried turning off the two 1080p displays to see if maybe them being active is confusing the core parking feature and thus causing the game to stutter. But no, the game still stutters even with only one display connected. 

Journeyman III

I fixed the problem without to take the windows 11 game mode off.

You only need CPU Core Unparking Manager 3 the link is at the Video.

Now Fifa 23 is like i wish. 


This is the same thing as turning off Game Mode. It just unparks the cores for all applications, which is not the desired outcome, especially for X3D processors.

I'm not sure whether the issue with FIFA 23 is the game itself, or Windows/Chipset drivers don't properly assign the right cores for FIFA 23.