Showing results for 
Search instead for 
Did you mean: 


Ryzen 5700G crashing/reboot

Hello Community,

I bought the following:

CPU: AMD Ryzen 7 5700G (65Watt TDP)
Cooler: AMD Box Cooler
Mainboard: MSI B550M PRO-VDH Wifi (UEFI: 7C95v2C)
RAM: Corsair CMK64GX4M2E3200C16, 2x32GB
PSU: bequiet BGT P6-470W (+3,3V/+5V 185W, +12V 360W), 8PIN CPU Power
Storage: none on testbench
GPU: none (only using included in Ryzen APU)
No other cables or fans connected to the motherboard.

The problem:
The system is rebooting/crashing suddenly and randomly just from the start. Sometimes showing Chinese instead of English in the UEFI. Reset and reboot fixed this. There is no OS or SSD installed. Just starting into UEFI/BIOS using the USB keyboard, HDMI and moving around in the screens of the BIOS. Crash, reboot into UEFI. Crash again without doing anything. Sometimes activity using the arrow keys in the BIOS results in crashing. Sometimes not.

I managed to update the firmware using the Flash-Button and a USB-stick that version 7C95v2C (2022-08-08) is used.

I googled the issue and found this: and 

I checked RAM settings: XMP, auto (DDR4-3200) as well lower settings like DDR-2166 didn't stop the crashing. CPU temps around 27 to 45, fan working at 1600. Disable CBP and PBO works, the constant crashing stops, almost... because it occasionally crashes in a 1h period. This setting forces a frequency that is fixed at 3.8GHz. I was able to boot from USB with memtest 6.00: passed 64GB RAM successfully. So, no real RAM issue. Stressing the system a bit with mprime also worked (95% RAM usage, CPU at 55 degree), until the end of the test: going back to CPU idle crashed the system, automatic reboot. I also tried to use a PSU be quiet! 300Watts (only 4PIN CPU connector) just to check a different power supply, no difference. 

Any ideas? I think it must be an issue with the mainboard or APU.

1 Solution

final solution: I got a brand new MSI mainboard (same type) and it works without any errors. So, it was definitely the mainboard, most probable the onboard voltage converter or power supply for the CPU. 

View solution in original post

11 Replies

Can you offer more data


sure, what do you need?


Did you edit the message? The only thing I saw before was heading without any message.

Something that jumps out is 5700G with integrated graphics connected to more than typical amount of memory, which is also likely dual rank (due to size). I would likely try with one dimm only and preferably with a stick that is single rank only. While 2x64 dual rank should work, it does not mean it necessarily does.

I know it sounds crazy, but sometimes it just works, that you clear cmos. I have no idea why it works, but sometimes it fixes issues you would never connect to it. So unplug machine from wall, wait 15-20 seconds, short JBAT1 jumper or remove battery.


It kind of also sounds like some button might be stuck. Try different keyboard/mouse if you can.

Just in case, you could also unplug reset switch cable from motherboard and power switch too after start. Sometimes switch in front panel of case is broken and causes issues.

Try to reseat CPU to socket (remember you'll need isopropyl alcohol from cleaning and new thermal paste to reinstall CPU cooler)

I would also check IO-shield does not have any of it's small grounding pins sticking to inside motherboards ports and shorting something.

After all this, if problem persists, there is a good chance it is just broken. Can't be sure, but I vould vote motherboard.


Thanks a lot for your answer and your effort. And yes, I edited the posting.

Regarding hint1: good point, I tried to insert just one 32GB DIMM, and I also moved to different slots. Unfortunately the same crashing happens. Due to lack of RAM modules, a test using just a smaller RAM module (single sided) cannot be executed.

Hint2: sadly reset cmos didn't work. I removed the battery earlier today but tested only with the firmware from last year.

Hint3: good point, but never had an issue with the keyboard. no mouse was plugged in at any time. so I think I can rule this out.

Hint4: the mainboard never connected to a frontpanel, just sitting on a plastic surface (suitable table in a lab) next to power supply. (hint5: so there can't be any shortening with the IO-shield or case)

Hint5: CPU was seated carefully onto the socket, but I could give a reseat a try.

If these new tests fail, I will try to replace the mainboard. Thanks a lot!

It's a very very strange problem! All tests below were done, without any case or pc-tower. Just the mainboard with CPU/Cooler and RAM sitting next to the PSU.

I took the MSI board with RAM and CPU to the resellers testbench. It IS WORKING WITHOUT ERRORS on a bequiet PSU and with another cooler and display. No single system crash.

So, back to my office, plugged into my PSU, HDMI display and using the boxed cooler: it is CRASHING AGAIN. Switched to new PSU bequiet Straight Power 11 650W at the office. No difference. Not using the HDMI display, using DP or VGA cable instead. No difference, system is crashing randomly.

So I tried a SECOND VISIT at the resellers testbench. It IS WORKING WITHOUT ERRORS using the resellers power supply, PSU bequiet and display using DP cable. We also started Windows 10 from USB drive and executed prime benchmark. No single system crash. I was really surprised.

So, back to my office for second test. Bequiet PSU is plugged into my UPS and with NO cable plugged into power connection of the room. Didn't unmount the cooler, CPU or RAM. Same mainboard like at the resellers testbench. No difference at the office, system is crashing randomly after start. Even if there is no electric connection to anything like the UPS. Maybe its the display, so unplugged the display from the UPS. Using network cable and bootable USB stick with unraid. Thus, only the network cable has a physical electrical connection to other components in the room. Surprisingly, unraid started and login to terminal was possible (just once!). Started prime benchmark, 1-2 minutes at full load and sadly the system crashed. Disabled the FI-switch of the entire office so that no device next to the office is disturbing the MSI board that is running on the new PSU plugged into UPS working on battery. MSI board is crashing randomly, even without display or keyboard connected.

How is this possible? Is it really an electro magentic situation in my office? I don't think so. Even the powerline device was unplugged. I really tried to find the reason... this is wierd.

I have another server in the room based on Intel CPU and Asrock mainboard. It is rock solid and never crashed a single time. Same with a couple of other devices. Never had an issue.

Next step will be to replace the mainboard.


dont laugh but those issues you mention sound familiar .

With my homeserver APU 2400G [TUF x470 Board ]which i got RMAed by AMD.

And got a shiny new 3400G but the issues stayed and at that time i had a Asus TUF Gaming Plus X470 Board.

Now my 3400G is on a B550 STeel Legend from asrock,my first one btw and im kinda impressed ,faster and much more stable than the TUF board was.

Also using a straight power 11 PSU 550W.

So did u already tried the APU on another Board?

6800XT Pulse,2700X @4 Ghz allcore,X470 Crosshair Hero VII,32GB Gskill 3600mhz B-Die,

thanks for your advice. 


Sounds like your previous motherboard was simply broken as motherboards do not really have noticeable performance differences nor are unstable if they work.


final solution: I got a brand new MSI mainboard (same type) and it works without any errors. So, it was definitely the mainboard, most probable the onboard voltage converter or power supply for the CPU. 

Journeyman III


My self Subhadip I also facing the same problem the pc is taking re-start after every interval no perfect timing. Some time it is taking re-start within 2min or sometime it also not taking re-start amd some time it taking after every 1 min..

Am also Ryzen 7 5700g user and facing this problem I claimed my SMPS Hardisk ssd ram because my system is under warranty but nothing has changed am still facing the same issue later I given mother board to service centre but they asked that the problem is with CPU

Journeyman III

You are wonderful!!!! I will try this. It is exactly what I am looking for. Thank you.