Showing results for 
Search instead for 
Did you mean: 


Adept II

Ryzen 5 1600 Microstutter

Message was edited by: M W - this answer should not be 'assumed answered' because a solution has not been found.

I'm essentially encountering stuttering in games and some applications, despite my temperatures being fine and low usage of the components. My questions are: is this likely hardware as it is presenting itself on operating systems, over two drives? Also, what other tests can be performed to isolate where the issue may be?

Prior to all of this, I have had difficulties with the system since I purchased the parts, and built it. I have had 3 motherboard replacements due to hard freezing, which appears to have been a PCIe lane problem from PCIe Gen 3 on the board. This is now resolved.

I have also had a problem with my GPU throttling due to heat problems, this was replaced and considered a faulty part.

Description of Problem:

On every setup I have tried, games will encounter some form of short micro stutter. This lasts a short amount of time, and occurs at seemingly unknown* intervals. It can happen in a series of stutters, or not happen for over one hour. Once it begins, it is very noticable and prominent. The stutter will last approximately between 250ms to 1 second. I observe that the frametime will often spike, but not always.

This was tested on both Linux and Windows 10, on separate drives, with fresh installs, over multiple disks. This has been tested under 'diagnostic' conditions, whereby I have installed and updated my drivers, and disabled anything that is not required, nor unrelated to the task at hand.

There are no overclocks, though I have tested with stock speeds at higher voltage. And tested with overclocks. If anything, an overclock will help. Though, I am keeping it removed. This began before any overclocking took place.

I have attempted the following:

* Replaced components

* Reinstalling the OS (and trying Linux, on different HDD's/SSD's, and removing them when other drive is in use)

* Flashing BIOS

* AMD chipset drivers

* Updating Nvidia drivers (and removing old ones with DDU)

* Reseating components

* Removing peripherals and components until the bare essentials

* Resetting CMOS

* Reducing GPU power target

* Checking VRM temps

* Disabling drivers, and keeping the bare esential drivers required to run

* Checking LatencyMon -- sometimes ntoskrnl will spike, sometimes it wont. Sometimes I will have a high ISR latency, sometimes I wont.

* Monitoring voltage

* 3 different monitors, cables and display interfaces (DVI, HDMI and displayport)

* Disabled and uninstalled monitoring software

* Reduced graphics settings in both Nvidia Control Panel and games themselves (remember, it happens in some applications, too) -- VSync off and on

* Using Prime95 for stability at stock settings -- passes all torture tests

* Tried different power plans, with different CPU % settings

* Purchased a PSU tester, and it passes all the tests.

I also disable unnecessary services and processes on both operating systems.

I've replaced the board, the GPU, and almost every other component. I've removed the network card and disabled the wifi and bluetooth drivers. My temperatures are good. To the point where Prime95 will max out around 78C on the test that produces the most heat. The GPU rarely goes above 70C unless in stress testing, and averages at around 61C during load. CPU averages around 58C during load.

There appears to be no throttling, or no obvious sign in monitoring software when this takes place.

The voltages appear to be fine, and hit the target voltages.

I do not know what to monitor anymore. I am kind of at a loss for where to look.

Clearing 'Standby Memory' on Windows appears to help for a short period of time, so I would have assumed disk/ram. Though, yesterday when I 'undervolted' (reduced power target) my GPU, it also helped for a long period of time. This does not always work, though. Sometimes I can remove the stanby memory and it will still happen, just less so. I cannot find the cause.

Component List

CPU: AMD - Ryzen 5 1600 3.2GHz 6-Core Processor Ryzen 5 2600

Motherboard: ASRock - AB350M Pro4 Micro ATX AM4 Motherboard  MSI B450M Mortar

Memory: Corsair - Vengeance LPX 8GB DDR4-2400 Memory x 2 (16GB total) G Skill Flare X 3200 CL14

Storage: Crucial - MX300 275GB 2.5" Solid State Drive Crucial MX500 2.5" Solid State Drive (500GB)

Storage: Seagate - BarraCuda 1TB 3.5" 7200RPM Internal Hard Drive

Video Card: EVGA - GeForce GTX 1060 6GB 6GB SC GAMING Video Card

Case: Thermaltake - Core V21 MicroATX Mini Tower Case

Power Supply: Corsair - TXM Gold 550W 80+ Gold Certified Semi-Modular ATX Power Supply  Corsair RMx 650W 80+

Wireless Network Adapter: Gigabyte - GC-WB867D-I PCI-Express x1 802.11a/b/g/n/ac Wi-Fi Adapter - Not connected

Monitors: Acer - XF240H 24.0" 1920x1080 144Hz Monitor  x 2

Updated component list

247 Replies
Journeyman III

Just read through your entire post, do you mind try doing this. Open Command Prompt in administrator and using the following command below and see if you still stutter.

bcdedit /deletevalue useplatformclock




This is an old fix apparently. I tried this a long time ago, and more recently too. It didn't ever fix the problem.

Adept II

... No comment


The new 1809 release update seemed to help a little, but its still there.

I feel like it maybe is a CPU issue related to all those patches intel and amd put in for spector hacks.
Theres a way to manually disable and undo those patches, and im curious if that may fix the problem.


I think some of it will be OS related, and some of it will be processor microcode. So, going forward, I doubt you'll be able to stop it.

Journeyman III

Hi have you still the same issue.

I have bought my new computer last month and I have noticed the same problem as you. I have it since I got my computer.

At first I thought it was because of my second hard drive so I reinstalled my games on my SSD but the stutter still happened. I tried to look on the Internet for solutions but so far your post has been the most useful I have found.

I noticed that the stuttering is not the same in every game. For instance it is far worse with games such as the last Total Wars (Rome II and on / Attila is horrible) because they are more CPU intensive. Yet I have this issue with all my games: DoW III, The Banner Saga I and II, Rome II, Shogun II, Attila, every game that I have tested so far I have had this issue.

I have a 6gb 1060 gtx MSI, 8gb of RAM, a Seasonic 550w gold plus, and a Ryzen 2600x. I am sure that the issue comes from the processor.

I have tried the spybot tools but it has improved nothing.

What I have noticed is that I can reproduce the stuttering. In Attila Total War there is a benchmark. The stuttering always happens at the exact same moment in the benchmark. At the end the benchmark says I had an average 52fps but there are huge spikes on it which show how terrible the problem is.

I had a similar problem in the past but it was because of a Green Caviar HDD and when I moved my game on the first HDD, which was a black caviar, the issue disappeared. But with my new computer the issue exists on both the HDD and the SSD.

Have you tried using a different processor mpw? I think I am going to buy an intel one as soon as I have the money but I'm not 100% sure that the problem comes from the Ryzen 2600X.

EDIT : Here is a screenshot of my cores when the problem happens. The second core seems to be doing something completely different than the others. The last one is deactivated for Attila because the game lags otherwise (issue related to the game). Imgur: The magic of the Internet


The problem Is Indeed CPU related but i'm not sure anymore if Is the CPU itself After i replaced mine  r5 1600 with a brand new 1600, but could Be something Killing the CPU performance, the stutter Is more evindent in CPU intensive game when loading new thing disabling Shadow atleast in fornite greatly decrease microstuttering but i never found a solution even After replacing different parts wasting money and time...


So, ive done alot of research this isnt ryzen specfic, this is all OS specific and all processor. 
I've been gaming and it seems ALOT better, almost perfect for me these days.

However, i did download fortnite and the game was chopping hard...?. I have no reasoning for it, however... has an AMD engineer gotten back to you yet? We need to involve amd and microsoft into this.

Also, why are you running a 1600 @ 3.98 its prolly not fully stable in that case.
I also played with my memory timings and loosened them up a bit.

New bios are out for our board, try it out.

Also something to try
6 Ways to Fix Micro Stuttering in Games on Windows 10 - Windows 10 Skills

I don't have a 1600 it's a Ryzen 5 2600X and I didn't change anything on the processor so I think there is no issue with that or is there?

It's funny because I have a 1060gtx 6gb same as you and when I look on the Internet there are many people complaining about the same issue with 1060 6gb. Could AMD investigate that?


cacxius, I have already tried with an AMD RX580 8GB. It still stuttered.


This BIOS update (if we're talking AB350M Pro4) is welcomed but I don't know if AGESA has any improvements for 1st generation Ryzen processors. Can amdmatt​ comment on that? I will be contacting ASRock for a response, too.

I understand that stuttering isn't isolated to Ryzen, but it appears that Ryzen is disproportionately affected with newer builds (1-2 years) that have all the latest updates.

I have been working with amdmatt​ and he setup a test system whereby he did not encounter any system stutter. Whilst he didn't have exactly the same system, he was using a Ryzen 5 1600 and didn't encounter stutter on 1809. This is the strange thing, though. Many people do, and many people don't. After reformatting and trying so many disks, peripherals, motherboards, etc etc, I simply cannot figure this out -- unless it's an AGESA issue.

As Gigabyte didn't have the latest updates to AGESA when I tested with a Gigabyte DS3-H B350, it could potentially be entirely down to this. I tried the (F1) and I believe (F22).

For what it's worth, I encountered less stutter duration (and frequency) with a manual overclock to 3.7GHz/3.8Ghz. Which, for me, is stable after running Prime95 for a few hours, Cinebench, Superposition, Firestrike, etc. In the real world, I ran games such as CS:GO, League of Legends, Overwatch and a Virtual Machine running Linux Mint 19 (I think), with 6 logical CPU's and approximately 4GB RAM along side other tasks such as 15+ Chrome tabs, and other every day applications. During this time temperatures were stable, never exceeding around 40C and VRM temps (to the touch) were warm but never unable to hold my hand on them.

I have tried loosened timings with my G SKill Flare X 3200 CL14, as well as tighter timings. I did this on 3200, 3000, 2933, 2800, etc... The best performance was 3200 XMP profile provided by ASRock.


I don't think it's entirely OS, though. Because it persists with Linux Mint running CS:GO. It could be BIOS firmware/AGESA code.



Try installing HWInfo64 and ensure that it's that core doing it. Sometimes the Windows Task Manager isn't the better at accurately providing what is happening.

If you're able to see the results in HWInfo64, you may also find something else that is taking place during that time.

If you select 'sensors only', and then at the bottom right, there should be an icon that will allow you to save a file that create CSV file. If you save and upload that after you encounter it, I will happily look through it.


My bad, the stutter is in the benchmark as recorded by the devs I watched it on youtube and there is a stutter at the exact same point.

I'm trying to see if I can update my BIOS.


Can you please let me know how the BIOS update goes.

I am away from my computer for a few days and will not be able to do it

until the new year.

I notice in this instance, there's an option to do it via Windows as well

as the regular Instant Flash method. This time I will try the Windows



Be aware flashing via Windows cause i bricked my old Sandy bridge mobo back then, luckly was dual bios


Thank you, I will do the regular flash.

I wasn't sure if maybe there would be some optimisations, but thinking

about it, that doesn't make much sense.


Did a bios update, OC is more stable with less tweaking.

I read 300+ pages from nvidia users with the same issue, guess what.... rolling back to windows 10 1607 was the final solution from their testing, that all new versions of windows since cause shutter.

Is not the windows build in my case, i even try windows 7 and all win 10 version from 1607 to 1809 and i did not solve the stutter at all,i tryed everything i could software related in this year,i will try a b450 motherboard in january to see if is a memory compatibility issue or somenthing else cause at this point i don't have any clue what to do


I've already tried 1607. It wasn't a solution for me.


Tons of variables in this then.
Has everyone gotten their new bios?

Also has AMD voiced some kind of solution like a HW swamp for us?


Not as of yet.

I could possibly do it via Windows AMI updater remotely, as I am away for a

few days, but I am unsure if that's wise.

For the AB350M Pro4, it's reportedly AGESA update. Though, what

that means is unknown.



Yes i tryed every bios for my mobo (msi mortar b350m) but the last 3 bios is kinda of buggy cause they don't let my system restart and i have to shut it down and then power it back otherwise my screen just stay black until i force the shutdown.

My old mobo was the asrock ab350m pro 4 and i had to rma cause of the constant freeze and after my pc stopped posting.


Try this

Search "Device Manager" on your PC.

Scroll down to "System Devices" and open the sub-menu.

Scroll to "High Precision Event Timer" and click it.

Click "Actions" at the top of the window, and from that pop-up menu, click "Disable".

Restart your computer.

Disable HPET, you can always enable it again, restart a few times after disabling it.


I have it disabled in windows and bios already i have done all this stuff before starting replacing part,

edit:i did a few games test and timerbench, in timerbench with the chipset driver stutter like you see in the image but whithout it just microstutter,in the witcher 3 i locked the fps to 60 but look at that frametime then there is ac odissey that in comparison to ac origin it run much better and i think is because the cpu and gpu render time is synchronize as you can see in the image but anyway there is microstutter just less noticeable


Ive found a solution for me, ive been very carefully testing everything.

I found the XMP memory profile to be the cause for shutter for me.
When i had XMP selected, and looked into the timings it was showing 16 for the cas for XMP but only applying 15.
After i fixed this bug, it smoothed out my gameplay.

Additionally, i used Standby memory cleaner.

Intelligent standby list cleaner v1.0.1.0 Released | Wagnardsoft

No more issues, so inspect your XMP profile' for an issue.


Yesterday i found out That my graphics card frequency was fluctuating causing huge stutter, then i clean the card and reapply the thermal paste and now i have Just the microstuttering as before, as for the ram i have manually set the timing as the xmp the same as the voltage and i have already set the empty standby Memory but the microstuttering still occur


I already checked the XMP - mine applies CAS 14 which is what it should. I also use standby memory cleaner and it didn't help. Remember - this happens on multiple OS's.

samulelo​ - I once had troubles with GPU, it was thermal throttling as you described, but even are replacing it, I still encounter the stutters, even with a very cool-running GPU.


Yes but this was happening recently so i figured out that was not the issue i was having so i  solved right away but yet i still have stutter and microstutter depending on the games i play, but most of the time it stutter when loading new asset so i assumed that is either cpu mobo or ram issue probably compatibility issue i guess cause software wise i did everything .

And another thing worth mentioning is that 2 stick of different memory kit i bought died in the same year (1st kit won't be recongnize anymore the second kit instead constantly bluescreen) and now i'm with another replacement kit


loosen up your timings and mess with values out of xmp profile.


I spent a whole week doing it. It didn't resolve the issue.


Dont know what to tell you, I've downgraded my windows 10 to 1607 like the nvidia forum suggested and it corrected my issue.

However, this needs to be corrected in a perfectly stable manner; while 1607 fixes it greatly, it still seems to pop up randomly but to a lesser extent.

Computer Stuttering Randomly (Partially Fixed) - Systems

I already tryed win 1607 even win 7 but the stutter appear Just in games for me no matter wich Windows Build i'm using as i Say All benchmark seems normal but in games the frametime Is very bad when the cpu Is more involved or the games Is less optimized It stutter the most, gpu only benchmark result in a steady frametime with no stuttering at all, i even tryed amd sata driver or without It i even buy an SSD with no result at all.


This is more or less my situation, too.


Is it present in older games?

I was playing BF3/ bf4 and had zero stutter but on newer titles it can occur in a much less noticeable extent as before.
Possibly engine, graphic practices in new software with a negative side effect?


All games.


I am glad you resolved your issue. However, many of us still didn't whilst trying the same steps.


By downgrading to Windows version 1607, you now have a Non-Supported Windows version installed. You won't be getting any more Windows Updates until you upgrade your version to a Supported version.

So downgrading to fix a video issue is that more important than having a Non-support Windows installed?

I agree with this. But it doesn't even matter, because many of us tried it, and it didn't solve the issue.


The problem is still present on my system, it comes and fresh restarts seems to give okay gaming for a few mins before it microshutters. 

I've found more issues then just microstutter; and zero solution. 

Starting to strongly feel this is a complex hardware issue that even their engineers missed.

Going to corporate, AMD community isnt going to provide any acceptable level of company support.