cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Journeyman III
Journeyman III

RX 6800 Black screen/ No signal

Hey guys,

Im the (un)lucky owner of a XFX RX 6800 (No XT)!

If i turn on the PC with the new graphics card, the "RADEON RX 6800 XFX" LEDs light up and the fans start.
The monitor isnt doing a thing. Its just black. The only thing i can trigger is a "No signal" if i plug out and in the Displayport cable. He starts swiching between HDMI and Displayport and turns off after a few times.
So, there are a few things i just tryed to solve it like:

-BIOS upgrade
-Pre installed the newest AMD drivers (Radeon Software)
-Tested other powersupply
-Changing VGA cables from PSU to make sure its not broken
-Testing older Monitor HDMI with same result
-I checked all different HDMI and Displayport slots

If i plug in my Radeon R9 380, it works fine. So the PCI x16 slot isn´t broken. Yesterday, i tried to plug it on an old Gigabyte 990X MB where my R9 works fine too. Nothing happens.

Specs:
BeQuiet Straight Power 11 750W
MSI X570 Gaming Edge Wifi
AMD Ryzen 5 3600X (Corsair AIO water-cooled)
4x Corsair Vengeance PRO 8GB @ 3200 MHz

Would be great if you guys have some ideas.
Greets

0 Kudos
6 Replies
Journeyman III
Journeyman III

Re: RX 6800 Black screen/ No signal

I purchased a new pc recently, when it arrived I have had the same exact problem, no signal displayed but the fans and LEDs work. I have tried everything I can think of to get it going and also have tried other cards in the system and they work. So must be a fault with the card, would like to know if you have had any luck with yours?

0 Kudos
Journeyman III
Journeyman III

Re: RX 6800 Black screen/ No signal

RX 6800 Black screen/ No signal - is a default issue 

0 Kudos
Journeyman III
Journeyman III

Re: RX 6800 Black screen/ No signal

Hi

 

Same here just got a Red Devil RX 6800 LEDs light up but that's it no fans spin or any signal from DP, I tried the card in my old rig, and would you believe it it worked ok starting to wonder if it's the PSU, not enough power.  I have an Aerocool 750w which on paper looks good and powers the RTX2060 currently ok not sure about this big boy GPU any advise or help would be great

0 Kudos
Journeyman III
Journeyman III

Re: RX 6800 Black screen/ No signal

Did you ever fix this?


@Serioussam wrote:

Hey guys,

Im the (un)lucky owner of a XFX RX 6800 (No XT)!

If i turn on the PC with the new graphics card, the "RADEON RX 6800 XFX" LEDs light up and the fans start.
The monitor isnt doing a thing. Its just black. The only thing i can trigger is a "No signal" if i plug out and in the Displayport cable. He starts swiching between HDMI and Displayport and turns off after a few times.
So, there are a few things i just tryed to solve it like:

-BIOS upgrade
-Pre installed the newest AMD drivers (Radeon Software)
-Tested other powersupply
-Changing VGA cables from PSU to make sure its not broken
-Testing older Monitor HDMI with same result
-I checked all different HDMI and Displayport slots

If i plug in my Radeon R9 380, it works fine. So the PCI x16 slot isn´t broken. Yesterday, i tried to plug it on an old Gigabyte 990X MB where my R9 works fine too. Nothing happens.

Specs:
BeQuiet Straight Power 11 750W
MSI X570 Gaming Edge Wifi
AMD Ryzen 5 3600X (Corsair AIO water-cooled)
4x Corsair Vengeance PRO 8GB @ 3200 MHz

Would be great if you guys have some ideas.
Greets


 

0 Kudos
Grandmaster
Grandmaster

Re: RX 6800 Black screen/ No signal

1. do a BIOS upgrade
2. do a CMOS and leave everything auto (no OC or XMP)
3. maybe set correct PCIe slot for main graphics

0 Kudos