Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

7900XTX HDMI out issue to 1080p TV

Been having a strange issue ever since I installed my XFX Merc 310 7900XTX card.  Same HDMI cable & DisplayPort to HDMI adapter were used on my EVGA 3080 FTW3 Ultra with no problems.

TV is an older 46" Samsung 1080P 60Hz 3D TV from 2010 era. I verified in AMD adrenalin as well as windows settings it is in fact outputting at 1080p@60Hz.  TV also confirms this in the setting menu that is what its receiving.  But for whatever reason it's only showing the bottom half of the screen in the top 50% of the TV. 

I tried both the 12/20/2022 Adrenalin Edition 22.12.2  drivers and the newest drivers released today 1/11/2023 Adrenalin Edition 23.1.1 and both have the same issue.

Any ideas?

[EDIT] Additional info:
I did run DDU prior to removing the 3080 and installing the 7900XTX.
Updated BIOS to latest version and loaded setup defaults too.
PC Specs:
Gigabyte X570 Aorus Master
XFX Merc 310 7900XTX
All 4 ports are taken up on the 7900XTX.
DisplayPort > DisplayPort LG 27" 1440P 144Hz monitor
DisplayPort > DVI Acer 24" 1080P 60Hz Monitor
DisplayPort > HDMI Samsung 46" 1080P 60Hz TV (One in question here)
HDMI > HDMI in to an Elgato 4K Capture Card on 2nd PC (Working fine no issues)


29 Replies

the first thing i notice is a thread already existing about this and same statement : coming from a nvidia gpu but didn't "load default settings" in bios , or DDU drivers

this 2 things have to be done before going any further

as i have a 1080p tv next to me i will check if i have the same behaviour with my 7900xtx (mba) and update my response

UPDATE : no problem here , display through hdmi no causing any issue on my tv ... but maybe i don't understand what you'te trying to get, do you try to extend or to duplicate ?


I recently updated my BIOS to the latest version F36 for my Gigabyta X570 Aorus Master. I always Load default settings after a BIOS reflash, same issue.

Prior to shutting my PC down when I took the 3080 out, I rebooted into safe mode, ran the full DDU, shut it down, took out the 3080 and put in the 7900XTX, so that was done.

The display is being extended not duplicated/cloned.


you must do "load setup default" after gpu change too

not sure it will fix your problem , but this has to be done, not just after updating bios, it can eliminate some causes of problems


As stated in previous comment, this was done already. This is not a BIOS issue.

Adept I

I have the 2010-era tv too, how old is yours? Also, your card is mba unlike us.



this one : 32pfl5606h/12

2011 apparently


Mine is a Samsung 46" 3DTV I bought from Best Buy back in 2010.  It's native 1080p @ 60hz

Adept III

Hi! Im so angry!! I have the exact same problem but with 7900 XT i also have a older TV from 2015 Sony KDL 55W807C 1080p. I think it happened when i changed GPU scaling or/and when changing 10 bit to 8 bit and to RGB full range. This i can change with no issue on my rtx 2080 and 1080 TI. Or i get blackscreen. It has driven me mad! I have done everything, nothing works. I can't even disable gpu scaling, it just re-enables itself. Maybe that's why this is happening. Im doing an RMA!

EDIT: i found a weird workaround, but that is not perfect at all, but it works to get fullscreen. Enable intel gpu in bios and multi display in the same options. Then have your TV connected to onboard intel GPU, and then go into intel graphics command center app that you install from Windows store. There you need to custom scale the image, so it fits the screen because it does not. And all is done! BUT, you will get blurry text and image quality will be a little lower because of the same blurry text issue, and also VSR won't work, at least on my TV. I'm RMAing my card, because this workaround is not acceptable.



That's exactly the same problem I'm experiencing.  Unfortunately I'm running a Gigabyte X570 Aorus Master with an AMD 5950X, so I dont have any other onboard GPU options to use as a workaround.

I strongly believe its related to native 1080p resolution. Tvs that has 1920x1080 as native.


Then why xlox has no problem with his 1080p TV?

I was wrong, this is related to 3D Tvs not 1080p, 3 or 4 people have confirmed it when i asked if the screen issue they are having is a 3D Tv, and they said yes! I made a post on this forum you can read it. I found a workaround that allows me for fullscreen 1080p and i can now use my 3D Tv, its not perfect but it works.

I submitted the bug report in the AMD adrenaline app. Hoping to get some traction on this issue from them.


I have the same problem with my 7900 XTX and my video projector benq W1070 1080p on HDMI out.


Just chiming in to say that I too have the issue

GPU: Sapphire 7900XTX Pulse

TV: Samsumg ue32f6400aw

And yes, I should upgrade my TV, but I didn't have this issue with my previous GPU

Adept I

Got my new 7900 XTX (Red Devil) and facing the same problem. It's obvious to me after trying to figure it out myself and by browsing the forums that the problem lies in the drivers and it is related to having a 3D-capable display. Mine is an Optoma HD25e projector. Had 6800 XT before and everything worked flawlessly now my living room home theather is out of order until this gets fixed :o(

My 2 cents to this thread other than just raising my hand to be affected is that I happened to have a HDMI-DP cable lying around - so I can confirm that it's not restricted to the HDMI-IN of the GPU as the problem was present via HDMI-DP cable to the DP-IN port of the GPU as well.

Also the other thread with a "solution" really isn't a solution at least for me, since my projector is still stuck in 3D-mode with reduced brightness and low refresh rate and probably only half the pixels too :s

Hopefully this gets fixed soon since I'd definitely need to change to another card if this doesn't gets fixed in reasonable time.

Please send them this info, that it does not work with 3D Tv's. Bug report with AMD software or through email or both.

So I received an email yesterday from AMD that Adrenalin 23.1.2 was available for download. Clicking the link brought me to the page to do the download.  However, opening the Adrenalin app "check for updates" doesn't see this available as an update. Also if you go to > downloads > drivers > select 7900 > it still shows the latest is 23.1.1.  So i took a shot, downloaded the update from the email link directly, and after rebooting AMD Adrenalin 23.1.2 completely refuses to open.  Tried ending the task several times in task manager, only for it to reopen itself, and be stuck at 5% CPU utilization for the process.  I rebooted it several times, no matter if i double clicked the icon by the systray or right click, still wouldn't open.  I had to uninstall it and go back to 23.1.1.


23.1.2 does not fix this problem. I have all the same on 7900xtx and samsung ps-59d6900. I bug report about the problem and I hope that it will be solved soon.

Journeyman III

same problem here... for me a worke around is to use an AKTIVE DP to HDMI adapter

Adept I


Since I installed the 7900 XTX the display on my video projector is crushed by 50% I can't find the solution, if I plug a screen into the same port the display is normal.

Journeyman III

Hey, I had the same problem with my video projector (Benq W2000) since updating to the 7900 xtx gpu.

I finally found out that it has to do something with 3D able devices/displays. I guess some bug in the amd driver software. When you enable the 3d mode on your projector the picture will change back to normal. But since the brightness is really bad in 3d mode its not really a work around. So I was trying around until i found this:

The work around: If you choose your bugged display (projector) in the amd software you can change the color depth from 10 bpc to 12 or either 8 bpc. This will fix your screen back to normal.

Hopefully this will work for you guys with 3D TV too.

I would be glad if amd fix this bug in an upcoming driver update.


Unfortunately this is just a workaround, and a crappy one at that.  Enabling 3D mode causes random flickering and it also cuts the refresh rate down in half from 60hz to 30hz.  It still needs a fix.


This workaround is NOT using the 3D mode. I just sayed I found out that this driver problem has something to do with 3d Mode.

The workaround is just simply changing the color depth in the amd driver on the display with that bug. You have no flickering and can use 60hz as well.

The only annoying thing is you have to do it every time after restarting your computer or display again and again..Changed from 10bpc to 12bpc display working fine. After restart need to change from 12bpc to 10bpc to fix the bug again.. and so on.

Hope AMD gonna fix that bug soon!


Interesting. I will have to try that when I get home later and will report back with my findings. Thank you.


Adept I

found my tribe ! having the same issue on an lg 42la6130 passive 3d tv.

i tried ddu, cru, changing the windows driver (it's impossible), tried unpluggin and replugging, or custom resolutions, but nothing worked.

my tv worked properly on my old 1070ti, or on the old 4790k integrated gpu, or even on the new 7700x integrated gpu. it's only the 7900 xtx having this issue, and i'm even on my second card and experiencing this (switched from a reference xfx with hotspot issue to a red devil - both are unable to display my tv properly).

i do have a workaround, but it's so annoying to do every time, plus my monitors don't enter standby properly, plus games randomly crash the driver because of this - going to amd adrenaline, starting eyefinity and changing pixel format for the tv display back and forward, and then discarding the eyefinity setup. i'm also experiencing other random crashes or even system crashes because of this.

i've sent 2 bug reports to amd, one of them has a very detailed account and even a recording of my screen while doing my workaround - no reply, and no fixes yet available for this. i shouldn't have to change my tv because a new gpu is incapable of using it - especially when even an integrated gpu has no issues with it.

and using my tv through the integrated hdmi is a no go - for example dead space remake doesn't even know how to go full screen if i do that, plus other games don't even know how to use the proper gpu (pharaoh remake runs horribly)




i installed the new driver (23.4.1) yesterday, and today i was randomly like 'ok let's switch the cable from the mb (which always dispayed the tv correctly) to the gpu'

to my surprise, it's working as it should now. so i think this got fixed, at least for me. can anyone else confirm ?


Thank you @alexc47, I was trying to sell my 7900XTX with the plan to buy a 4080. Thanks to your message I reinstalled it in my PC (after two weeks of sitting in a box) and today it is working beautifully. I'm really happy about the performance. 

Yeah its also working fine for me now with the latest driver update. Looks like they fixed it finally.