Showing results for 
Search instead for 
Did you mean: 

General Discussions

Adept I

Random reboots and BSOD on a full AMD build

Hello, how are you everyone? First of all, I'm sorry if my English is a bit bad, well, I'll tell you what's happening with the hope that you can help me and/or guide me with this.

About 2 weeks ago I built my full AMD PC, since I could finally afford the expenses for the complete change CPU, GPU, MOBO and RAM, I had been coming for a long time with a 4th generation i7 the 4790k, 32GB Ram DDR3 and a GTX 970 (about 5-6 years), but when making the change I have encountered some rather unpleasant inconveniences since the day I built it, and this happens when playing some titles, it should be noted that the system behaves in a stable way while I do basic tasks, that is, when I use it to navigate in windows, youtube, discord, among other things, the pc also has no problems starting with or without XMP activated, the problem comes when playing, the first problem I had was playing METRO EXODUS which caused my pc to restart randomly without showing BSOD, it just turned off and on, which after investigating and trying some things I deduced that it could be a CPU or RAM problem, leaning more towards the latter, which it led me to think first in the XMP profile which was active, I deactivated it and put absolutely all the default parameters and even so it kept restarting after playing for a while, then I configured some XMP, SOC and PBO parameters in general manually, reaching a " stability" (I carried out many tests in different sections before arriving at this) that lasted me approximately 5 days until I tried MONSTER HUNTER WORLD which began to have symptoms similar to those I had with METRO EXODUS except that now there were BSODs and it crashed In less time.

 I will describe the problems presented with the games so far:

METRO EXODUS (Fixed(?)):

  • Random reboot without BSOD
  • In the event viewer errors of "Event ID 41"
  • Game time approx for problems between 15 - 90 min

PUBG (Fixed(?)):

  • Only frozen image, I listened to everything in the background of the game and discord. I had to restart from the button (only happened once, search for solution and maybe disabling all background hardware acceleration helped (still checking))


  • BSOD error for "WHEA", event viewer "Event ID: 46"
  • Freezing without BSOD, only it is solved by rebooting
  • Game time approx for problems between 5 - 60 min

Here are the MINIDUMPS and what I got into BSODs playing MONSTER HUNTER WORLD, along with the manual I found to guide me a bit:

Something should appear in the MCA_STATUS section of the Processor Programming Reference (PPR) for AMD Family 19h Model 01h, Revision B1 Processors manual, volume 2. From what I saw in another thread.

It would help me a lot if you can get some clue or information from the cause here, since I have little knowledge of this.

My System:

  • CPU: AMD Ryzen 5 5600x with Hyper T4 (Cooler)
  • MOBO: ASRock B550m Steel Legend (v2.20)
  • GPU: XFX Speedster SWFT309 Radeon RX 6700 (non XT)
  • RAM: Corsair Vengeance RGB Pro 16GB (2x8) DDR4 3200MHz Cl16
  • PSU: Cooler Master v1000 (80+ Gold)
  • SSD: Crucial MX500
  • O.S: Windows 11 PRO 22H2


  1. I rule out problems with the GPU and PSU as they work perfectly on my old Intel system.
  2. My video card is connected to 2x PCI-E 8pin cables from the PSU.
  3. RAMs are located in slots A2 and B2.



Temps ºC :

  • CPU: 40º - 50º idle / 55º - 65º in game
  • GPU: 30º - 35º idle / 60º - 75º in game 
  • RAM: 30º - 35º idle / 40º - 45º in game

What I have tried so far:

  • Clear CMOS
  • Clean each MOBO slot
  • Different BIOS versions from 2021 onwards
  • Use BIOS v2.20 due to possible problems with agesa in later versions
  • Install drivers downloaded from both AMD and the motherboard manufacturer (ASRock)
  • Install windows 10 and windows 11 clean with all its updates
  • Use DDU (in case it was the video card)
  • Use the "Balanced" and "High Performance" power plan
  • Use a "Balanced" power plan with CPU at 5% min and 95% max
  • Use BIOS settings completely by default
  • Disable SVM and Core Isolation* (testing)
  • Use the PBO section in enabled, disabled and auto
  • Different configurations for XMP profile, auto and manual (different frequencies, timmings,     voltage settings and infinity fabric)
  • Configure SoC voltages manually (Auto - 1v -1.1v - 1.15)
  • Disable fast boot in windows and BIOS
  • Disable MPO
  • Use CMD with "sfc /scannow" and "dism.exe /online /image-cleanup /restorehealth"
  • Check the status of the SDD (O.S) and HDD (Game Library)
  • Check PSU and GPU
  • Memory tests such as memtest86, occt (between 1 and 3 hours), tm5 (12 cycles with the Extreme1@anta777 configuration)  and everything went well without errors.

I feel something is left, but I think there are already mostly listed "possible solutions." Even after all that the problem persists.

Drivers versions used:

  • Chipstet: (Asrock) - (AMD)
  • GPU: Adrenalin 22.10.1 to Adrenalin 22.11.2


The configuration that lasted me 5 days was this:


  • Chipstet: (AMD)
  • GPU: Adrenalin 22.11.2 (AMD)

BIOS v2.50 ASRock B550m:

  • CSM Disabled
  • Enable Secure Boot in Standard profile
  • Check if AMD fTPM is active
  • AMD OC > PBO > Advanced - Motherboard
  • PCI > 4G Decoding: Enable - ReSize BAR: Enable
  • XMP Profile 1 (manual adjustment):

  SoC: 1.15v

  VDDP: 1.15v

  VDDG CDD: 1.05v

  VDDG IOD: 1.05v

  DRAM: 3200MHz

  DRAM: 1.48v or 1.38v (testing - it works both ways)

  Infinity: 1600MHz

  tCL: 16

  tRDCDWR: 18

  tRCDRD: 18

  tRP: 18

  tRAS: 36

  tRC: 56 or auto (75)

(playing with SOC voltages, frequencies and latencies I have seen that the game time lasts more or less depending on these values)

On Windows:

  • Clean installation of Windows 10 or 11
  • Use "CMD - sfc /scannow" and verify file integrity (dism.exe /online /image-cleanup /restorehealth)
  • Install the latest GPU and Chipset drivers
  • Check for Windows updates
  • Go to Devices Manager > System Devices > AMD GPIO Controller > Properties > Power Management > Uncheck all (possible conflict with GPU)
  • Disable MPO (possible conflict with GPU)
  • Check "Core Isolation"


  • Enable "High Performance" power plan
  • Disable Telemetry
  • Remove Windows 11 context menu
  • Component services > Computers > My Computer Properties > Disable DCOM (enabled) (Possible conflict with GPU?)

All without internet connection.

In the background it runs:

  • Vanguard (Riot)
  • MSI Afterburner (for GPU fans with "disable ULPS" marked)
  • Lightshot
  • ModernFlyouts
  • Wallpaper Engine
  • Windows Defender
  • VibranceGUI


At this point I think it could be the RAM or the IMC of my CPU, I don't rule out problems with the MOBO either.

Everything was "stable" until I started playing MONSTER HUNTER WORLD.

Clarify that some of these steps are "solutions" that I found throughout these days to my "possible" problems.

At this point I don't know what to do anymore, I thought I already had it solved, but no. My head hurts just thinking about looking for solutions and that they don't work for me, I'm already pretty frustrated with this.

RMA is not possible on CPU and RAM.

Sorry if it's a lot of text but I need help.

Thank you very much in advance, I will be reading them.

10 Replies
Big Boss

Hi, you seem very knowledgeable so I might not add much to your troubleshooting.

Try to test each stick of ram individually if you have not done so.
I know 8gb is a pain but its just another troubleshooting.

I also had some strange behaviors with ram and found a mitigation with this values:

 tCL: 16

  tRDCDWR: 18

  tRCDRD: 18

  tRP: 18

  tRAS: 40

  tRC: 56

SOC: 1.2 (beware with this)

DRAM voltage: 1.3v (don't set above 1.45v that's overkill)

XMP 3200mhz


My kit is a Corsair Vengeance LPX 16x8Gb DDR 3200 B-Die

The Englishman

Hey thanks for answering.

Now I made the modifications only in the SoC and DRAM voltage, the rest in Auto, tRAS 36 > 40 and tRC 56 > Auto.

I tried to play MHW 50 min and there was no restart, I have to continue testing.


I've been on several different forums with this issue and found a couple of other interesting things.  One article I read was testing a correlation with not only RAM but also with mainly WD storage devices.  They noticed some strange things happening with them as well.  One of the postings stated that they had set all things in the BIOS affecting RAM to AUTO and it seemed to fix the problem.

Just my experience and opinion, I have long been a strong supporter of Corsair RAM and also jumped onto the GSKIL brand.  To be honest, I have had no issues with the GSKIL RAM at all which is fewer than I have had with Corsair going back to DDR2 and 3.. 

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

I am going to try the activated XMP profile and everything in auto, also today I will be able to try 2 kits different from mine, a HyperX and another Teamgroup.

I hope this can work well.

Adept I

I have the same problem as you with my new rx 6650 xt and the ram solution had already been done and it did nothing. My girlfriend has the same card as me and nothing happens to her. and in the event viewer show level critical kernel-power event id 41.

Oh I'm sorry to hear that, the Event ID 41 thing with the Metro Exodus happened to me at first (typing error in the post), although if there is something wrong configured in regards to RAM in the BIOS that error returns , but after the adjustments I made, it didn't happen anymore and now I only have Event ID 46 with the MHW, which is just as annoying.


Check your pcie cables and make sure that the ones going to the card are on different rails unless you have a single large rail.  That used to trip up my aib 6900xt until I discovered it. 

After I replaced that ps with a unit with individual rails for each pcie connector it never happened again.

Thanks for answering

Indeed my card is connected to 2 different PCI-E rails.


I have been searching for a compatibility issue between MOBO and Corsair Venegence RAM you listed.

Corsair doe's not even want to recognize the ASrock boards period.

Here are a couple of things others have done to eliminate this error:

  1. Mess around with VDDG voltages like I did. Turning down VDDG IOD a notch completely eliminated every WHEA.
  2. I solved the WHEA errors increasing VCCIO and VCCSA but you're using AMD so i don't know anything about it.

There appears to be some compatibility issues with certain Ryzen CPU's and Corsair RAM.   See if you can find a friend or someone to loan you a couple of sticks of GSKIL and see if that eliminates the problem.  


Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"


Thanks for answering

I'll be checking the voltages again to see if I can do something, for now I think I can get a couple of HyperX RAM from a friend to see if that's really the problem, I really hope it's that and not the CPU