Showing results for 
Search instead for 
Did you mean: 

General Discussions

Adept III

Help Whanted. MSI 6900XT 16G. LOW FPS.

My System is. MSI 6900XT Graficcard

Desktop. EVGA X299 Dark Bios Version. 1.23

Windows 10 64 bit system buils 19042 (20H2=

CPU.Intel Core 7960X 16 threds.

SSD.Samsung SSD Pro 970 1T Bite.

Power Supply. EVGA 1600 Wats

Memory GSkrill Trident 3200 32 Gb

Problem is LOW FSP after a day or 2, if i delete the Adralina 21.3.1 latest driver on my system, and instal the same one again, it will woork for some time(1 Day) or so, but after a while i have the same issuie LOW FSB, like 30-40 and up to 200, then again down to 30-40 and up again, i thing this is somthing what the driver to do, but what to do now????? Kim Madse. DK EU.

92 Replies

Clockblocker justs runs an OpenCL workload to fool the GPU into thinking it need to run at higher clock all of the time. 
I think it might be worth a try on the RX6900XT .. 
But the addional OpenCL workload might not be enough. 

I do not know. 

I tested it in the past on Vega GPUs and it worked o.k. 


test it. nothing changes. now will go ahead an test the all newest windows update and de newest 21.3.2 and the newest bios for my board. this is the only thing i dont have test right now 

Have you tried using the 21.2.1 drivers? I use those and get great FPS performance on my 6900 XT.


Also, the cause of your low FPS is GPU utilization. It doesn't get fully used and so you have a loss in FPS. I made a thread about this as well.

yes. have testet both drivers. on both directx11 doesnt get more than 40-50fps. 

i konw that is not fully utilized. but dont know why. and why only in directx11.


So even on the 21.2.1 drivers, you get poor performance?

yes. the 3d mark scores are nearly the same. them on the photo above was with 21.3.2 uninstall it with ddu and test 21.3.1 , same expirience. i wait for the amd support (made a ticket) when they cant help me, i will go back to my old card.


I'm still lost here. You keep saying the 21.3.1, and 21.3.2 I'm talking about the driver before that the 21.2.1

oh sry. dont read it correct. Download it and can say more tomorrow. here it is 00:15 now. So dont wanna waste more time in this. 



Same problem, still no clue what is going on, have tryed all you said, after a while the same resoults, CPU 2 is going 100 %, and only CPU core 2.




looking at my processes in proformance graf, CPU is om 100 % on 1 theds, you know I have 16 theds CPU, but on Theds 2 it seems to be on 100 % all the time, maby strenges but overall CPU proformce is only used a 5 % so, I dont think this is the problem, Ram is good, SSD is good, dont know what to try next, but I will like before try DDU again, and see if that CPU thed 2, still is on 100 % after I install driver again, littel lost here, still bad performnce again.

Humm i am still having problems what 3Dmark Firestrike scorre, but it seems that my CPU Nr. 2 Core off 16, 32 theds, is working hard somtimes, and i dont know why, but this can be the problem. Here is a skreenshot. And it is NOT all the time, it get to 100 %, and it is only on core 2, WHAT The F.........., i dont know, somtimes this is there, somtimes NOT.Any idea??????




1. Make sure you have used Task Manager to stop as many programs as possible at start up. 
2. Disable everything  in Adrenalin 2020 20.3.1 WHQL Settings -> General -: Preferences.
3. Make sure Windows 10 Automatic update is pased completetly. You can also disable Windows Update completely.
    Go to  Task manager -> services and properties to disable it.  


You should be able to use Resource Manager to identifiy exactly what processes are running on each CPU core. 
It should tell you what procees are running, provided your are running as administrator.


I Have tryed, but cant see what is runing on CPU 2, there is notthing shown abaut CPU 2, only on CPU 1 and 3, but still CPU 2 High usage.




You can force applications to run on a certain logical processor (i.e. real core or thread)  in Windows using Task Manager to select a running process and then right click and use go to details. Then right click and Set Affinity to run on Core 3. You should be able to see what is running on Core3, if anything is. 


Select RadeonSoftware.exe, set Affinity to CPU3. Open Resource Monitor. 
Open the Adrenalin 2020 20.3.1 GUI/UI. 
Select Gaming. 

Move your mouse and scrollbar and watch almost an entire CPU Core/Thread being used .
On R7 2700X 1 of 16 logical cores is maxed out,  just for that "fancy pants" GUI.
Complained about this before.  Reported it before. Release noted says it was fixed. Back again.

That might be it?

It is hard to find because if you exit the Adrenalin GUI, the process CPU use drops to nothing.

Adept I

Too bad you can't try another motherboard. I think it would be educational, say if you had an am3 or am4 platform lying around. If the issue vanished than you know the issue is in the EVGA firmware or MB. Just a suggestion.


Yess i maby have a old Asus Maximus motherboard to try out.



I can se there is a new BIOS Update to my motherboard, and somthing abaut AMD. I will try now.


i think we have a different problem. i dont have any cpu going high. but today it works perfectly. for my problem, it looks like i have to shut down the pc for a few hours. is was on the last 3 weeks. shut it down yesterday and today it works (nearly) fine. more fps in the most game. so rust runs now on 100fps. even not so great like the first few days with the graphic card. but not unplayable.


Maby, still the same low profoamce again, it goes up and down, some days good some bad, i dont know.

Kim Madsen.


Have you checked your system's file integrity?


tells you do run Windows system checks  and you should always verify game files. 

Something running on one of your CPU cores in the background that you cannot identify using Task Manager/Resource Monitor  is a real concern.
Check what processes you have running at start up. 
Is it a virus or Malware?  
I have used Malwarebytes in the past:

Your Windows installation may simply be so borked that there is nothing you can do to fix it. 
The way to check  is buy a new SSD or at least SSHD, download the latest Windows 10 image and install it from a USB onto the SSD/SSHD. You do not have to but a Windows License key to run that new Windows image. 


my fix was to go back to 21.2.1 driver. now it all works like bevore. good performance in all games. 


Thanks i will try that, you say Adrailna 21.2.1 right????


Yes Adrenalin 2020 21.2.1


Hummm after install Adralina 2020 21.2.1 older version, my computer perform also better again, so maby driver issue somwhere.  





that looks good. it looks like for some people the driver is broken. know other people here the driver works fine.

Even as i say. i dont have cpu peaks. only the 6900xt works poor. but good to know that you even have now a working solution. 

have no time today. but tomorrow i will try the 21.2.3 driver. i think is also should work. only the new 21.3 looks to have problems for us.

The AMD Team is also informed. They have a great support. So hopefully in a few weeks we get a good working driver with the newest features for us. 



I hope too, somthing is wrong whit this driver, i think.



No all the time i allways restasted the PC, then i get new software and so on.




It is quick and easy to check what those FRTC related Registry entries are. 

You can find them as follows: 
In Adrenalin Software select System -> Settings. 
Your GPU will be listed under Hardware. 
Click on the "More Details" down arrow for your GPU. 
Look at: 
2D Driver File Path

An example of what I see is here: 

Open regedit:

Navigate to: 

You should see the following three variables and values set after Adrenalin 2020 21.3.1 or 21.3.2 install: 

KMD_FRTCInitialStatus 1
KMD_FRTEnabled  0
KMD_MaxFrameRateRequested 60



Have tryed cant find it in regedit, i have the path in Adralina, and copy this file, but cant find it in the treee, i think this is just me, i am NOT a computer hacker. Lol.


m close but maby not close engnoth.




You are now on your cd drive. must be on display. you can look for the path in the driver and then expand on display the 0000 as you see in my picture.



Thank you for posting that. 
I have hit the "photo limit" otherwise I would have done it myself. 

Can say, i have the exsakt same problem again, i have tryed to get this solved, but it wont wook for me, this is not a good driver i think, and i dont think i am alone, tryed whit older driver, it was better, buy stil the same LOW FPS in 3DMark Firestrike, not better than my 970 Nvidia, hummm this is bad.

ok thats baad. i stuck with 21.2.1 and this works for me. dont upgrade now until i a newer version that (mby?) works. baad that amd dont cant handle this. ok, the nvidia driver even have problems. but i dont know anything so bad like this. and now 3 weeks ago its still the same. 


I did a clean install this afternoon and when I installed the latest drivers and played BF3 my framerates were pitifull, not much better than my old gtx 1080.  I tried rolling back to the original driver but the amd installer wouldn't let me so I'm on 21.3.1 and my fps came back up near what it used to be but not quite all the way.  From now on I will only buy Nvidia cards....made damned sure that my new laptop had a 3000 series gpu in it.


Yess this is NOT OKAY.


for me the newest update (21.4.1) works good. normal fps. so think they have solved the problem