Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Win11 does'nt like AMD Destiny driver


My laptop runs with Win11 and a Radeon RX640.

The installed driver version was 26.20.14040.0 (2020/03/11).

I checked AMD pages for any update and downloaded the recommended Destiny 22.3.1

Installing worked like a charm and everything was fine.

Then I allowed M$ to search for any updates for OS etc.

A driver update was available. Me - naive - agreeed.

New driver was downloaded and immediately installed.

Then the OS rebooted for a while without notice (I was scared)

After a while the OS recurred.

I checked the update prot and was told that the installation of version 26.20.14040.0 has failed.

A look on device manager: version 26.20.14040.0 is installed.

There are two possibilities:

1) I install Destiny again and check how to not allow M$ unwanted update

2) Let M$ have its will. (but why should I?)

The prob is why my OS downloaded and installed without permission


4 Replies

Please post your laptop's exact Make & Model plus your APU Processor and GPU card installed.

If you have a laptop with a AMD APU Processor you must download the APU Graphics driver and not your GPU card driver.

If you have an Intel APU processor than you must have the latest Intel Graphics & Chipset drivers installed with the latest BIOS Version installed.

Note: If you have Windows 10/11 Pro version you can use Group Policy to prevent Windows Update from installing a Windows driver in the future to prevent the situation you now have.


Like elstaci said and I've had to do this as well.

Windows Home use Registry Editor to block window update form downloading outdated AMD drivers.

Windows Pro use a Group Policy Editor to do the same thing.

We have tried many other options and this is the only one that works.

screenshot - windows updatescreenshot - windows update

Above is windows update protocol

Below shows part of my device manager's listing.

screenshot - device managerscreenshot - device manager

OS is Windows11 prof

I checked the site of AMD for updates and found something new for RX640.

After DL I started the update.

The package asked if I would like to install the latest version of adrenalin.

I said to myself: why not? give it a try.

Update worked as a charm and I could set some parameters.

Then M$ update entered the scene and restored the old version.

Can anyone verify that the adrenalin driver should work?

How to change the GP?

Somehow confused but not desperated.




If you have Windows 11 Pro or higher installed than you can use Group Policy to prevent Windows Update from installing Device drivers.

If you have Windows 11 Home then it is a little bit more complicated but you still can prevent Windows 11 from updating drivers via Windows Update.

This Tens Forum shows the various method to prevent Windows 10 from updating drivers. The method is the same for Windows 11: