Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

RX 5700 XT randomly loses signal when idling or gaming, afterwards it doesnt even load into windows.

I have a RX 5700 XT SAPPHIRE NITRO that I bought in January from a trusted EBAY seller. When the card got here, I repasted and cleaned it, it worked fine until now. This summer I didn't use my pc for about a month and when I turned it on about 4 days ago it randomly lost signal. I thought it went to sleep but it did not show signal no matter how much I clicked my keyboard or moved my mouse, funny though, audio was still audible through speakers. My friend said that he could still hear and see my screen. I rebooted the pc by holding down the power button and to my surprise it didn't show signal, but I could hear the windows start up sound. I had to reboot again and after 2 tries it finally booted up to windows but only lasted about 5 minutes before showing no signal again. Also, sometimes the cards lights don't even turn on, and I have to reseat for the card to work again, but still does the same thing a couple of minutes later. The longest it has lasted was 6 hours whiteout any issues, but I was watching mostly YouTube. I then swapped out the PSU to verify if it was faulty, but the issue still persisted whit another PSU. I then took out the card and placed a RX 570 and it worked completely fine. I am still currently using it because I don't have the patience to deal whit the other card right now. Also, overheating isn't the issue, when gaming my temps didn't reach anything over 75C and the max my CPU reaches is. 70C.

Things I've tried:

Reseating GPU, trying out another PSU, Reseating RAM, trying different drivers, Updating BIOS, Using DDU to do a clean install, using different PCIe power connectors. Disabling HCDP, Undervolting and Underclocking. Using a different PCIe lane.

PC Specs:
CPU: Ryzen 5 5600X


GPU: Sapphire Nitro RX 5700 XT

MOBO: Asrock Steel Legend B450 ATX

PSU: Corsair AX760

Storage: Kingston 220 GB SSD & Seagate FireCuda 2TB External drive




0 Replies