Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

No audio output available, AMD audio driver version not available.


I recognise there is a few people asking about this problem but no apparent solutions so I'll give it a go.

New PC, everything came installed, I have connected my TV to my AMD RX 580 through a HDMI cable and have visual only. I've tried plugging speakers and headphones in via audio jack but nothing appears in audio in.

In my drivers I have AMD high definition audio device (AMD High Definition Audio Bus) which I believe may be for my integrated graphics (Radeon vega 11) if so, nothing for my RX 580. I have disabled the integrated graphics in the BIOS to see if this helped but no luck. I have also tried uninstalling this when I update my drivers and uninstall and restarting the computer.

I have updated drivers (20.4.2), rolled back drivers, installed drivers as old as December 2019 (19.12.3). In the AMD software app details it always lists AMD audio driver version as "not available". 

My PC specifications:

Windows 10 64 bit 1909

AMG Ryzen 3 3200g 

Radeon Vega integrated graphics

AMD RX580 8gb phantom gaming card


TV - 37LG3000 connected via HDMI

Any help would be greatly appreciated

4 Replies
Adept I

If anyone has any experience with this type of issue and doesn’t know a fix but knows if it’s a “it will be parched at some point in the future” or a “it’s a brick, live without audio or buy a new one” type of scenario. I’d love to know which as well.

many thanks


While I can't say for certain what the issue is, I can tell you that this issue has been reported here before. AMD released a new microcode update a few days ago and apparently according to some it fixes issues with polaris audio. If it fixes what you have not sure. Worth trying though. Talk to your motherboard makers support department about your issue. If they don't have an updated bios up for download they may be able to still send you a beta one with the update. Hope this helps. I get it is frustrating.  AGESA is the new microcode.

Keep checking for updates but no luck, no luck with past versions either. As you say it seems like a problem that crops up every now and then.

Thanks for the motherboard support idea, I’ll give that a go. 

They finaaaally fixed it thank god!!!!  I was still using an extremely old AMD radeon version) which was the ONLY one working up to date for surround/audio at all through HDMI.   But the very latest release (21.4.1) finally works again after years of waiting... HDMI audio 7.1 dolby atmos through HDMI  RX470 card.


Do note dolby atmos is now paid?... you have to use a app (if you right click on your mouse button on the audio icon right bottom).

You will see 2 apps mentioned, now trying the trial but before it was free so not totally sure if it will keep working after 14 days.