Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

My graphics won't switch from R7 to R9

Hi everyone,

I own an ASUS N551ZU laptop (i have included the stats below). The laptop comes with a primary AMD Radeon(TM) R7 Graphic linked with a AMD Radeon R9 M280X but recently it won't switch to R9 from R7 while gaming as it is supposed to do. so in a game for example Assassin's Creed: Syndicate when i go to graphics setting section it shows that the game is using R7 instead of R9 so i have 1GB of video memory instead of 4GB and as far as i can remember it always used R9 in the past.

i have tried clean installing the Radeon drivers but it didn't fix the problem and i don't know what else i can do. I'm so frustrated. Does someone know how to fix this problem ?

btw my OS is Windows 10 single language.

thanks in advance


6 Replies

Are these the drivers you are installing? The latest 18.2.1 > APU


yeah it is the exact driver  installed. laptop is plugged in and the game is on high performance in the Radeon setting app but still in game setting it says it is using R7

In Device Manager/display adapter do you have any yellow marks?

Have you rolled back to the previous drivers (that were working correctly) ?

Has Microsoft changed the drivers? Did you take the necessary steps to prevent/delay the automatic installation of drivers?


- no all the display drivers seemed to be working fine no yellow marks

- i tried installing an old driver from Crimson days but that didn’t work out too

- and before clean install i disabled  windows update & turned off automatic driver install

Adept II

Hi! I have this problem makes me mad. I am tired of uninstalling and installing graphic drivers. It also happens in COD WW2. plz some one help us