cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

RPX100
Miniboss

how to stop RX 5700 XT from downclocking?

Energy saving features are great to reduce heat and fan noise for sure.
But they can also lead to stuttering in games, especially while turning the camera.

@Ray_AMD my GPU usage looks like this in less demanding games: [driver 21.9.1]
RX 5700 XT hardware monitor and usageRX 5700 XT hardware monitor and usage

Temps are not shown in this picture, but they were also monitored and stayed
around 50-55°C with fans spinning around at 38%.

I am looking for a way to improve the GPU core and memory clock stability,
without losing the energy saving features. The driver should be able to tell the
difference between desktop use and gaming use, even for older/less demanding games.

Please post some feedback or useful info, if you know how to improve this.
Thank you!

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
11 Replies
Aibisi
Adept I

Hello friend, I am having the same issue with my RX 6600XT for about 2 weeks now and its also driving me insane...

For example, im playing Battlefield 5 or No Man's Sky and it works fine for a bit, but randomly the game starts lagging A LOT and when i check GPU utilization and frequency its jumping between 10% and 60% causing my games to be unplayable... 

The only solution I found to fix this for me is to completely disable Smart Acess Memory, for some reason it only happens when it is ON for me...

I also want to say I have tried basically EVERYTHING, chipset drivers, BIOS updates, GPU drivers, fresh windows install, GPU temperatures are fine, removed all overclocks, power supply is not the issue... 

Setup:
CPU: Ryzen 5 3600

RAM: G.Skill RIPJAWS V 3200Mhz

GPU: AMD Radeon RX 6600XT
Motherboard: Gigabyte B550M DS3H

PSU: Seasonic BRONZE B12 BC-650

@Aibisi I tried to disable Smart Access Memory, but sadly it did not change the downclocking behavior for me.

I did see that other topic though and tried to disable the "deep sleep" features of my card:
RX 5700 XT (deep sleep features disabled via MPT)RX 5700 XT (deep sleep features disabled via MPT)

GPU core clock is now using the minimum core clock that I entered into the P1 power state,
which is indeed very nice and does improve overall game stability a lot for me. Awesome!

Power consumption went up from 11W (10-12W) on idle to 14W ... which is okay I guess.
(core and SoC clocks are more stable now and are using actual minimum values: great!)

@gn07 thank you for posting this information within that other thread - it helped me already.

---
Now I just need to figure out how to prevent that memory downclock, without disabling the
energy saving features for it - because mem clock stuck on 1750 (max) = 33-36W on idle + higher temps.

I want to preserve the energy saving on desktop/idle use, but improve clock stability while gaming.

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes
eccentric
Elite

in registry find your powercfg power plan folders and delete em all! no more power plans.. no more power dropping

also in bios on my x570 board asrock steel legend, theres where you enable PBO or somewhere in bios theres "enabled PCI express power level detection" or some nonsense like that. if you read description it says allows PCI express to lower power levels to devices automatically and its got like "typical idle" or "lower power" or something

i enable enhanced detection or i maybe disable it havent benchmarked either one but removing all power plants and going 'give my stuff power' seemed to work better for me for stability and performance.

0 Likes

@eccentric I do not want to lose the overall power saving features.
I do like the power saving features, if they work like they are intended to.

---
I have not yet found a good way to improve memory clock behavior.
But I did find a way to lock the memory to max clock, by remembering that strange bug.
(multi monitor setup with different resolution/refresh rate)
RX 5700 XT, memory clock locked by multi monitor bug, deep sleep disabledRX 5700 XT, memory clock locked by multi monitor bug, deep sleep disabled

As you can see from the image above, I managed to improve GPU core clock stability,
even though the GPU usage is sometimes as low as 2% (CPU bound game).

Memory clock is now locked to max by using 2 monitors with different resolution.
(I just have to remember to switch to this resolution for these kind of games).

Frametimes are now finally stable and I can play without stutter.

---
@Ray_AMD @Matt_AMD bugreport for driver 21.9.1 - rare green screen crash:
CPU bound games may force rapid GPU memory clock changes (as you can see from the images).
I was able to get rid of these rare green screen crashes by locking my memory clock to max.
(16+ hours of gaming with this locked memory clock, no more stutter, no more crashes)

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes
Anonymous
Not applicable

Instead of the Adrenalin software, I only use the Radeon graphics driver. For this I use the MSI Afterburner, where you can simply force a constant voltage. With FurMark you can test the graphics profiles you have created, with GPU-Z you can compare your manufacturer-specific graphics card data (button Lookup) with the standard setting of the Radeon driver. On my Gigabyte RX5700XT, the standard core clock is 2100 and the boost clock is 2010 (I have set the other clocks too). With our graphics card, it is generally helpful to lower the core voltage from 1185 to 1100. After a graphics crash, the graphics driver restores the default setting. There is a procedure to consider when installing the Radeon graphics driver, look for it in my posts.

0 Likes

@Anonymous I was going to send you a private message just now, but you have them deactivated.
(dear mods, the following message is meant for the user above this post as he does not understand english very well)
The following text is in german and explains the content of this topic:

Hallo Bernd! @Anonymous 

Schön das du deine eigene RX 5700 XT mit meinen Tipps verbessern konntest.
Ich habe in den letzten Wochen etliche Beiträge von dir gesehen, in denen du immer wieder deinen Erfolg beschreibst. Toll!
Scheinbar hattest du wohl vergessen woher diese Tipps ursprünglich mal kamen (siehe dein Thema mit meinen Antworten) ^^

Du hast heute sogar einen dieser Beiträge in eines meiner eigenen Themen gepostet,
obwohl es in diesem Thema um eine ganz andere Problematik geht. Interessant.

Ich glaube dir fällt es weiterhin schwer die englischen Texte mit Google Translator zu übersetzen und zu verstehen,
daher hast du wohl missverstanden worum es in meinem Thema geht,
denn dein Beitrag hatte nichts mit meinem Problem zu tun.

---

kurze Zusammenfassung für dich:
- ältere Spiele mit geringeren grafischen Anforderungen (GPU Auslastung zwischen 2 und 36%)
- oder auch Spiele die sehr CPU-intensiv sind, führen zu massiven Takt-Sprüngen bei GPU Kern, SoC und Speicher

Bei mir hat vor allem das Hoch- und Runtertakten vom Speicher zu gelegentlichen Green-Screen-Abstürzen geführt.
Außerdem hat dieses Verhalten zu Rucklern geführt... und ich wollte eine Lösung dafür suchen.

---

Am Ende hat hier im Forum jemand von "deep sleep" Energiemaßnahmen gesprochen,
allerdings in einem Beitrag zu einer RX 6000 series Grafikkarte und unter Hilfe vom MorePowerTool.

Ich selbst verwende schon sehr lang das MorePowerTool und hatte keine Ahnung das man damit
auch die Energiesparmaßnahmen deaktivieren kann. Das war also in diesem Fall sehr nützlich für mich.

Aktuell konnte ich über Umwege all meine Taktraten stabilisieren und kann nun auch alte Spiele ruckelfrei genießen.

 

Liebe Grüße

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes
gn07
Adept II

I made a post about this for my 6800xt then shortly thereafter found a solution that worked on the internet. I’ve pasted the steps I took in that thread, please check my posts then go to “6800xt downclocking”

0 Likes

@gn07 you could have taken the time to actually read this entire topic, before posting. ^^
Because then you would know that I already mentioned you and linked your topic in my 2nd post.

Thanks again for posting this in the other thread. (linked it again, just in case)

edit: disabling the deep sleep stuff does not help with memory clock fluctuation, sadly.

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes

bumping this topic to confirm my findings regarding memory instability and green screen crashes.

It has been 4 days without any green screen crashes. (driver 21.9.1, S.A.M. enabled)
I achieved this by locking my VRAM clock to max (1748 MHz).
(had to use 2 monitors with different resolution: which results in this behavior)
-> doing this will increase power draw (ASIC) to 36W even on desktop/idle! *sad face*

I still do not know a good way to enable power saving features,
while memory also stays stable under CPU bound use cases.

---
I will most likely update this topic again when driver 21.12.1 is out.

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes

bumping this topic again to confirm my findings yet again:

- Have been able to get rid of micro stutters by disabling GPU deep sleep states
- GPU Core clock will not drop below the 800 MHz (power state 1) value

- I continued to force lock a stable memory clock (1750 MHz) to prevent green screen crashes (only while gaming)
- I can confirm that even driver 22.1.2 still causes the rare green screen crash due to memory clock fluctuations
(took me 5 hours of casual gameplay on CPU bound game to encounter my first green screen since November)
(this crash happened when I did not force lock my memory clock to 1750 MHz and let the driver decide what to do)

(this resulted in memory clock fluctuation and after 5 hours I got the rare green screen crash again)
- these fluctuations can be seen on my screenshots in the posts above and are power saving related (= driver bug!)

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]

@RPX100 thank you for replying at my other post.

I found a solution for get clocks more stable on light applications/games.

1) As you suggested, I used MorePowerTool for deleting DS plans, than I edited and flashed bios with Red Bios Editor and set some power state modifications (I used 500 mhz min not 800 mhz, it seems to be enough). I found this method much better than write only registry with SPPT.

2) I uninstalled Adrenalin with DDU and installed only driver from windows update (driver is older but works the same for me)

3) I installed GPU Tweak III (I am on Asus Mobo) and set the "OC" default profile (a small improvement for me, not too aggressive).

At this moment, clocks are much more stable, monitor doesn't blink, app's windows doen't become black, the power usage is basically the same as before, no green screens or crashes at all.

Of course I have tested just some hours so I can't tell issue is gone forever. By the way I am positive about it. I only think I can have new issues in the future when Windows will update amd driver.

Thank you again.

0 Likes