cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

gn07
Adept II

6800xt Clock speed problems (downclocking)

First post on this forum.

I have a reference 6800xt and I’m having really weird clock speed problems in almost every game. For whatever reason the card will clock down from 2.3ghz to 300mhz randomly and lag out the game. No reason this should be happening, temps aren’t above 65c, power supply is 750watts, and I’m using a 5900x. All I need to do is prevent the card from going below ~2ghz in load during gaming. The built in minimum clock speed doesn’t work, and I can’t find any software to stop this. Completely unacceptable for an 800 dollar graphics card to be performing this way. Help please!

0 Likes
11 Replies
gn07
Adept II

Is there anybody here? I really need some help I’ve tried everything

0 Likes

Depends, could be game specific/low graphics settings.

These cards are meant for high graphics settings where they work best (depending on game/cpu heavy/nv optimized).

Many (name of game) graphics performance tweak guides on the web, though most seem to focus on max fps there are those that offer good graphics/fps options.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 7000s 2tb, Nitro+RX6900XT, RM850, Win.10 Pro..
0 Likes

It’s not game specific it happens in all games, though in Beamng.drive and GTAV it’s almost unplayable. It shouldn’t matter if the game is high enough performance or not it should just work and not stutter. I’ve already tweaked with all my settings and nothing works, I’m two seconds away from sending back this piece of **bleep** and getting a 3080.

0 Likes

Are you living in the EU ?

Lately I also do have this problem and RMA ed my first GPU. 

Now with the new GPU I think I do have still the same issue.

I might have bettered it a bit by downclocking ( see attached file)  my max coreclock, but stutters still occur at least once every 5 minutes while gaming ( not really in benchmarks).aeawd.png

 

0 Likes

I live in North America. Retuning the card isn’t going to fix their software but I appreciate the reply.


I found this solution online, it helps but it’s not a perfect fix.

 

If setting a game-specific and global minimum clock speed doesn't make that clock speed stick (like Unity games did to me in exclusive fullscreen mode), give this a try:
- Download and familiarize yourself with how to use MorePowerTool from Igor's Lab.
- Go into MPT, select your GPU in the drop down, and click "load" and select your GPU's bios
- On the Features tab, click the "Feature Control" button
- Uncheck the 6 or 7 entries, all grouped together, that begin with "DS_"
- Click "Ok", click "Write SPPT", click "Ok" again if it pops up, then click Exit
- Restart your PC
This does NOT edit your bios, instead it writes registry entries (that can be undone with "Delete SPPT", or a driver reinstall). However, you DO need a copy of your vbios for MPT to function properly.
It's dumb that I had to do this for Unity games in exclusive fullscreen to honor the minimum set GPU clock rate that I set in Adrenalin, but it is what it is. I've put a bug report in nearly every driver version since December, but the issue persists.
All this change does is turn off "Deep sleep" (similar to C-states past C3). Your card still downclocks at idle, but won't put CU's to sleep when they're not loaded down.

*edit* I DO want to make it clear that the SUPER aggressive downclocking issue occurs with ANY game that is light on loading up the GPU. The issue I have with unity is the issue above *plus* a manually-set minimum clock rate not being obeyed when the unity game is running in exclusive fullscreen mode.

 

I don’t know what website I got it from but it works somewhat. If you need help preforming it’s just shoot me a reply and I’ll try my best.

Aibisi
Adept I

Hello friend, I am having the same issue with my RX 6600XT for about 2 weeks now and its also driving me insane...

For example, im playing Battlefield 5 or No Man's Sky and it works fine for a bit, but randomly the game starts lagging A LOT and when i check GPU utilization and frequency its jumping between 10% and 60% causing my games to be unplayable... 

The only solution I found to fix this for me is to completely disable Smart Acess Memory.

I also want to say I have tried basically EVERYTHING, chipset drivers, BIOS updates, GPU drivers, fresh install, GPU temperatures are fine, removed all overclocks, power supply is not the issue... 

Setup:
CPU: Ryzen 3600

RAM: G.Skill RIPJAWS V 3200Mhz

GPU: AMD Radeon RX 6600XT
Motherboard: Gigabyte B550M DS3H

PSU: Seasonic BRONZE B12 BC-650

0 Likes

Try out my above post, it worked pretty well for me. Just note that once that’s done you need to set a minimum clock speed in Radeon settings 

0 Likes

So in my case your MorePowertools method seems to work to at least get stable clocks.

I sadly couldn't find any other weirdness in my afterburner sessions, but i will gladly search on the find the cause of my stutters.

Thanks for your insight.

I’m glad it helped. All credit goes to whoever found that solution originally, all I did was copy his post verbatim. If I find the link I’ll post it.

0 Likes

Does the issue look like this: https://www.youtube.com/shorts/1gO3K4hg6x8

I have noticed that when I play long time in Apex Legends, after couple of hours it starts to lag in menu.

This does not seem to happen in-game. Just in menu.

0 Likes

Not sure there is anything wrong (the Apex legends example). It's showing a constant framerate of 39 regardless of what speed the graphics card is running at. I mean they're literally designed to downclock to save power if the load isn't high so that looks like it's actually working properly.

Does it actually lag because that video doesn't show that?

Even if it is lagging, is it possible that it's Apex misbehaving? I've noticed a couple games I play leak memory like a sieve. If you play them for hours you'll check task manager and they're using 12GB of RAM.

0 Likes