cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

angellicious
Elite

High Vram Clock always!!!

Vram clock stuck at 1750 as you can see on idle. Saphire Nitro+ 5700 XT latest driver after a fresh install of windows.

Fix please.

What you see on the picture is Vram Clock Speed at 1750 MHz whenever 240hz are active so theres clearly some issue in the driver since when i lower my refresh rate to 144hz Vram Clock Speed goes to normal values!fffff.png

0 Likes
1 Solution
Matt_AMD
Community Manager

I checked with the product team and their feedback is that depending on specific display configurations (resolution and refresh rate combinations) and background tasks, RX 5000 Series GPUs may maintain memory frequency to ensure an optimal user experience. This behavior is expected and does not impact the RX 5000 GPU in any way.

View solution in original post

156 Replies

to use 30hz in FreeSync your panel has to support LFC - if it doesnt your Games will flicker or sporadicly blackscreen

if you need help than show me your standard settings and i can show you what to set in CRU

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS

AN515-42_100hz_+_FreeSync.jpg

here i OCed my 60Hz IPS without activated FreeSync to 100hz with FreeSync-Range of 35-99

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS

I got blackscreen frames below 50.....(my monitor has the 48-75 range, being OCed by factory and it's why Catalyst drivers force the VRAM @ full clock).

Any solutions to set to 35/37 the lower limit with no LFC support? Impossible?

0 Likes

@hekoone 

no it is not possible with YOUR panel - as each panel is different (even within same model)

like many cant even reach 95hz with aLP156WFC-SPP1 - and my could do 105hz

LFC is needed when going in the sub 40hz range for FreeSync (afaik there is no panel without LFC that can do less than 44hz-75/120/144hz) (so if you have won in the panel lottery you maybe can squeeze 35-75hz FreeSync range out of a non-LFC panel - but this is not common)

currently i use N156HHE-GA1 120hz 3ms TN Panel for my Laptop (replaced the LP156WFC-SPP1)
FreeSync works with 48-120hz // i cant go lower than 48hz because the N156HHE-GA1 doesnt have LFC (or i am to stupid to make it work)

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes

Thanks!

0 Likes

Brother. Thank you! Wish you all the best.

Changed the value fro 33 to 43 and it worked. This bothered me for so long

0 Likes

Normally I don't post but this issue is beyond frustrating.

6700XT on an Xiaomi Mi 34" 144Hz monitor, Vram pegged at around 1985 idle desktop usage.

I'm guessing people are having diffrent experiances with certain monitors and configs because i have tried CRU and tried setting CVT - Reduced Blinking in the Amd software to no avail.

Only way to get the Vram to downclock is to set the refresh rate to 60Hz. 

Idle temps are 50-53C unless at 60Hz then there are comfortable at 40C degrees.

Would love an official fix from Amd and not having to resort to 3rd party software to tinker with this.

For what its worth my previous card an 1080Ti never had this issue using the same monitor.

0 Likes

How is not impacting when we litterally go +15 degrees celsius and +20 watt idle!?

When is AMD willing to fix this?

It's not like 2 (or more) monitor users are the minority.

Same clustercrap happens to iiyama GB3466WQSU (3440x1440) and I didn't had any idea AMD changed something in their drivers to make my life THIS hard. In times of high power bills due to global shortages, it isn't fun to see a GPU unneccessarily consume FOUR TIMES the power of what it should normally draw! **bleep** AMD?

Do you happen to know about the Reset Bug? YES, AGAIN AMD! I bought the first and second Ryzen Gen, I even chose RX5700 over better GeForces, just to support AMD on one hand and don't pay for overpriced electronics. I even thought with the new Adrenalin Center, AMD would do it right for once. I even bought a notebook - well that APU is still good and NOT power-hungry, huh. I even bought a second APU for a small NAS and started to regret when trying to transcode stuff.

Most of my problems (GPU passthrough; reset bug; resolution problems; display problems; 0 RPM fan speed) are mainly caused by AMD and their unwillingness to respect different needs. Now Intel gets back at the top, has better hardware-support and whoever managed to get into transcoding stuff, knows how well QuickSync runs. The "soft skills" of AMD or the meta behind their electronics and technologies is still bad, to say the least.

I'm not even mad anymore - I'm just taking consequences and won't buy AMD again for the next decade. This **bleep** is fixable for sure, but it took me way to much effort an lifetime!

what about relive when the desktop recording is active... there is also a high Vram clock in idle. That sucks like 40-50 watts extra. Without the recording, my computer draws 65 watts from the socket and 115 watts with the recording. This messes up the whole AMD Efficient... isn't that crazy?

Is there a workaround?
B450M PRO-VDH PLUS
Ryzen 3600
RX 6800

 

OFF

2022.06.26-17.20.23.png

ON
2022.06.26-17.21.11.png

2022.06.26-17.25.42.png

2022.06.26-17.51.12.png

2022.06.26-17.51.04.png

  

0 Likes
Pyro_J4ck
Journeyman III

I have this issue as well with a single WQHD monitor at 60hz refresh. It's been present ever since version 20.11.2, and 20.11.1 doesn't exhibit it. I've never had issues with my monitor before, and I've used 3 different graphics cards with it (nvidia 980ti, 1080, and now the amd rx 5700xt). It's the samsung s32d850t which is a 30bit 60hz panel, and it does support the CVT-RB1 or just CVT-RB standard. 

I compared the timings for the monitor between 20.11.1 and the current version 21.2.3, and they're pretty much the same by default. The issue is the drivers consider the v-blanking for the CVT-RB standard to be out of range now even though it shouldn't be (especially for 60hz). I got it to idle again by using CRU to increase the v-blanking by 3 lines (yes 3) which seems silly as this puts it off of the standard timings.

Here's the kicker though, with a custom resolution set through CRU it completely screws up the gamma on my monitor which makes the colors look like crap. I also get random GPU driver crashes with 21.2.3 with a custom res. set, which results in a temporary black screen on occasion. All this after a perfectly stable driver on 20.11.1 (which is almost 5 months old now) is pretty frustrating.

Fix: What I'm doing for now is just use the old 20.11.1 to fix this problem. 

I only have a 29inch 2560x1080 @60hz montitor on my 5600xt, any newer driver than 20.11.1 will stuck vram clock at full speed at idel. since 20.11.1 is not that bad afterall, so I'm not gonna update my driver untill AMD fix this problem. 

Should not be a problem with 60hz monitors.

Disable hardware acceleration in browser used to be one suggestion.

There was also an issue (not widely reported (afaik)) that appeared where having both 'instant replay' and 'record desktop' enabled (not being used) would push vram clock to full. Disable one or the other returns clock to idle states.

Don't recall when it appeared, but it's there on 21.2.1.

Might be worth checking in some cases ?

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 7000s 2tb, Nitro+RX6900XT, RM850, Win.10 Pro..
0 Likes

VRAM clocks stay at load state (1750Mhz) just sitting on the desktop with no active software running. I also have all the recording stuff turned off in adrenalin including all the instant replay and desktop capture stuff. It's clear to me that the issue is tied to the v-blank in the CVT-RB standard timings for my monitor even though it's 60hz.

AMD needs to extend the range of v-blank values that allow proper VRAM idling. Alternatively they need to add a toggle to remove the max VRAM clock fallback in case your monitor needs non-standard timings with a "may cause black screens or flickering" warning. That would help the 120+hz monitor guys more than anything as those monitors usually use non-standard timings to ramp up the v-sync and h-sync.

I tried my monitor on a buddy's system that has a 6900XT, and I saw the same behavior sadly. I think this is the aftermath of the "fix" for intermittent screen blanking issues that were seen on the rx 400/500 series GPUs introduced in 20.11.2; it doesn't seem like a coincidence for sure.

Yea I mean make it an option, I never had blanking issues, guess we all stuck on 6 month old drivers, shame really.

0 Likes

I set my screen refresh rate using CRU from 165 to 155 and I go from 24/7 100% vram clock usage, to %8 idle and very little when watching videos etc.

I say this not as a solution, but as to say how ridiculous that this small change makes such a difference. And that this didn't used to be the case for some people in the past says a lot. I think the engineer who says this is intended, is lazy, and/or didn't understand what the issue is and assumes every person running high refresh rate monitor has a demanding application in the background that justifies utilizing 100% of vram clock all the time... And now I am at 9w idle vs before 30w idle. And my system runs 10c cooler. All for 10 frames/sec difference.

Engineers need to retake a look at this.

I suffered from the problem of black screens, crashes and reboots from November 2019 to November 2020 with the rx5700, I participated in discussions, tried different solutions to problems, changed pc components, nothing helped. Then driver 20.11.2 came out which solved my problem. Starting with this driver, vram frequency is kept around 1750mhz all the time. My display runs at 75hz. As I understand the black screen problems were related to compatibility with some displays with non-standard refresh rate, and the problem was solved by fixing the vram frequency. The high vram frequency does not affect the performance of the pc or the temperatures of my graphics card in any way

0 Likes

That's great for you but I didn't have those issues and now with new drivers I went from a 8 watt idle to a 30+ watt idle with a jump of 20+ celius temp.

If anything on top of that the last couple have been less stable game wise.

That's what we here are all talking about, also running a 75hz screen, does the same when set to 60hz.

I don't like using more wattage then needed, I don't like my GPU hotter while it does nothing.

 

AMD does need to look into this.

0 Likes

If i set refresh rate to 60Hz my vram frequency drops to 200mhz like it was before

0 Likes

Doesn't on all screens.

 

If I hook up my older screen it does, if I use my current better one it does not.

 

AMD does need to figure all this out.

0 Likes

@spardasieg 

and yet again:
your Monitor PANEL does not comply to "LCD Standards" - therefore your GPUs VRAM go into a higher powerstate to maintain 100% stability...

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes

and yet again:  This doesn't happen with drivers from just a couple months ago. My GPU has been stable on drivers that don't do this for months btw, so that makes zero sense for me and many others here.

I can pop in a 1050 ti in the same system and it also doesn't do this.

Which means it's avoidable. Keep posting the same lame excuse though.

0 Likes

I know this is months later, but are you still using driver 20.11.1? I am asking this because I am currently on driver 21.6.1 and am having this issue and idle temps are now at 52 degrees Celsius, instead of being at 32 degrees Celsius which is how it used to be. I’ve tried many newer driver versions and still have this problem. Should I go back to driver 20.11.1, or is there a different solution? 

0 Likes

 

I'm using a 6700xt so some what limited to how far back i can go with drivers sadly.

In my case they have all had this bug, so yeah its still an issue at least for me on the latest drivers currently  21.6.2 of writing.

What i can tell you is i've tried alot of methods to no avail.

My options are running a custom fan curve to keep the temps in check while idle. 

Letting the card idle at 50C + on desktop.

Creating a custom resoloution in adrenaline and setting the timing standard to CVT- Reduced Blanking.

Messing with CRU - did not work for me.

All options are not ideal as longevity of fans now come into play, longevity of the ram if running so hot and when I create a custom resoloution my drivers force my monitor to 6bit.

My advice to you if you don't need the feture set of the latest drivers just stay on a driver that works.

Hope i've been of some help.

 

 

0 Likes

Thanks for the reply and advice! Is there an older driver that you recommend that won’t have this issue? I’ve uninstalled my driver and software using the built in uninstaller a couple of times and have tried different versions of the driver, but I still have the issue. I can’t remember the last driver that doesn’t give this issue. I would also like to mention that I think the temp readings might be incorrect because when I open more applications the temp isn’t affected at all, and even upon the gpu going up in temp while idle, the glass of my pc doesn’t feel any warmer than it was when first booted. Thanks!

0 Likes

Ive complained about it at the end of 2019. Still they didn't fix it and they admit the behavior is normal. Plugging nvidia gpu to the same monitor = downlocking vram, plugging amd to the same monitor = vram at full. 

It's nice to have your vram burning all the time. I wouldn't buy any used AMD GPU after warranty period because of this potential problem. 

sando
Journeyman III

yo man

I have a 5700xt anniversary edition and noticed the VRAM clocks maxed out as well after I updated. Rolling back to 20.4.2 fixed it for me. 

 

I hope that helps

0 Likes

Do you mean you went back to 21.4.2? If not and you mean 20.4.2 then I can’t go that far back in drivers so I won’t be able to try that. Thanks for the help tho.

0 Likes

I would have to be nuts to go back to 20.4.2.

People with newer cards can only roll back drivers so far so that may not be an option. 

Worse yet if rolling back a driver fixes the issue then im going to call amd out on there claim its normal behaviour.

I know we flock to posts more often when theres an issue and there will be people with out this issue but surely amd need to come to the table and at least look into this by the sheer number of posts alone.

 

They've looked at it and made reponsse. AMD Matt or some other amd employee said the behavior is normal and expected. He didn't say it was a bug. Case closed for AMD.

0 Likes

Even if it isn’t a bug and is expected behavior I just find it very strange that my gpu is running 20 degrees Celsius hotter at idle. 

What do you expected to hear from AMD employe? That it's a bug that we don't know how to tackle so you will have to endure it? This is not how todays marketing work, the employee would be fired on the spot. 

I have this same issue with my 6900XT, and from what I have been able to find out, it is an issue between AMD's memory handling framework working in combination with the physical refresh constraints of each panel.

The key features are the panel's Pixel Clock (like a speed limit of each panel for pushing  pixels) and the amount of Blanking used for each refresh.

The Blanking is excess pixels over and above your screen's resolution and was a technical feature of older CRT monitors where the electron beam would start and finish outside the part of the panel you could actually see and work its way down one horizontal line after another and then have to return back to the top to start the next refresh cycle. Blanking is made up of both a horizontal blanking component and a vertical blanking component. VESA specify standard Blanking values to be adopted by the panel manufacturers - called Coordinated Video Timings (CVT).

The Blanking specified by VESA is in either pixels (for horizontal blanking) or lines (vertical blanking) - rather than time. Therefore as panel refresh rates go up the physical time for each Blanking period each refresh cycle gets smaller. As I understand it, AMD's VRAM needs a Blanking period of sufficient time duration (I don't know what this is) to be able to downclock below it's maximum speed. If the Blanking time is too short, the memory won't downclock.

Compounding this issue is the fact the LCD panels don't actually need Blanking and so VESA have introduced Reduced Blanking specifications - CVT-RB and CVT-R2. These reduce the Blanking sizes (pixels and lines) below the the standard CVT Blanking specifications. What I think people are finding is that by using CRU and specifying 'LCD Standard' they are actually increasing the Blanking period from one of the Reduced Blanking timings used, e.g. from CVT-RB (fewer Blankng pixels/lines) back up to CVT (more Blanking pixels/lines). This increased Blanking now allows sufficient time the memory to downclock when idle.

OK you say, but why does it not work for me? This is where the panel's Pixel Clock comes in. As mentioned above, this is your panel's 'speed limit'. A monitor can only push as many pixels as it's maximum Pixel Clock limit will allow. The more pixels per refresh and the higher refresh rate, the higher Pixel Clock needed. 

In order to push higher refresh rates, panel manufacturers can adopt a Reduced Blanking VESA standard as this reduces the total number of pixel's that need to be pushed and allow refresh rates that are under the panel's Pixel Clock maximum limit. However, as we saw above, this reduces the Blanking period time (in micro-seconds) each refresh and it may fall below the time required for the VRAM to down-clock. The issue comes about if you use CRU and opt for the 'LCD Standard', e.g. increases the Blanking period - but this increases the total number of pixels and lines, and to push this increased number of pixels at the refresh rate you want (e.g. 144Hz) results in a required Pixel Clock MHz rate which is above your panel's maximum Pixel Clock MHz specification and therefore pushes your panel out of the manufacturer's rated Pixel Clock specified limit. 

As an example, my panel is an HP Z27n G2 and it's maximum Pixel Clock is only 310MHz (as read off the specification sheet). It can operate at 1440p and 60Hz with standard LCD timings - and hence downclocks the VRAM, but it uses Reduced Blanking timings to squeeze in a 75Hz refresh rate that is still below the 310 MHz maximum Pixel Clock limit. This results in my memory clock constantly running at max speed when at 75Hz as even at only 75Hz, the Reduced Blanking time is too short for my memory to downclock. If I try to use CRU and specify 'LCD standard" Blanking at 75Hz, the Pixel Clock needed would be faster than the 310MHz of my panel.

In order to run at high refresh rates and still have downclocked VRAM, panels need as a high Pixel Clock as possible as this would allow as long a Blanking time as possible (using one of VESA's standards, e.g. CVT) to give sufficient time for the VRAM to downclock.

I trust that the above makes sense and is close to reality, but I apologise for the long post and any technical mistakes I have made. I am just trying to make some sense of what I have found thus far.

 

0 Likes

Thanks!

0 Likes

I am having problems with my RX 6900 XT too. Actually I have connected 2 AOC Agon AG324UX screens to the DP ports.

If a single screen is connected memory clock is dynamic as it should. No matter if I run the screen with AdaptiveSync or without or at which refresh rate between 60 and 144Hz at 4K.

When connecting the second screen the memory clock is nailed up to 2GHz. No matter the resolution or AdaptiveSync status. It can't be a bandwith problem as 2x 4K60 using the same bandwith as 1x 4K120.

I intend to use both screens in 120Hz in desktop mode.

I have also used CRU to check the blankings. 4K144 is configured with 62 lines blanking at 320kHz horizontal and 1331MHz pixel clock. Actually the display reporting 1400MHz pixel clock.

So what I tried is to increase blanking:

4K144: 152
4K120: 128
4K100: 106
4K85: 90
4K75: 78

All staying below 1.4GHz pixel clock.


Unfortunately the problem remains. I have not been able to find any configuration with dynamic memory clocks as soon as 2 screens are connected.

Running driver versoin 22.1.2 currently.

0 Likes

hello my asus monitor mg248qr 144Hz DP and asus rx5700xt rog I have been experiencing hanged memory frequencies 1850MHz at 144Hz for more than a year now, I 120Hz and then everything is fine and the frequencies are reset to a minimum

0 Likes