Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Endless Google Chrome errors related to OpenGL on Ubuntu 20.04

Running the 20.20-1098277 amdgpu-pro drivers on a fresh Ubuntu 20.04 install with Chrome open my syslog has filled up to 8GB, primarily with the following error, often at a rate of dozens per second:

google-chrome.desktop[1887]: [2040:2040:0907/] EGL Driver message (Error) eglGetMscRateANGLE: glXGetMscRateOML failed.

Here's what chrome://gpu/ says: Result

glxinfo | grep OpenGL does, I think, show OpenGL is using the amdpro-gpu driver: Result

I tried the Chrome Beta and Unstable channels and had the same problem.

Is there any way this can be fixed in the drivers, or should I take it to Chromium?

For now I have added --use-gl=desktop to every Exec line in /usr/share/applications/google-chrome.desktop and it seems to have stopped the errors, and performance seems reasonable with large HD videos, but I wonder if it could be better with GL support working properly. I also wonder if everyone else's logs are filling up.


7 Replies
Adept I

I found the slightly newer driver 1109583 here and installed it. Same problem.


Would be really helpful to know your computer information plus Linux version installed including Make & Model of your GPU and CPU and Motherboard.

I would open a thread at one of the premier Linux Websites called Phoronix from here: 

Does your PC have a Windows OS or MACOS installed?


I've had the problem on two machines now (I returned the first one):

  1. Lenovo Flex 5 14" 2-in-1, AMD Ryzen 5 4500U, 81X20005US.
    Fully updated Ubuntu 20.04.1, no dual boot, AMDGPU-PRO 20.20
  2. ASUS VivoBook 14”, AMD Ryzen 5 3500U, X412D.
    Fully updated Ubuntu 20.04.1, no dual boot, AMDGPU-PRO 20.20 and 20.30.
Journeyman III

I have the same issue since I upgraded from Ubuntu stock AMD drivers to amdgpu-pro today (20.20-1098277):

[2656:2656:1018/] EGL Driver message (Error) eglGetMscRateANGLE: glXGetMscRateOML failed.

I get it in Chrome apparently on every render event. google-chrome-stable is 85.0.4183.83-1.

MB is an old Z87 (Gigabyte GA-Z87-D3HP) with Intel i5-4670K, GPU is a newer Gigabyte Gaming OC 8G AMD Radeon RX 5700. Ubuntu 20.04/Windows 10 dual boot.


hi this is happening also with palemoon browser except that it makes it crash I tried using export MOZ_X11_EGL=0 but it didn't help... seems that most browsers prefer the amdgpu open source driver.

Gigabyte 5600xt, Ryzen 2600, ab350 gaming ver1 gigabyte board.

Journeyman III

this is happening with palemoon browser except that it's worse because it crashes, I tried using export MOZ_X11_EGL=0 but it doesn't help.

Gigabyte gaming Ab350 board, Gigabyte Windforce 5600xt, Ryzen 2600, DDR4 16gb RAM 2400mhz.

On focal fossa also.

Adept I

I have the same issue using the amdgpu-pro-20.45-1164792-rhel-8.2 driver on RHEL 8.3.

I'm using the Radeon VII driver for RHEL 8.2 with my Radeon Pro VII, as the RHEL 8.1 driver for the Pro wouldn't build on 8.3.

Launching Chrome with --use-gl=desktop stopped the error spam, but resulted in no WebGL support. Overriding the software rendering list at chrome://flags/#ignore-gpu-blocklist fixes that, but perhaps I will have problems/crashes/insecurity :-(

I think this is likely Google's bug...

Chromium's GetMscRate function in gl_surface_glx actually has a comment "Once glXGetMscRateOML has been found to fail, don't try again, since each failing call may spew an error message."

I think that knowledge may have been lost with the move to the ANGLE library and/or gl_surface_egl.

There's mention of this log spam in a recent ANGLE bug about a failing unit test on ATI/Ubuntu, though I'm not sure if it got fixed as part of that, so I've asked: