cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

greyrain
Journeyman III

Blackscreen after installing RX580

Jump to solution

Hey guys!
It is my first time posting my problem on this forum. (btw I am german, so if my english is as bad as google translate, sry)

I need some help fixing this problem:
I am getting blackscreens after removing my GTX 750ti's driver with DDU ( in safe mode) and installing the AMD drivers for my new Sapphire Pulse RX580 (It is working on my friend's pc)
At first it is working fine with incredible perfomance, but after restart I am getting blackscreens (no signal) when I open things like AMD Radeon settings, a video, youtube (Google Chrome and Explorer). The GPU's fans are going 100% while the blackscreen happens.
I also once got a Radeon error something with "no OpenGL-context for
the format QSurfaceFormat (version 3.0...

Specs:

-Intel Core i7-4770K
-Asus NVIDIA GTX 750TI (old)
-Sapphire Pulse RX580 (new)
-ASRock Z87-Pro3
-24GB RAM 2 x 8192MB and 2 x 4096 all DDR3-1333
-ADATA S650
-a HDD (cant remember which on)
-BeQuiet 600W

I hope someone can help me.

Thank you for reading!

Edit: I tried using the AMD auto detect and install program.

I reinstalled Windows and installed the driver on the clean Windows.

Animations are killing the pc everytime.

I tried to install previous drivers.

1 Solution

Accepted Solutions
greyrain
Journeyman III

Re: Blackscreen after installing RX580

Jump to solution

I did after weeks of researching ...
The problem was that AMD doesn't update all the DLL-files.

So OpenGL couldn't work properly with an outdated DLL

So I updated my onboard graphics card and voila it works !

Thanks to Event Viewer I found this error. 

And thanks to the only helpful thread on the Internet!!!

semillerimages‌ THANK YOU SOOOOOO MUCH

Problems with igdrcl64.dll solved 

Just like you said "Stupid computers"   

View solution in original post

0 Likes
1 Reply
greyrain
Journeyman III

Re: Blackscreen after installing RX580

Jump to solution

I did after weeks of researching ...
The problem was that AMD doesn't update all the DLL-files.

So OpenGL couldn't work properly with an outdated DLL

So I updated my onboard graphics card and voila it works !

Thanks to Event Viewer I found this error. 

And thanks to the only helpful thread on the Internet!!!

semillerimages‌ THANK YOU SOOOOOO MUCH

Problems with igdrcl64.dll solved 

Just like you said "Stupid computers"   

View solution in original post

0 Likes