Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

2024 drivers don't work on Wolfenstein Enemy Territory

Hi all, I'm having issues with AMD gpu drivers >=2023

 22.8.2 or 22-Q4 Pro24.3.1
Wolfenstein: Enemy Territory, ET:Legacy, ETeworksdoesn't work
Overwatchdoesn't work since latest game updateworks

Details on the behavior:

1. ET:L's loading screen is defective:


erronous loading screen with dots.jpg

Those dot's are erroneous 



2. It crashes after ~2 seconds in the game (when rendering the world, correctly by the way).

Or in server browser.

Also it crashes, if you just start it and don't touch anything, but takes a few seconds.


3. Both monitors turn black then, turn on again, ET has been closed silently and the amd gpu driver shows an error:


AMD driver crash error window.png

gpu  driver crashed



Details on software setup:

I've tried the official all 3 ET clients I know:

- Wolfenstein: Enemy Territory 2.60b directly from SplashDamage:

- Enemy Territory: Legacy 32bit windows 2.81.0 and 2.82.1:

- ETe: Windows 32Bit from commit a6274fc

All of them crash (with new drivers), but only ET:Legacy shows the erroneous loading screen.


I've also tried a fresh install of Windows (10 Pro 64bit 22H2)

(messed around with my PC for 17 hours...)


I've been switching between these 2 drivers:

- working for ET: amd-software-pro-edition-22.q4-win10-win11-nov15.exe

- not working for ET: whql-amd-software-adrenalin-edition-24.3.1-win10-win11-mar20-rdna.exe

To perform a switch between those, I've uninstalled it in control panel in safe mode, rebooted, used DisplayDriverUninstaller to remove the remainings (otherwise it doesn't work; also in safe mode) and installed the other version (in normal boot mode). Both directions worked in this way (upgrading and downgrading) and showed the behavior described in the table on top.


Details on hardware setup:

I'm using a Sapphire AMD Radeon RX 5700 XT NITRO+

with a Ryzen 3700X

on a Gigabyte X570 Aorus Elite

with ram: 2x8GB Patriot Viper Steel DDR4-4133 CL19 


I've also reported it in ET:Legacy's issue tracker (issue is here:, but I think due to I was clearly able to reproduce it on a fresh Windows installation and it clearly showed: "old drivers work on my machine but newer ones don't",

this is the correct place to report that issue


It might be related to an error tons of players suffer from: due to it also only occurs with newer driver versions, but in my case it has much worse consequences (game and driver crash)


1 Reply

Hi @rhinocracker,


We were already notified of this issue and our internal team is working on it. We are working on it and hope to resolve the issue soon.