AnsweredAssumed Answered

RX 580 Problem with VDDC

Question asked by lambiselef on Jun 15, 2020
Latest reply on Sep 5, 2020 by lambiselef

I have a problem with a Sapphire RX 580 Nitro+. Voltage states (VDDC) won't apply, at least for State 0. It should be 750mV according to GPU BIOS and AMD Settings Tuning, but it is 950mV.

This situation happened first with Windows 1904 after installing 20.5.1 drivers (been using 20.2.2 with no problems till then). Rolled back to 20.2.2 and problem was fixed, my State 0 voltage went back to 750mV.

Now after upgrading to Windows 2004, whatever drivers I use, 20.5.1, 20.2.2, 19.12.2, my State 0 voltage is 950mV. The max voltage hasn't changed, it is 1150mV as it should be.

I also tried uninstalling and reinstalling Sapphire TRIXX, which I've been using since I bought the card almost 3 years ago to apply a global -96mV to all States, which was stable for me. I was stable at 650mV State 0.

It's also worth mentioning that 950mV isn't registered as any State's voltage.

Any solutions or ideas? Tried AMD Factory Reset option, as well as DDU.

System Description:

  • Sapphire RX 580 Nitro+ 8GB
  • Desktop
  • Windows 10 64 bit 2004 Update
  • Driver version installed
    • 20.5.1, 20.2.2, 19.12.2
  • Display Devices
    • Dell SE 2717H 1920x1080 @75Hz on HDMI
    • Dell SE 2719H 1920x1080 @60Hz on HDMI
  • Motherboard + Bios Revision
    • ASUS X370 Pro, BIOS 5216
  • CPU/APU
    • Ryzen 1600
  • Power Supply Unit  Make, Model & Wattage
    • EVGA B3 650W
  • RAM
    • G.SKill 16GB DDR4 @3133MHz

Outcomes