kquex

[ Solved ] Windows uses gpu copy engine feature causing stutters w/high fps in-game

Discussion created by kquex on May 27, 2020
Latest reply on May 28, 2020 by kquex

Dear community,

 

I have found that stuttering while in-game even with high fps was caused by NT kernel & system ( system.exe )

and this issue was unknown by the people who had this issue and couldn't figure it out but i finally found the cause

and i tried to find a solution for this but it's really hard to stop the system from using the " copy " feature on AMD gpu


so what i'm saying is that even using the official driver from the computer/laptop manufacture it's still the same

even tho i was on windows 7 and i had this issue and i was confused by that time which i didn't know about it before

 

and before this happens, there was absolutely no stutters or anything and it was super smooth until this happend after 20 minutes or something of playing

 

 

The gpu i'm using for gaming is Amd radeon r7 M440

 

And i tried several things and still it didn't work for me :

  • Scanning for a malware
  • Changing the AMD's software Settings
  • Removing the driver completely using AMD's official driver cleaner utility
  • Disabling services that were running in the background ( 34 Services )
  • Removing the latest program i have installed
  • Defraging the hard drive with all the three partitions by many times day by day
  • Disabling superfetch service
  • Optimizing windows 10 using Microsoft's official guide of improving the performance
  • Disabling some features of the intel's i7 cpu
  • And etc....

 

Day Later -

 

Found the solution and it worked for me, i hope this works for some users out there !

 

so what happened is that gpu copy feature is still working but it's not affecting my game and it's using much much lower usage and i have seen much improvement on the performance.

 

here's how !

  • First you have to uninstall your AMD's Display Driver completely using DDU Display Driver Uninstaller Download version 18.0.2.5  ( on the Safe Mode )
  • after uninstalling it on the safe mode restart your computer/laptop and get into the normal boot of your operating system
  • then check for updates and let the windows updates download the driver by it self AND NOT downloading the driver from the manufacturer ( example: amd, hp, etc.. )

 

then yeah the problem got solved for me, and maybe after that try installing the driver from the manufacturer if you really need it but don't know if the issue will start again.

Outcomes