AnsweredAssumed Answered

Aorus 5700 xt crash + black screen

Question asked by evgeny.po on Apr 19, 2020
Latest reply on Jun 6, 2020 by wim-bart

Hi!
Recently I bought the AORUS Radeon RX 5700 XT 8G Since then I cant play without unexpected crashes in game. It happens with random effect, sometimes it just crashes the game for a minute and sometimes it crashes the whole OS or the monitor just loses signal.

I even had a situation when the pc just went "brick" and only pushing power button for 10 seconds helped.
Event viewer says its radeon software crashing but there is not always a saved log of this.
In addition to the black screens and crashes i have artifacts, blinking picture, and fps drops
its been 2 months that im struggling with this problem and nothing helps.

 

 

What I did:

Clean install of Windows 10 (1909) + newest drivers (20.4.1) like 4-5 times already

Tried older drivers (All of them since 19.12.1)

DDU + Install again newer driver (20.4.1)

Updated MB bios (Gigabyte F2 to F7c)

Switched to alternative bios

Switched vBios silent\OC

Replaced PSU 8+8 Pins connector

Removed Gigabyte APP Center (Motherboard applications: fan control, bios update, leds etc.)

Disabled hardware acceleration of the browser

Disabled AMD software settings (anti lag, freesync)

Deleted all games from amd software

Switched DisplayPort mode 1.1/1.2

Tried HDMI Cable

Switched to another pci-e x16 slot

Enabled/Disabled XMP

Reduced clocks manually 1905Mhz, 1100mV and automatic undervolt profile via Amd Software.

Tried gpu utilities Aorus /Msi Afterburner

Watched dozens of "solutions" on YouTube, checked all the forums that i could (English, Russian)

 


My specs:

CPU: Intel Core i7-5820K 3.30 Ghz

MB: GA-X99-Ultra Gaming (rev. 1.0)

RAM: 4x4GB 2133 Mhz (XMP 2400 Mhz)

GPU: AORUS Radeon RX 5700 XT 8G

PSU: Chieftec cft-750-14cs 750W

HD: Intel 660p Series M.2 2280 1TB PCIe NVMe 3.0 x4 3D2, QLC

Monitor: Asus VP28UQG

 

I would point a finger at my PSU but there is one game - kingdom come: deliverance that runs on 2k and ultra settings without a problem for 6-5 hours on 60+ fps so i dont understand, why other more optimized and less buggy games work for few minutes and then we go again with the crashes, flickering pictures, artifact, signal lose?

 

 

Im an IT specialist and I have enough troubleshooting 9 hours a day, then I come home and i have THIS to deal with. Its already 2 months everyday. It seems Im not so good at my profession, I give up amd. you won.

 

But still, can someone provide a few tips?

Thanks!!

 

amd tech support is not answering anymore. their best advice was reinstall the driver.

Outcomes