AnsweredAssumed Answered

RX Vega M GH is detected incorrectly using AMD driver

Question asked by samsam on Apr 5, 2020
Latest reply on Apr 8, 2020 by dipak

I'm referring to my question in the Graphics forum.

 

I have a #RX Vega M GH which is integarated with the Intel Kaby-Lake G.  I tried to use the latest AMD driver (both WHQL 20.2.2 and the Adrenalin 2020 Edition 20.4.1 drivers) and ran any opencl code (tried plaidbench from plaidml and folding@home client), but it hanged the computer.

 

However, when I tried the Intel RX Vega driver, it ran flawlessly.

 

I figured out that using AMD driver, it showed gfx902 on plaidml-setup but using Intel driver, it showed gfx804.  I suspect the RX Vega M is not a truely gfx9 gpu so it can run on gfx8 code flawlessly but on gfx9 code, it hangs.  Can AMD help to adjust the driver or investigate on this issue?  I really want to use the AMD driver to see any better opencl performance on RX Vega M.

 

I have read the following link: https://www.reddit.com/r/Amd/comments/8agcpj/kaby_lake_gs_rx_vega_m_polaris_22/ 

It suggested the RX Vega M should be gfx804 but I don't know why the latest AMD driver shows that it's a gfx902 on plaidml-setup check.

 

Intel is pointing back to use AMD driver here: Download Radeon™ RX Vega M Graphics Driver for Windows® 10 64-bit for NUC8i7HNK, NUC8i7HVK 

 

But apart from the original Intel driver, which is 18.2.2, using the latest AMD 2020 driver always cause the same hang up issue.  I guest it's the same issue as this link: Hang in clFinish on gfx902 (Vega M GH)

 

I haven't tried ROCm as I just have Windows 10 installed.  Does anyone know if ROCm also detect it as gfx902?  Hope AMD can solve the issue soon.

Outcomes