Showing results for 
Search instead for 
Did you mean: 


Journeyman III

RX Vega M GH is detected incorrectly using AMD driver

I'm referring to my question in the Graphics forum.

I have a #RX Vega M GH which is integarated with the Intel Kaby-Lake G.  I tried to use the latest AMD driver (both WHQL 20.2.2 and the Adrenalin 2020 Edition 20.4.1 drivers) and ran any #opencl code (tried plaidbench from plaidml and folding@home client), but it hanged the computer.


However, when I tried the Intel RX Vega driver, it ran flawlessly.


I figured out that using AMD driver, it showed gfx902 on plaidml-setup but using Intel driver, it showed gfx804.  I suspect the RX Vega M is not a truely gfx9 gpu so it can run on gfx8 code flawlessly but on gfx9 code, it hangs.  Can AMD help to adjust the driver or investigate on this issue?  I really want to use the AMD driver to see any better opencl performance on RX Vega M.

I have read the following link: 

It suggested the RX Vega M should be gfx804 but I don't know why the latest AMD driver shows that it's a gfx902 on plaidml-setup check.

Intel is pointing back to use AMD driver here: Download Radeon™ RX Vega M Graphics Driver for Windows® 10 64-bit for NUC8i7HNK, NUC8i7HVK 

But apart from the original Intel driver, which is 18.2.2, using the latest AMD 2020 driver always cause the same hang up issue.  I guest it's the same issue as this link: Hang in clFinish on gfx902 (Vega M GH)

I haven't tried ROCm as I just have Windows 10 installed.  Does anyone know if ROCm also detect it as gfx902?  Hope AMD can solve the issue soon.

3 Replies
Big Boss

Thank you for reporting this and sharing the above useful information. You have been whitelisted.

As I said here Hang in clFinish on gfx902 (Vega M GH) , I've already reported the hang issue to the OpenCL team. At this moment, I'm not sure whether these two issues are related or not. Anyway, I'll pass on the above information to the OpenCL team. By the way, can you please attach the clinfo output for Intel RX Vega driver and AMD Adrenalin driver?

I'm also adding amdmatt and ray_m from our technical support team if they can provide any update/feedback on this issue.

Just for reference, the same issue was reported in the support forum here : RX Vega GH is detected incorrectly using AMD driver 



Here are the clinfo for both Intel (clinfo(inteldrv)) and AMD (clinfo(amddrv)) drivers.

Using Intel RX Vega driver, the driver version is 2766.5 and it detected the device name as gfx804.

Using AMD Adrenalin 2020 Edition 20.2.2, the driver version is 3004.8 and it detected the device name as gfx902.


Thank you for providing the clinfo output files. I'll share these files with the concerned team.  

 Once I get any update on this, I will let you know.