AnsweredAssumed Answered

Spellforce 3 game crash with 5700 XT - DirectX Device lost / hung

Question asked by pajo-san on Nov 27, 2019
Latest reply on Mar 20, 2020 by wandrer

Hi there.

 

There's seems to be a driver issue related to Spellforce 3. There are multiple bug reports in the steam forum from users with 5700 XT graphic cards:

 

5700XT || DXGI_Error_Device_Hung || Spellforce 3 Crashes || Soul Harvest Runs| Needs HOTFIX :: SpellForce 3 Bug Reports 

DirectX errors at start of campaing :: SpellForce 3 Bug Reports 

DirectX Error (DXGI_ERROR_DEVICE_RESET) [Device lost / hung] :: SpellForce 3 Bug Reports 

Fatal DirectX Error :: SpellForce 3 Bug Reports 

 

I myself also run into this issue. I can't play the game. It always says DX device hung / lost. You can reproduce this problem with the game installed, starting the campaign. You only need a 5700 XT graphics card:

SpellForce III - CTD Kampagne - YouTube 

 

After the Youtube video there are multiple popups with the error messages and the game screen is black:

(DXGI_ERROR_DEVICE_HUNG) [Device lost / hung]
(DXGI_ERROR_DEVICE_REMOVED) [Failed to create vertex buffer]

 

My system:

OS: Windows 10 Pro 64-bit (10.0, Build 18362)

CPU: AMD Ryzen 7 3700X 8-Core Processor

MB: ASUS PRIME X470-PRO

RAM: 32 GB G.Skill F4-3200C16-16GTZR

GPU: AMD Radeon RX 5700 XT - Powercolor Red Devil

 

Please fix this bug with an driver update. I already tested multiple driver versions and graphic settings. 

 

Best regards.

Outcomes