drasko

5700 [non xt] game freezes and crashes

Discussion created by drasko on Oct 9, 2019

Everything (Desktop browsing/YouTube) seems to work fine, but when I start the Total War: Warhammer 2 campaign benchmark in DX11 the game keeps constantly freezing - the monitor turns off then back on again I see some artifacts then it return to normal and keeps working for like 30 seconds until it freezes again and cycle continues. If I start the game in DX12 (it gives lower FPS...) the game runs normally for ~5 minutes and then just CTD.

 

My specs:

GPU - Powercolor RX 5700 [non XT] Red Dragon

 

CPU - AMD 3700X

 

MB - MSI B450 Tomahawk max (with latest ABBA BIOS update, V33)

 

PSU - EVGA 650W P2

 

RAM - Kingston HyperX 3600 CL17 (disabled XMP so possible ram errors wouldn't be a problem)

 

Tried 19.9.2 and 19.7.5 GPU drivers.

 

Windows 10 were fully updated, chipset drivers are installed.

 

Additional notes:

Unreal Engine game (The Isle) crashed and gave me an error message stating: "Unreal Engine is exiting due to D3D device being lost (Error: 0x887A0006 - 'HUNG')

Grim Dawn just freezes after 10 to 30 seconds.

Arma 3 crashes after a not so long while.

 

It seems games run longer if I limit the frame rate to 60 (with vsync).

 

I already tried reinstalling Windows, but that did not help (also this is a completely fresh PC build)

Also tried to put the card into the secondary PCIE slot, but that didn't change anything.

I also ran AIDA64 GPU stress test for 10 mins, hotspot reached 86 degrees, memory and VRM stayed below 70 degrees.

 

It seems all these problems are reported before, but AMD is yet to make an official statement, so I'm adding my two cents. 

Outcomes