AnsweredAssumed Answered

RX Vega 64 Clock frequency/Power State bug with 19.2.1/19.2.2 and 19.2.3

Question asked by tonyturbo78 on Feb 26, 2019
Latest reply on Jun 11, 2019 by toasttheoriginal

Hi guys. 

 

Been having this very annoying issue since the 19.2.1 driver a few weeks back which is still present with 19.2.2 and 19.2.3.  THIS BUG DOES NOT HAPPEN ON 19.1.2 AND PRIOR

 

Basically, when running any 3d application, my core and memory clocks are tanking every few seconds then returning to the set frequencies.  On the GPU itself, the LED's on the side go from 8 lights showing to 1 light showing when the drops in frequency happen which would suggest the Power State isn't holding at P7.  Now like I said above, this never happened prior to the 19.2.1 driver, I've had this card since launch day, it's in a custom water loop so temps and throttling is not an issue.  No matter what clock frequency I use for the core or the memory, this sudden drop in frequency happens every few seconds.  It happens when using Power Save, Balanced and Turbo profiles, it also happens whatever custom profile you set.  I've tried dozens of re-installs since 19.2.1 using cleaning tools like DDU, disabling software like AV and overlays, not installing Relive etc but the problem remains.  Rolling back to 19.1.2 driver or older solves this issue.  

 

Here is a little video of the bug AMD Vega64 Driver Bug?? (19.2.1 and onwards) - YouTube 

 

I7 8700K @ 5GHz Watercooled

MSI Gaming 5 Z370 Motherboard

Sapphire RX Vega 64 Watercooled

16GB Teamgroup DDR4 3600mhz 

BenQ XL2730Z 1440p 144hz Freesync monitor

Superflower 1200W PSU

Windows 10PRO 64 bit latest build 1809

Outcomes