12 Replies Latest reply on Apr 14, 2018 12:30 PM by daankvader

    Why is my Radeon R5 unable to update to 18.2.3?

    daankvader

      It is currently on 18.2.1, Radeon settings does not specify which mx series.

      It is integrated, I have A9-9420 aswell.

      I could really use the performance enhancement mentioned in the update notes and any help getting the full enjoyment of my AMD powered notebook is greatly appreciated.

       

      Default update program thinks 18.2.1 is the latest version, I have tried the manual update with 18.2.3 for Windows 10 64bit but oddly the install process finished quicker than usual and sadly Radeon settings indicate that the update never happened, if I tried to do a clean install of the supposed 18.2.3 driver I ended up with some 17.x installed instead after the restart.

       

      I took it a step further and extracted the installer and tried installing by running the executable, this showed an older 17.x version instead of the 18.2.3 that I was looking for. Attempts to run the individual driver setups indicated that the setup was not intended for my version of windows. I tried manually installing the drivers themselves through device manager and Windows indicated the best drivers are already installed.

       

       

      Question time:

      1) What the heck version of Radeon R5 do I have? As far as the compatibility list on the 18.2.3 goes my best guess is the mx200 or mx300 since this is a laptop.

      2) Is 18.2.3 setup for Windows 10 64bit faulty? Should I try the 32 bit?

      3) Is the fact that The automatic/online update search indicating my drivers are already up to date an indication that 18.2.3 is not yet configured for my particular GPU to install? In that case will it ever be?

      4) Why is the manual installation attempt only yielding a much older driver or failing to update at all however claiming that it was successful? I downloaded it directly from the AMD 18.2.3 Full Detail page.