2 Replies Latest reply on Jan 6, 2010 4:45 AM by ols6000@sbcglobal.net

    Don't see symbols from .pdb

    ols6000@sbcglobal.net
      TBP isn't showing symbols even though .pdb path is in Debug File Search Paths. How do I get this to work?

      I am attempting TBP on a .exe under WinXP64. If I use Express mode, I can launch my app and profile successfully.

      What I want to do now is take samples while the pgm is already running. I managed this by using Normal mode and leaving the "Launch" box blank. CA took samples, and displayed the results, but in my app, the symbols are missing ("NO SYMBOL").

      The .pdb file is in the same directory as the .exe. I used the Tools/CodeAnalysst options/Directories tab to add the directory of the .pdb (and .exe) to Debug File Search Paths. The source (all C++) is in a different directory, shown in the Additional Source Dir box.

      How can I get CA to read my symbols for this kind of sampling?

        • Don't see symbols from .pdb

          Hello,

          It sounds like you have done everything right in CodeAnalyst.  When you build your exe, are you generating symbols with /Zi or /ZI? Another thing to check would be are you stripping private symbols during the linking (/PDBSTRIPPED)?

          Did this help?

            • Don't see symbols from .pdb
              ols6000@sbcglobal.net

              This is a release build. I am using /Zi, /GL (enable link-time code generation) in the VS2005 C++ compiler, and /DEBUG in the linker. I am not using /PDBSTRIPPED in the linker.

              If it makes any difference, I am building w/VS2005 on a WinXP32 machine, and moving the .exe and .pdb to a WinXP64 machine.

              It is possible the .exe and .pdb are not from the same build; I will have to check that.