Showing results for 
Search instead for 
Did you mean: 


Journeyman III

WSL 2 / Hyper-V + AMD Ryzen 7 PRO 4750U = BSOD


I've just got myself a new laptop without an OS. I have bought a licence and installed Windows 10, updated to the latest version and installed the latest drivers from AMD.

Lenovo Thinkpad T14s
Processor AMD Ryzen 7 PRO 4750U with Radeon Graphics 1.70 GHz
Installed RAM 32.0 GB (31.2 GB usable)
I can provide additional information if needed.

The problem happens when I try to enable either the Virtual Machine Platform or the Hyper-V feature of Windows. Either one causes BSOD and I've tried looking into the Windows Event logs but didnt' really find anything what might be explaining the issue. Once this happens, I need to fall back to a previous restore point.

Any ideas? This blocks both the Docker Desktop and the WSL 2 from running on my machine.

10 Replies

In BIOS there are a couple of settings that must be enabled for Hyper-V to work correctly.

Microsoft explains how to properly enable Hyper-V in Windows and BIOS plus give troubleshooting tip on various errors:

Make sure you have the latest Non-BETA BIOS installed for your laptop.

This site gives good instructions on what to enable in BIOS to enable Virtualization:

Enabling Virtualization in your PC BIOS

While most recent PCs support hardware virtualization, not all computer vendors enable this feature as shipped from the factory. To turn this feature on, try these instructions based on Red Hat instructions:

  • Reboot your computer
  • Right when the computer is coming up from the black screen, press Delete, Esc, F1, F2, or F4. Each computer manufacturer uses a different key but it may show a brief message at boot telling you which one to press. If you miss it the first time, reboot and try again. It helps to tap the key about twice a second when the computer is coming up. If you are not able to enter the BIOS via this method, consult your computer’s manual.
  • In the BIOS settings, find the configuration items related to the CPU. These can be in under the headings Processor, Chipset, or Northbridge.
  • Enable virtualization; the setting may be called VT-x, AMD-V, SVM, or Vanderpool. Enable Intel VT-d or AMD IOMMU if the options are available.
  • Save your changes and reboot.
  • Delete any existing VMs (Machine > Remove ** and select ** Delete all files) and re-import the .ova file (following step 4 and subsequent steps of the installation instructions).

ZDNET explains how to check to see if your laptop supports Hyper-V:

If Windows 10 is running, you just open the System Information utility.

Type msinfo32 in the search box and then click System Information from the top of the results list.That opens the app shown here, with the System Summary page visible.

Scroll to the very end and look for the four items that begin with Hyper-V. If you see a Yes next to each one, you're ready to enable Hyper-V. If you see a No after the Virtualization Enabled In Firmware setting, you have to go into your BIOS (or UEFI firmware) settings and turn on support for virtualization. If you see a No next to any of the other items, you won't be able to run Hyper-V.

Finally, if in place of these four items you see a message that begins "A hypervisor has been detected..." that means you are already running virtualization software or you're working in a virtual machine.


Hi @elstaci,

Thanks for your answer, but it's not really helpful. I do know how to enable hyper-v, problem is that when I enable it, I get blue screen of death. I have tried upgrading to the latest development version and instead of blue screen of death, it is now restarting over and over again.

Sorry my information wasn't helpful.

Maybe someone else can offer more helpful advice.

Take care.

Journeyman III

I have this same machine and this same issue.  If you are still experiencing the problem, the solution is as simple as it is infuriating.  In the BIOS, under Security->Virtualization, disable 'Enhanced Windows Biometric Security'.   Make sure AMD V(Tm) Technology is enabled, and that's it.  

I suspect that the Windows Biometrics use a Windows hypervisor.  Not that any of this is obvious, but once this was done, I was able to complete a Docker install, and was able to turn on those features without crashing the system.

It does use a hypervisor. That damned feature also prevents VMware Vms to run .


I have the same Lenovo T14 Laptop with the Ryzen 4750U and Windows 10 and I encountered the SAME ISSUE.

Thankfully the suggestion to disable 'Enhanced Windows Biometric Security' in the BIOS worked!


@amd @amd4 @lenovo80mq  @ Lenovo and @AMD... Please update the BIOS so that Fingerprint Scanner can work alongside Windows Subsystem for Linux (WSL 2) &/OR Hyper-V please.!


I have the same problem on my HP Pavilion 15 with Ryzen 7 4700u. But there's no any bimetric or additional virtualization settings in HP "branded" BIOS. I think, this CPU is pretty new, so maybe Windows updates will fix it in nearest future.


It's now the end of May 2022 and I'm having the same issues on my Lenovo AMD Ryzen 7 4800H. Whenever I install Hyper-V I get various errors. Mostly - not always - at "reboot". In the best case, the computer starts after 4 minutes, often only after about 9 minutes and sometimes not at all: Black screen Power LED is on. In the second and third case, I always find a Kernel Power 41 error in the MS event viewer with the information that the computer was shut down unexpectedly and almost always volmgr and VSS errors. If this happens after a Windows update, then the chaos is perfect. Windows then tries to undo the update, which then leads to a "restart" and possibly to a kernel power error again etc. etc. Without Hyper-V, the computer runs wonderfully.
BIOS is up to date and I've tried all possible Windows 11 versions, including the latest beta version (22621.1). The main board was exchanged twice, SSD and HDD once.

What I forgot: Windows then always creates minidumps. If you analyze the dump, the cause of the error is always a DPC_WATCHDOG_VIOLATION (133).

Journeyman III

Hi, I have the same issue with Ryzen 1700 but I fixed it. You guys should disable all HyperV services, WSL and then install Oracle VirtualBox.

Adept I

Just want to update.

On Windows 11 with last updates this issue was resolved for me.