Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Ryzen 7 3700x issues with a ASUS x470 plus gaming MOBO, Monitor says 'no signal'

Aloha all, after searching countless threads and forums and trying everything I can possibly think of I need some help!!

Current build:

  • ASUS TUF X470 plus gaming
  • EVGA 2060 KO Ultra
  • GeIL Super luce RGB 16G DDR4/3000MHz Dual channel memory
  • 600W Standard 80 plus Power Supply
  • CyberpowerPC Asetek 550LC 120mm AIO
  • LG - UltraGear 27" IPS LED FHD G-Sync Compatible Monitor with HDR (DisplayPort, HDMI)
  • (REPLACING) AMD Ryzen 5 1600

I recently purchased a Ryzen 7 3700x for an upgrade.
BIOS is updated to the most recent version 5809. When booting the all fans start up, MOBO rgb turns on, RAM rgb lights up, Display turns on but says:
"no signal"
"an incorrect display version setting will cause the screen to be blank. If this occurs make sure the displayport settings of your monitor matches the device its connected to".

The only change to this build is the CPU swap. I tried a different monitor that is HMDI only, it simply says "no signal".
I Decided to put the 5 1600 CPU back in to double check the BIOS version and reset all BIOS settings to default. Put the 3700x back in, same issue. I've double, triple, and quadruple checked the following:

  • reseating the CPU and GPU
  • checked the 24pin and 8pin connectors
  • reseated the RAM (in the correct channels 2 and 4)
  • checked power and SATA cable for the HDD
  • No bent pins on the CPU or broken pins on the GPU
  • The previous version on my MOBO was 5406, same issue with this version.

I also have an older 1080p VeiwSonic 24in monitor that is HMDI only, tried booting with only this monitor plugged into the GPU, tried booting with only this monitor plugged into the MOBO as well just to see if I can get any screen to display, still says "no signal"

At a complete loss on why I can't get any display. I put the Ryzen 5 1600 back in, BIOS comes up just fine, Windows boots properly. Unfortunately this MOBO has no debug LEDs or speaker. I'm beginning to think this CPU is defective, how common is this?

Thoughts? Suggestions?

Thanks for reading <3

1 Reply
Big Boss

1. flash latest bios
2. reboot
3. go into bios and load defaults
4. shutdown
5. insert new CP
6. do a hard cmos (pin or button) - for 30s-1min
7. boot system

edit - if you are very unlucky your CPU is dead // did you bought it used?

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS