Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Ryzen 5 5600 and MSI B450M Gaming Plus booting sequence

Hello All,
After a  processor upgrade from Ryzen 5 2500X to 5600, it looks like the boot sequence does not allow me to access the BIOS ( there is no initial screen asking to press DEL , it just goes straight to Windows).

Processor: Ryzen 5 5600
MB: MSI B450M Gaming Plus bios 7B87v1G support AGESA (latest version)
Memory: Patriot Viper RGB Black 16GB DDR4 3200MHz CL16

Using the  2500x with the same G version BIOS I get a full correct boot sequence, having the possbility to access the BIOS.
BIOS-ul is compatible with the 5600 according to MSI  ( ).
On the MSI site , amongst the changes made to the BIOS is also:  - Change the default setting of Secure Boot.
I tried searching the BIOS for boot settings and I have the posibility to boot UEFI or Legacy+UEFI (currently selected).
Should I assume that 2500x boots Legacy, and 5600  somehow chooses UEFI ?

I tried accessing the BIOS  by using the Windows sequence: Settings --> Updates & Security --> Recovery ---> Advanced Startup -----> Restart ---> UEFI firmware settings but the computer won't boot up after this kind of restart, it just remains suspended, needing a poweroff and power on. 

Any idea how to access  the BIOS and get rid of the Secure Boot sequence? 
7 Replies

Some monitors doesn't have video output during POST or BIOS until Windows starts loading in UEFI Mode.

The latest BIOS versions for most Motherboards now has a Windows 11 ready type version where it sets BIOS automatically to UEFI mode and other BIOS settings related to Windows 11.

EDIT: Have you tried a different Video output port on the GPU card?  Like using DP instead of HDMI or changed Ports.

Since both of your CPUs are Windows 11 compatible it is possible that BIOS is automatically set in UEFI mode.

I have a LG 4k Monitor that only has video output when Windows starts loading in UEFI Mode. But in CSM Mode (Legacy) I have video output during POST or BIOS.

I just replaced my LG 4k Monitor with a newer LG 4K monitor and the same thing is occurring. But when I temporarily had a Samsung 4k Monitor I did have video output in UEFI Mode but I needed to RMA the Samsung Monitor.

My work around that works for me is to switch my LG 4k Monitor to my Samsung 2k Smart TV which does have video output in POST or BIOS. Thus I am able to enter BIOS and configure the settings.


I have only Windows 10 installed. I tried connecting only the HDMI instead of the DP , but no luck.


I also had the same problem as you do when I had Windows 10 installed. But at that time I was strictly using CSM Mode which I always had video output during POST or BIOS. But as soon as I upgraded to Windows 11 and was forced to configure BIOS to run in UEFI Mode that was when I lost video output from my monitor during POST or BIOS loading.

If you have another Monitor or a TV set try connecting that and see if you get video output during POST.

When I upgraded to Windows 11 I knew I wouldn't have access via my LG 4k Monitor to BIOS but I also knew I would have access via my 2k Samsung Smart TV.

If you computer is booting up normally into Windows with Video Output than it is an issue with your Monitor being compatible with UEFI BIOS Mode.

EDIT: Reread your Original Post you did mentioned the Monitor had video output with the previous older CPU but not with the new CPU.

I am assuming you had BIOS configured in CSM Mode (Legacy). I had my Asus Motherboard BIOS configure with CSM + UEFI Mode.

If you are sure BIOS is using Secure Boot option then you are in UEFI Mode. Secure Boot doesn't work with CSM Mode only in UEFI Mode.

You can try to install your previous CPU and enter BIOS to see if it is set at CSM Mode or UEFI Mode.

Not sure if you have a BIOS Version that configures BIOS to be compatible with Windows 11 if it will do the same thing if you are running Windows 10. I am assuming that it wouldn't but I could be wrong.



That's the issue  , I have only Uefi or CSM+Uefi. I selected the latter for both processors. The 5600 will pick Uefi...


Do you mean that BIOS wouldn't let you switch to CSM Mode that it keep reverting back to UEFI Mode?

Okay I just went to MSI Support for your motherboard and indeed the "Default Settings is Secure Boot".

Can you downgrade the BIOS to the next previous version that doesn't have that new setting:

Screenshot 2023-01-06 163101.png

NOTE: you will need to install your previous 2500x to downgrade the BIOS but then it won't be compatible with your 5600X processor that requires the "1G" BIOS version to work.

I would open a MSI SUPPORT ticket and see if there is a way to run the latest BIOS version without Secure Boot enabled with the new 5600X processor installed.

Possibly MSI made it so that the 5000 series processors will be used only in UEFI mode.

Maybe MSI could send you a BETA BIOS to see if it fixes your problem.

Big Boss

MAbrudan, have you tried hitting Del continuously immediately after power on?

Try pasting this: "Shutdown /r /fw /t 0" without quotes into an Administrative command prompt.

This sounds like a MB problem, so open a service request with your MB vendor. Thanks and enjoy, John.


If I hit DEL continuously the system does not boot. I tried hittng DEL after NUM LOCK is lit.

I tried the command but this error appeared: "The system could not find the environment option that was entered.(203)"