cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Highlighted
Journeyman III
Journeyman III

Ryzen 2950x LAG_0,5 GHz

I need this PC to work as a graphic designer.
It started to go slow. I noticed that processor is at 0,5-0,6 GHz.
I refreshed the bios and reinstalled win10 x64 (from windows, newest)
Installed clean drivers from amd support/

Nothing changed!
It is working for few minutes on 3.5 approximately and then go to 0,52 GHz and stay still. It is impossible to even write this message.
Restart doesnt help at all.
As i am writing this message it is at 0,5 and then suddenly 3,6. Most of the time is 0,52.
Cannot write to support becouse AMD Support service doesnt WORK!

2 Replies
Highlighted
Big Boss
Big Boss

Re: Ryzen 2950x LAG_0,5 GHz

Sorry for your trouble. That indeed sounds like a serious issue. I have had issues getting AMD support to answer at times too. Just to make sure this is the place you were contacting: https://www.amd.com/en/support/contact-email-form  Because if you file the bug reports those are one way and they don't respond. 

If I were you, I would contact the support department of your motherboard. They would be best equipped to help you in diagnosing if you have a cpu or motherboard issue. They would then give you an RMA for your board if they think that is the issue. 

If they think the CPU is the issue you can start the RMA Warranty process on your CPU at AMD. They are usually a bit better about getting back to you but know it often takes many days for them to respond as well. 

If you need to get warranty on the cpu, you can start that process here: https://www.amd.com/en/support/kb/warranty-information/rma-form 

0 Kudos
Highlighted
Big Boss
Big Boss

Re: Ryzen 2950x LAG_0,5 GHz

Not sure but this guy seems to have a very similar problem. You might want to read what he has done to help. He too is looking for a real fix.

https://community.amd.com/thread/257629 

0 Kudos