Showing results for 
Search instead for 
Did you mean: 


Adept II

New Ryzen 3900x x570 random restarts, WHEA-logger error ID17, PCI Express Endpoint, no bsod, no log, no dump

3900x w x570 mobo is crashing, new build, random freeze but (way more frequently) restarts with no events in the evenviewer present before the crash happens. It just looks like someone pushed the restart button. I've read about the WHEA-Logger events in the eventviewer and intdeed it seems to be my 2080Ti is causing some issue with the PCI Express slot.
Whether or not this is the reason why my PC restarts is not definitive tho as I have literally no way of determining which component causes the crash. I have an 850W gold rated EVGA power supply so that should not be an issue. Also I was able to play metro exodus with all the fancy raytracing turned up all the way with no issues whatsoever. Then I just checked the windows app store and it suddenly restarted. I have no clue what to do about it. 

157 Replies
Journeyman III

I'm getting the same issue with the 3900X, but NOT the 3700X which I had for over a week before it. The only difference aside from that is I'm not getting a WHEA error, it's just shutting off randomly.

ASUS Crosshair VIII Hero WiFi

Corsair 4x16gb 3000mhz (CMW64GX4M4C3000C15)

Corsair RMx850w PSU

Corsair H150i AIO cooler

Latest BIOS, latest chipset drivers, PBO off, can't get through 2 hours of AIDA (last time it died the CPU was only hitting 55C).

Adept I

Oh, I'm having the same problem. Tried everything... Eliminated most of the hardware, the only things left are the cpu and the motherboard. So my build is the following.

  • CPU: AMD Ryzen 5 3600X
  • RAM: 2x8G Ballstix 3000MHz
  • Disk: Intel 760p 256GB M.2 and 3.5 WD Blue 1TB HDD
  • VC: GIGABYTE GeForce 2060 Super Windforce OC

I also upgraded to the latest BIOS. If I leave the PC for some time it then might let me use it for a few hours and then just reboots: black screen, no error whatsoever, only WHEA logs and ciritical error in the event viewer saying that it was as if the power went off at some point. And then it may not even let me log into the system, just at the point when the OS is loading it would reboot again and then it's just an infinite restart loop. It's definitely not the PSU, I tested it.

The temps of the CPU are quite normal: 35-50C and peaking up to 76 under stress. The videocard is also cold enough. No idea what to do, I'd appreciate some help.

Adept I

Also experiencing the problem with random reboots. The specs of my builds are as follows (all new parts):

CPU: AMD Ryzen 9 3900X

Motherboard: ASUS TUF GAMING X570-PLUS (Wi-Fi)

RAM: 2 x 16 GB G.Skill Trident Z Neo DDR4 3600MHz

Storage: ADATA XPG SX8200 Pro M.2 NVMe SSD 2TB

Graphics card: ASUS ROG Strix GeForce RTX 2080

PSU: Phanteks PH-P750GS

The system reboots any time between couple minutes and couple hours of using it. After a reboot (no BSOD, just black screen and reboot) in the Event Viewer in Windows I can see "Kernel Power" critical error, with Error ID 41. I used to see WHEA Error ID 17, but not anymore. I'm running latest BIOS (1005 at the time of writing), latest chipset & graphics card drivers (436.15), fully updated Windows 10 version 1903.

So far I've tried replacing the PSU (didn't help) and the graphics card (also didn't help). I've run MemTest86 (full test, no errors) and managed to run Prime95 for couple hours - CPU temp under 100% load was around 75-76 C.

Tried to run the memory at lowest frequency (automatic settings in BIOS, 2133 Mhz) and disabling PBO - same thing, random restarts.

I have returned the motherboard to the store and waiting for a confirmation that it is faulty... otherwise I'll be returning the CPU.

Any suggestions what else I can try appreciated!

Oh, another person with the same motherboard. Please, let me know when you find out which part was faulty.


I have the same motherboard too, and have exactly the same errors. Going back to the shop tomorrow to have an RMA.

CPU: AMD Ryzen 9 3700X

RAM: 2 x 8 GB Patriot Viper Steel CL17 3600 Mhz

Storage: ADATA XPG SX8200 Pro M.2 NVMe SSD 512GB

Graphics card: Zotac 2070 Super

PSU: Seasonic Focus Plus Platinum 850W


Hey beluckydaf‌ and carlcamper‌, my mate got a Ryzen 3900X and an ASRock X570 Taichi motherboard today. We tried all my parts (including my CPU) with his mobo - same issues as before, random restarts, no BSOD.

With his CPU and his motherboard (everything else staying the same), the system was stable, no crashes in situations that would otherwise crash it every time. I'll be returning the CPU to manufacturer in upcoming days.

Best of luck.




So, was it the motherboard? Damn, I'm sick of this... 


No, in my case the problem lies within the CPU - changing the motherboard did not resolve my issue. I'm sending the CPU back to the store tomorrow.


Are you exchanging the CPU or just returning and going a different route? 

If you are exchanging for a new CPU 3900x, I would be interested to know if the new CPU has the same BSODs and random restarts.


So, I was away for a month. In the meantime AMD accepted warranty for the CPU and I got a new one. After installing the new CPU I still had random restarts... Turns out this time they were caused by overclocking memory (to 3600MHz CL16 via D.O.C.P profile) - no restarts anymore when running native speed (2133 MHz).

After this I still had problems with stability of nVidia drivers - in the Event Viewer I could see multiple Warnings with event ID 4101 and a message "Display driver nvlddmkm stopped responding and has successfully recovered". This caused games/3D benchmarks to crash. Turns out something's wrong with one of the sticks of my RAM. I have this issue when running both/the faulty one. Running just non-faulty one fixes the problem...

To confirm this, I've been running my build for last couple days with my friend's RAM (D.O.C.P profile 3200 MHz CL18) and everything works great - no restarts, no nVidia driver crashes. I'm still getting WHEA event ID 17 warnings on boot, but they don't cause me any real issues.

I'm using BIOS version 1005 for the ASUS TUF Gaming X570-Plus WiFi - I tried version 1201 but it didn't fix WHEA 17 errors so no need for me to change right now. I also have changed default settings of "AMD Ryzen Balanced" power plan in Windows to disable "Link State Power Management" (under PCI Express) - this can also be achieved by switching to "AMD Ryzen High Performance" plan.

Hope this helps someone in investigating their issues!

I disabled PBO and xmp in BIOS and I haven't had a restart in three days. I'll try applying the profile again to see if thats the problem. 

Hi Everyone,

Just to update everyone, I changed my Motherboard from ASUS TUF Gaming Plus Wifi to Gigabyte Aorus Pro Gaming Plus Wifi. I no longer got the WHEA errors, but still had random restarts, and a new problem is intermittent Wifi Disconnects. I also couldnt get my XMP profile to stick without memtest errors, except if I typed the timings and voltage manually. I bought new memory (Corsair LP 3600 CL18) 3600Mhz), and those hold the XMP profile without memtest errors, but I still get random restarts. I ran Prime95, and it would stop workers 13 and 14 at small FTT 16K tests. Because of this, I was able tor equest for an RMA of my 3700x. I will be getting it back on Thursday.

In the meantime, I have come across a fix, could anyone try it? The fix is to remove all Front Panel Headers like reset button from the motherboard, as it can short the connection apparently. Only leave the Power button connected.

Got the fix from here: Q3'19 Tech Support Megathread : Amd 

Adept I


I'm facing following issue with WHEA errors with latest BIOS installed with latest available AGESA:

My configuration is Ryzen 7 3800X, MB Gigabyte X470 AORUS ULTRA GAMING and newly Asus 1070 replaced by Gigabyte 1080Ti Extreme. With the 1080Ti I'm not able to bypass 3D Mark and also my only game PUBG crashing due to WHEA issues. Graphics card Gigabyte 1080Ti Extreme has been replaced already with exactly the same result and crashing. I'm running latest BIOS with Agesa ABB, latest nVidia drivers, latest AMD chipset drivers, latest everything and clean Windows installation as well. It's super annoying and driving me crazy and it's not acceptable. Hopefully AMD will fix it it in next Agesa which should mainly fix boost frequencies but who cares as WHEA errors are really serious issues as I see in many discussions and should have TOP priority for AMD!!! Strange is that I didn't had issue with Asus 1070 but with two 1080Ti I have. On top of it I tried all tips, reset BIOS, change PCI-E from Auto to Gen4 to Gen3 to Gen2, underclock infifinity fabric with memory clocks no success at all. PSU is also sufficient with 750W Corsair. Any advice how to temporarily fix is highly appreciated and hopefully AMD & Gigabyte will fix it within coming days!

After more than 20 years this is first time to build so unreliable PC and spend so much time for troubleshooting and waiting for solution. 


Small correction as still have available Asusu 1070 therefore test it and WHEA PCI-E issues are present as well only didn't noticed them as they are not causing crashing of 3D mark and games. Will finally AMD wake up and come with the solution for WHEA or it needs to be again misused by blue team for anti-advert?


I have had the same issue with random restarts and crashes since I built the computer with the 3900x. I have changed motherboard brands (x570 Aurous Master and Crosshair VIII) and both motherboards had the same crashing issue. I've done over four fresh Windows installs, have the latest drivers, bios updates, etc.  I have tried ALL types of settings from Auto to XMP on to PBO off to on to every little thing I could think of. Nothing works.

The odd thing is that this problem only occurs when I am idling or web browsing on the desktop. I can play a video game for hours. Once I go back to the desktop to idle or browse the internet, crashes happen immediately. I literally can only play video games with this PC. If I try to do research (part of my work), I get crashes and random reboots every 5-10 min. 

I am almost at the point where I am going to RMA the CPU and switch over to Intel. It is ridiculous this is happening on a brand new CPU. Especially considering this is not a user error but rather a AMD issue.


In addition, why is this post not viewable in the processor forum postings? I can only find this post from Googling. 

It is like AMD is hiding this issue. I have found countless of other people having this issue from Reddit forums as well. 

Can an AMD rep please respond to this thread? There are 46 replies and no one has found a solution. 


Chill bro  

mine got fixed with bios update + installing the new ryzen chipset driver and power plan. If you have already done that and you are still getting those reboots, I would suggest to try disabling all Google Chrome services(hardware acceleration + Chrome stuff running in the background) as I found out last time that it was the culprit after weeks of trying to figure out the cause of the issue, its worth a try.

btw im running 3900x with MSI Meg ace x570 board with 8gb X4 3200 corsair vengeance pro rgb with xmp on and gtx 1070 as the gpu. I never had any other issues since then and im using my pc for work 12+ hours everyday and gaming after.


I have the latest Bios version, Chipset driver, and power plan. 

I have disabled hardware acceleration. Plus even when Chrome isn't running, I get random restarts and crashes. 

I have done memtests to test the memory. 0 errors.

I have reinstalled windows 10 over 4 times.

I have changed motherboards. Both motherboards had the same crashing and restart issue.

I have changed all types of BIOS settings (Auto Everything, XMP on vs off, PBO on vs off, Fast start on vs off, C state on vs off, altering voltages). 

Nothing fixes this problem.

My old computer with the same Power Supply, GPU,  Memory, and storage has ZERO problems. 

So your "Chill bro" comment comes across as really insensitive. I paid $850 for this upgrade (CPU+motherboard). This is completely unacceptable on AMD's part. They always have horrible launches of their new processors. This is probably the last time I purchase a AMD processor.

In addition, I have emailed AMD and still have not received a response on this problem. Horrible customer service.


Hey, we're all having similar problems here and we all have spent a lot of money and effort. I, personally, as a student was working hard this whole summer to build this PC for over $1000 and it doesn't work properly. In fact, I am unable to find out exactly that it's the motherboard or that it's the processor causing the problem. I am desperate now, feeling like I wasted a lot of time and going to waste much more dealing with these problems.

What the hell, AMD? Guess next time I'll stick with Intel.

Preach. At least when Intel comes out with new CPUs, they are not flooded with problems

Journeyman III

I've been having the same issue. No warning, no error. Just like how one the guys here explained it: "It just looks like someone pushed the restart button" . And I'm not sure if any of you guys noticed that this started when they launched the new AMD Chipset Driver Installation. Before it was just 1 app(AMD Software) in the Windows 10 apps for the AMD Chipset and GPU Driver. And then they made it separate: AMD Software for the GPU and AMD_Chipset_Drivers for the Chipset. And thats when this problem started. Never had this problem before then.

Adept I

Perfect review about WHEA errors which can't be ignored anymore by AMD:


Any update? I am going to respond to this thread every day until we get some traction from AMD to come up with a solution.

Using an AMD 3900x on an ASUS ROG CROSSHAIR VIII HERO (WI-FI), and having similar issues, I just received this response from AMD tech support in my ongoing tech support saga:

"I understand your concern, please be informed Today we have published the following updates regarding 3rd Gen Ryzen boost speed: We have issued a public statement on our Corporate community site, which can be found here: We have also posted a blog on our Gaming community site which contains information about upcoming fixes for the boost and idle behavior, as well as monitoring SDK. The blog post is available here:"

Well, I guess that qualifies as an update - rarely do public corporate announcements magically solve hardware issues though.

Meanwhile, Asus tech helpfully reminded me to provide sufficient cooling in my case.

I guess AMD is now outsourcing alpha-testing to its own customers.

So, thoughts and prayers for now I suppose?

Nothing stated in those posts indicate this will fix our issues.

The August 30th update is to fix our CPU's so that they reach advertised speeds. Also, to smooth out the sporadic jumping of up and down voltages previously seen. There are people out there with the current drivers that do not have the issues we are having. Their computer is stable. The only issue they have is not reaching advertised speeds.

We on the other hand have instability issues. Our computers are not working correctly. AMD needs to respond to this thread and give us some solutions to OUR problems. This isn't some one-off problem. I have seen this EXACT issue across multiple forums. Many of us have ruled out hardware issues (PSU, RAM, Motherboard). This is an AMD issue with our computers just randomly restarting or bsoding.

In addition, I've seen issues similar to this since the 1st Gen Ryzens. If you Google search 'Ryzen crashing on idle" you'll see a bunch of posts of people having similar issues as us with the 1st and 2nd Gen Ryzen CPUs. And guess what AMD has done since then? Nothing!


You're right, of course. Just a bit of sarcasm that did not go over on

my part...

Other than an RMA of my CPU and mobo, I don't see what else I can do.

And that won't even guarantee it will get solved. Because I'm just over

the 30-day return period, I cannot get a refund for any of my parts.

And I work from home freelancing, and get all my work online and need

this machine to run the applications I need - so an RMA would be

massively inconvenient. It's not like I have parts just lying around.

So yes, I couldn't agree more!

disappointedamdcustomer wrote on 9/11/2019 5:45 PM:


Community <>


Re: New Ryzen 3900x x570 random restarts, WHEA-logger error

ID17, PCI Express Endpoint, no bsod, no log, no dump

in /Processors/

Hi disappointedamdcustomer,

Just wondering if something changed in your case and if you are WHEA free now as new ABBA agesa BIOSes are rolling out already for X570 chipset?

I'm on X470 and still waiting for ABBA agesa as a last solution before I will get out 3800X and move out to blue team after 20 years as this is not acceptable anymore.


My crashes are not WHEA related. 

I have updated to the ABBA bios and do not have WHEA errors. However, I still do have the random crashes even after buying new RAM and PSU.

Adept I

Same issue, restarts when idle with the following parts:

  • MSI X570-A PRO ATX AM4 Motherboard
  • AMD Ryzen 7 3700X 3.6 GHz 8-Core Processor
  • G.Skill Ripjaws V Series 16 GB (2 x 8 GB) DDR4-3200 Memory
  • Corsair RMx (2018) 650 W 80+ Gold Certified Fully Modular ATX Power Supply

Will try updating the BIOS tonight, if I never post again it means it worked.


Is your machine set to go to sleep?  That is when mine was restarting and it still does today if I hit start > shutdown > sleep.  I set my machine not to go to sleep to work around it.  Mine was also restarting when the machine was idle which is what clued me into it going to sleep.

No, I disabled the sleep feature already, and several of the reboots happened while I was using the computer and moving the cursor around. I meant "idle" as not using a lot of ressources such as browsing the internet.

Quick update: a week ago I updated my BIOS and the chipset drivers and I made sure the cables going between the PSU and motherboard were tight. Since then I haven't had a random restart. I will reply to this if it starts happening again but so far it looks like that worked.

Adept I

Guys, I am no longer having random crashes.  My restarts that I thought were random were actually when the computer tried to go to sleep.  That is still not solved.  To work around it I set it not to go to sleep.  If I manually tell it to go to sleep to day it restarts immediately.  If you have updated all your drivers/bios (Nvidia or AMD, AMD Chipset, Ryzen Master if installed), and you've tested memory or tried different memory and you are still having issues try installing on a regular SATA SSD and see if you still have the issues if you haven't tried that already instead of nvme drive.  I've seen horror stories of people having issues only to find out when the replaced their nvme drive that appeared to be working correctly all their issues and random restarts went away.


I changed my settings so that the computer does not go to sleep.

The issue arises when the computer is idling on the desktop (with no applications open) or even doing simple tasks like browsing the internet or playing around with Windows settings. So I could see how you would think that it could be a sleep setting issue. But that was one of the first things I changed so that it never goes to sleep.

If I was a guessing man, I think it is an issue with the CPU and how it handles going from high to low state. The CPU cannot handle the low state and crashes. I think it is a driver issue on AMD's part.

Then turn off C-states in the bios so the cpu won't change states maybe it will help. I don't know if I have them on tbh at this point. I think it's a memory controller thing in my case. But I could be wrong.

Journeyman III

Sup guys. 

I’m having the same problem with completely random shut downs or failed posts and boots. 

I’ve ran into the BSOD many times now and physically don’t know what to do now. 

I had an professional IT technician come over to look, he found this forum, and basically told me be believes that there isn’t anything wrong with my computer but the chip it’s self. 

Worse thing is I waited 5 weeks for my chip to arrive and once it did all I’ve had is problems. 

When I eventually get my computer to turn on, after a few boot loops and BSOD the chip is a beast in games, but never freezers or shuts down in game. 

If if anyone could comment back on how they’ve made it better. That would be great. 

Im running;

R9 3900x 

Asus Crossair Hero VIII WiFi 

ASUS strix 2080Ti OC 

64g of Corsair vengeance 3400 

1200watt ASUS rog psu 

thank you and hope hope we can sort this. 

I have a Strix 570-e and still have problems with post once in a while when turning it in.  I think my code is like b8 or something.  I just hit the reset button and it boots normally usually.

Adept III

ASUS x570 Prime Pro/3600 here, for me this was resolved by (on ABB):

  • Ensuring windows was fully updated
  • Setting Bios to default, besides DOCP
  • Installing latest chipset driver from AMD website, not ASUS (I see alot of ASUS boards here, try using the driver from AMD)
  • Ensuring windows power settings was on the 'Ryzen Performance' Profile

After doing this event viewer was clear of WHEA and several other errors.  I am still seeing some but in general I am stable.

From talking to a ton of new 5700/Zen 2 owners, I've learned the biggest difference between people who are having problems with new AMD hardware and those who aren't is driver and windows update install order.  People who are really careful with how they install/update drivers and software seem to be having the best experience.  Before any RMA I would try to start over with a fresh bios flash and 1903 install and carefully apply each piece of software/driver in the correct order.  Here is an install order recommend to me by a reddit user u/idontknowu1 for his x570/5700 build.


"So, I am pretty anal when it comes to these things so I can tell you exactly what I installed and what order. I installed the BIOS update first via thumbdrive using the UEFI updater, installed Windows 1903, ran Windows update and got all the patches and let it install Asus Crate when prompted so I could do Aura sync, reboot, installed the latest AMD chipset driver from AMD's site, reboot, the latest Radeon drivers (19.8.1 at the time), reboot, and the LAN and Audio drivers from the Asus download site for the board, reboot. I installed the Razer Synapse 3.0 and Ryzen Master software last and then started gaming. The only thing I have messed with in Radeon settings is VSR turned on. My BIOS is stock except using DOCP."

I have a x470 board (flashed to latest bios and set to default), ryzen 1700x, 16g ram at 2400 (set to 2133 by default), an m.1 ssd (250 g's) and a rx580 with 19.9.1 (sept 10). I have been getting random restarts several times a day everyday for nearly a week. I have an older pc I pulled out of the closet and set up. Installed the same OS (win64 home) and a few hours later I get hit with the same random restart. Hell, I even tried with an older monitor and it's own DP cable. Didn't matter...the only common threads between the two computers were the OS and drivers. What could this be and is there a way to fix it?? 


Hi, apart from the same problems everyone has here, when I run memtest, I get errors from the first 6 threads, none from the other 6 threads. It happens only when I run in parallel and if I run on a single thread, even one of those 6, I don't get the errors. I tried several RAM sticks.