Showing results for 
Search instead for 
Did you mean: 


Adept I

5600X MSI B550 Tomahawk NO Post dual channel Memory

As the title say I can not achieve post with my memory configured in dual channel only in single channel

Specs :

AMD 5600x

Corsair Vengenace RGB PRO 2x8(16gb)

Nvidia GeForce Rtx 3080

I have sent my motherboard out twice for Rma to MSI, i am starting to think it is somehow an issue with my 5600X

i have tested both Ram sticks seperatly and even tried a different set of thermaltake toughram the system only posts in single channel.

does anyone have any ideas?

4 Replies
Adept III

Did you update your motherboards BIOS to the version that supports ryzen 5000 series cpu's?


Sorry I should have said, the system was working fine for since release. I tried to update the bios and bricked the motherboard somehow following the bios update steps. I sent the motherboard in to be unbricked, they sent it back with the newest bios. After putting it back together the system wouldn't post in dual channel memory only single channel. I sent it back in, and they replaced the board. The new board came with the latest bios on it. However the system still won't post in dual channel. I have tested both sticks of ram separately, both are functioning. Which leads me to think the processor is at fault. Is there a way to test or verify before I attempt an RMA?


Did you check that your RAM is on your motherboards QVL compatibility list? Did you buy the RAM separately or as a dual set?


It was a 16gb kit, it is on the qvl list