Showing results for 
Search instead for 
Did you mean: 


Journeyman III

3950X Pcie Lane bug

Hello .

I Have a Ryzen 3950x whit a Crosshair viii Hero X570.

I have a 5700Xt and it's impossible to got the video car in PCIE 4.0 16x.

The Car work only in pcie 4.0 8x ( The card is ine the first slot )

I try DIfferent Bios . i have 2 NVME SSD Sabrent 1tb pice 4.0 

but i am supposed to have enough lane for my video card.

in the bios it show and it set to pcie_1 16x but it show pcie Native 8X.

i clear CMOS , update bios , 

I RMA 3 Motherboard and the problem still.

Is it possible the CPU is defect?

How can i check ?.


6 Replies

Do you have any other cards installed?


No Other card installed.

Only card installed is the 5700XT .


For testing sake. Change the slot to PCIe 3.0 in the bios and see if that changes things. If it does I would suspect it is an issue with the board. If it does not then I suspect the card has an issue. 

Just because you went through several boards doesn't mean the board can't have a bios bug affecting all of them. The GPUs pcb traces maybe have an issue. 

You could try that GPU in another board if you know someone with PCIe 4.

I don't suspect the CPU in this case, but not saying impossible, as PCIe 4 on x570 is controlled by the chipset. Unlike b550 where it is CPU controlled. 


Hello . 

I alerady put the card in another slot and set pcie to 3.0 .

on the second slot on the 3 MB i try the card run at 4x native.

i put the VGA on another systeme pcie 3.0 and the card run at pcie 16x 3.0 whitout issue.

i try all the Asus C8H Bios and nothing change .

Even GPUZ show PCIE 4.0 8x but can run at PCIE 4.0 16X.

i really don't know ..


Well it doesn't sound like a card issue then. If you have been through 3 boards and that hasn't fixed it, you may just have a defective cpu. I really think based on what you have already tried it is as good a bet as anything. I don't know if you have a board that allows bios regression. You could try an earlier bios if possible. I assume you are on the latest bios and chipset driver? A new chipset driver came out about a week ago. It also can't hurt to run all this past your motherboards support department again too, and see if they think it is time to try another CPU or if they have any ideas for the board still. 

You can request an RMA on the CPU from AMD here: 


Hello .

I will try to RMA the CPU cause i really think the problem is there .

i tre Bios since 1302, and all the driver are up to date .

i wait the AMD answer and come back .

Thanks for your help