Showing results for 
Search instead for 
Did you mean: 


Adept I

Issues with access violations

Hey there folks I dunno if anyone has any ideas I'm really hoping this is software but at the same time I'm pretty much out of ideas as I've talked on other forums, and to AMD's support as well but I don't know what to do here. I'm so tired of doing tech support right now I have the biggest headache over it. So my old PC I was not ready to replace but it died and it HAD to be replaced, so I built a new one out of savings trying not to cut too many corners but leave room to upgrade. This new PC is pretty great... when it works right, and that's the problem, it's not. I'll see if I can remember everything I've done but I've had it about a month so I've been fighting with quite a bit, there's too many things to forget!

This new machine has the following stuff:

Asus x370-A Prime motherboard, newest bios

Ryzen 1800x

Corsair RAM DDR4 16 gb (2x 8gb sticks) 2666 Mhz (I'd have to look up the model, but it's on QVL)

EVGA Geforce GTX 1060 6gb

Crucial 250gb SSD M.2


Corsair CX650M PSU (650w)

So I'm grasping at straws for what's wrong. This PC in general is usually working fine, however it's the intensive programs like games that are the issue. I'm guessing 0xc0000005 general protection fault crashes (regular crashes, not BSOD level) frequently .While my older stuff is generally fine, the newer stuff is not. Star Trek 's never crashed it, Guild Wars 2.... I was saying it hadn't but it just did a little ago, Warframe, Batman Arkham Knight (which is already a terrible PC port) and Deus Ex Mankind Divided however do it frequently. In Batman's case the game won't stay running longer than 5 minutes in most cases, Deus Ex is random, sometimes it works for a while, sometimes it's a 5 min thing (I think it crashes on autosave, and actually that might be the case on Batman also, but not sure why.) Honestly as far as Batman goes, I'd like to play it but I know that's such a bad PC port there's plenty of people that have still never gotten it to work right.

I'm just stumped to what's doing this. I've ran benchmarks that don't fail. I've ran Memtest86 and the windows memory test which don't find anything wrong with the memory. I've done the usual sfc/dism/chkdsk to no avail. I've had probably 5-8 driver versions of Nvidia's drivers in here (honestly if it's a software thing I fully suspect them as the QA on their drivers has gotten more than a little terrible in recent years) as for the Nvidia drivers I did use DDU to blow those out in numerous cases, I'm quite familiar with that tool. As for other general drivers as far as I know, they should be up to date I installed stuff fresh from the company sites when I built this in just the last month. I'd done quite a bit with the video driver too, I often suspect Nvidia quite a bit these days. I had tried various builds, I'd tried installing the driver only without the extras especially PhysX, but no dice. Oh, and it's not overheating, either, not even close.

As for the RAM, it's in the recommended slots on the motherboard, I've also tried one stick, I've tried juggling them, it doesn't matter the crashes persist. I also didn't have DOCP turned on when I originally made this yet, so it ran at 2133mhz for over a week fine, and I've got DOCP now, running it at it's full expected 2666Mhz but it makes no difference, the errors still occur.

I'm also aware of the Ryzen batches that had the segmentation faulting issue that was mostly seen on Linux, I already contacted AMD's support though and they checked the serial number and said it shouldn't be in that batch, so I should have a good one, unless it's just broken. I'm also not sure if the board itself can be involved in that? Maybe? I hope it's not the board, cripes, this PSU power plug has such a death grip I'm afraid of how I'll replace it in the future.

I did contact AMD's email support, unfortunately they weren't very helpful. He wanted me to go try the CPU in another machine and would RMA it if it did it on another one. While the attic is full of old computers, everything's pretty outdated by the time I replace them, (or like the old one, they break down and even then it wasn't AM4) I don't have another AM4 machine to test anything in so if it is the CPU somehow I really hope that trying it in another machine that costs $200+ to make, which I don't need, isn't going to be a warranty contingency here. As much as I wish I could just do that to test it out and make this all less of a headache, I just don't have another AM4 PC or the money, or need, for one right now.

This is just kinda killing me here. I really didn't have the money to be building this in the first place and had to use savings to do it because I can't sit here going stir crazy with nothing to do (and actually to make matters worse my TV broke while waiting on parts to make this new one, how about that timing, and we have no cable TV anyway lol ) My old PC, the PSU blew, I dropped a new one in (the one in this new PC now actually) and it came back, and worked fine for a few days, but then it started doing hangs and BSODing all the time, and it got increasingly worse. When that PSU blew though, it didn't just stop turning on, it stopped working when the PC was at a high load gaming and broke down, so I'm not sure it didn't damage anything. But, I was doing nothing but tech support at home for like 2 weeks trying to fix the stupid thing, eventually, it got to the point that it was hanging outside of Windows prior to boot and that was close to the final straw on that once I realized it couldn't possibly be software related or the disk. The old PC I'd been upgrading since 2009, so it wasn't really in a good place to be repaired, so I had to shell out on this new one, which I really didn't have money to be making, but I needed to make a reasonable foundation to upgrade in the future, ya know?

I was floating the idea that the PSU might not be working right seeing as the old PC didn't work right with this new one either. But I dunno, I'm just not really convinced unless someone else knows more about it than I do. As for wattage, 650 watt should be enough for this, I even ran my parts through various PSU calculators before deciding on the final build instead of eyeballing it. I did hear some shaky things about this PSU after buying it. At the time, I was just so distraught trying to get the PC repaired that Corsair's was what was available locally quickly, usually a reasonable brand, and had a general 4/5 star rating on it, but later on I found out there's a green and gray tagged version of this PSU and the earlier green printed ones were crappy build quality, mine's gray though, I hope it's ok but I don't know. Is it possible for voltage changes to cause an access violation of some kind? I really don't know. Either way if it's hardware, and it may very well, it this is already shaping into a massive headache especially if I gotta get that PSU off of this board haha... ugh... Seriously though, Corsair's board power supply plug has a death grip.

Anyway sorry for the verbose spiel, thanks for any ideas or help anyone can provide

33 Replies

If you suspect the PSU may be an issue. I always suggest to download a free Diagnostic program called OCCT. It is probably the only one the actually stress test a PSU besides the CPU and GPU.

The PSU Test is basically running both the CPU and GPU test simultaneously to put the maximum stress on the PSU. If the PSU is underpowered or faulty, many times as soon as you start the test, the Computer shuts down. But if it runs, in full screen, you can check the PSU outputs to see if they are within tolerances.

* The OCCT PSU TEST might damage or ruin a weak or cheaply made PSU*  Just a warning.

Both CPU and GPU Test also shows the PSU Outputs while running those particular tests.

On another note: Sometimes updating the Motherboard BIOS and CHIPSET to the latest version helps in compatibility issues and other issues. PRIME X370-A Driver & Tools | Motherboards | ASUS USA  for Windows 10:


Version 40112018/05/027.98 MBytes

PRIME X370-A BIOS 4011
Update AGESA + SMU 43.18


Version MBytes

AMD Chipset driver
AMD AM4 Chipset Driver V5.12.0.38 for Windows Win10 64bit. (AMD package version is V17.40.3765, VGA driver version is V23.20.840.0)

Check the QVL list to see if your SSD are listed. Sometimes that can problems if not completely compatible with the Motherboard.

This is a list for the M.2 SSD that are compatible with your Motherboard. These are the crucial SSD listed: (04/24/2017)

M.2 SSD :

Crucial CT128M550SSD4



Adept I

hmm QVL for the SSD I hadn't thought of that, although not sure I'd be able to solve the problem if that's the case haha I'll have to take a look.

I did actually do OCCT already a bit and ran it for a while fine I may have to look deeper into that. As for the BIOS and chipset drivers those should be up to date.

As for the SSD I hadn't thought of that, that's an interesting point. You're right, it's not on the QVL list I hadn't even thought of trying a QVL list for that. Although, they didn't seem to test too many of the M.2s, especially from Crucial who I chose because of the brand quality. Mine is a CT250MX500SSD4, it seems they only tested the M500-120G, CT128M550SSD4, and CT250MX200SSD4. It would seem for a fairly new board, Asus didn't pick very good products to test, the first, I didn't really find a product for, the other two seem to be legacy products Crucial isn't selling anymore, the product codes are very similar though I wonder how different they are, hmm.

I may have to play with OCCT more I don't want to damage anything but I guess if it's working RIGHT it shouldn't damage anything hmm. I guess really I don't have a real reason to suspect that the PSU is bad. My old PC I had it in after it's old one blew, before I used it to build this one, had it's former PSU break down at peak usage during playing a game, so it comes as little surprise to me that it could have broken something on it's way out (and honestly, that old PSU was kicking after like 8 or 9 years which is just crazy to me especially since I took a risk on that originally getting a Rosewill I can't believe it lasted so long, although I've never had a PSU break anything when dying before but I know it happens.) After I put this new one in, the old PC started, ran ok for a couple days, but then started to just get worse and worse to the point that it would barely POST over a week or so. So I'm not sure if the old PSU broke something (likely) or if this one did over the course of the time fried stuff in that week or two it was in there, or if the original one's break down damaged it and this one made it worse (still unlikely I think) or what :\ I'd like to hope it's not frying this new PC, who knows, realistically it's hard for me to truly suspect it, since the old PC did just have a PSU die at peak usage when it died on me.


Does your Motherboard has any Troubleshooting LED or ERROR CODES lit up when you are booting up?

Since it is getting worse and worse, it sounds like a hardware is failing. Eventually it probably will die and you might be able to see what component it was.

Stress testing, in this case, may cause an early death to your computer.

When you run OCCT, are the 12 VDC, 5.0 VDC and 3.3 VDC within tolerances?  Those are the three main outputs that the Motherboard and components use. If one of those are too low it will cause a lot of power issues. Look at the OCCT Graphs from your test carefully and check those voltages.

Normally, if you have a Overheating or Power issue and sometimes a failing component or incompatible issues your computer will shutdown as though you pressed the Power Off switch. No errors or BSOD.

EDIT: You may just want to contact ASUS SUPPORT and find out if your SSDs are compatible. In my opinion, it should be if they are newer than 4/2017, the date of the posting of the QVL List.  But you never know.

Adept I

Oh the worse and worse one was on my old PC that was dying after the PSU failure, it's pretty much dead, which forced me to build this new one, which is the one with the access violations I'm having issues with now in this post. On the old PC, before it's old PSU failed, I had had no problems, when I put the new one in though, I was getting whacky BSODs and hard locks all the time which had gotten more frequent over a week or two, eventually the reset button wasn't even resetting, and it started producing the hard locks before windows even loaded which definitely lead to it not being a Windows/driver thing, and occasionally artifacts when it froze also, and I had tried another video card I had too so that wasn't it, I'm fairly sure the PSU broke something on that when it died. That PC was built in 2009 though, it was about ready to be replaced whether I had the money or not. I could talk about the insane amount of stuff I did trying to save the life of that one all day, but anyway, that lead me to building this new one.

The new one just uses the PSU I had bought as a replacement for the old one, since the old PC wouldn't be needing it and I'm not made of money haha, and from multiple power calculators I played with, 650 should easily make the clearance I need. I've seen no actual symptoms on the new one that would lead me to believe the PSU is actually bad though. I haven't had anything like monitor black outs, or TDRs on the video card or anything similar with the new one. Normally this PC runs perfectly fine and very well, until I run into a random game crashing with a protection fault, anyway. It's just regular general protection faults too, not the BSOD nature, just regular crashes but they're 0xC0000005 every time (and usually show itself as the faulting module, but occasionally, one of the kernel DLLs or a visual C++ DLL but I've already got all the C++ ones up to date too not sure what could cause that from that angle), but multiple games are doing it, and it's ONLY games doing it, especially newer ones that push the PC harder, the older ones seem to do it less or not at all, or kind of middle ground on something like Warframe where it's from 2013 but they've upgraded the graphics and content continually over time. Although, Witcher 3 hasn't done it, which is one of the few other more recent games with high tier graphics I have, maybe these particular games are just REALLY badly programmed, I know Batman is for sure though?

I had recently seen another case where somebody had this happening and RMA'd their CPU and the new one didn't do it, but I'm not sure I'll have luck with that unless I can prove it's the CPU for sure, and I sure don't want to wait on an RMA or have to redo it if I'm being honest. I had contacted AMD's support already but they expect me to test it in another PC which if I'm being honest is not really realistic, I don't keep multiple current generation PCs around and even then I couldn't guarantee it'd be socket AM4 either, having to purchase parts for a whole extra PC to test a product that costs less than it for a warranty isn't really reasonable. I wonder if I should try stressing it with OCCT more than I had before?

I suppose there's the possibility it's still a driver. That would be the easiest solution if I could figure out what it was causing it though. I usually suspect Nvidia but after trying 5-10 driver versions already that's not really helped. I wish I had more crash more dumps too. I can't do a ton with it but I had broken down Batman Arkham Knight and Deus Ex Mankind Divided's crashes more in a debugger. Deus Ex's and Batman's dumps are as follows, from the place where Deus Ex crashed I would have expected Nvidia's involvement, as for Batman that points to a function in the Wwise audio pipeline middleware a lot of games use.

I suppose there's the possibility it's a completely unrelated driver but I'm not really sure where to go to start tracking that down, I already got the newest version of everything when I built this PC around a month ago it should be all fairly up to date if not entirely up to date, they don't really change the non-video related drivers too often. But yeah if you have any other suggestions throw it at me


Oh whoops can't edit these and silly me I forgot to paste in the debugger break down on the two game crashes whoops here they are, I'll bold the part that stood out to me but I'm not THAT good of a programmer so I can't really do much especially with these not being my code to break into further haha:

Deus Ex:

User Mini Dump File: Only registers, stack and portions of memory are available

************* Path validation summary **************

Response                         Time (ms)     Location

Deferred                                       srv*

Symbol search path is: srv*

Executable search path is:

Windows 10 Version 17134 MP (16 procs) Free x64

Product: WinNt, suite: SingleUserTS Personal


Machine Name:

Debug session time: Mon Jul 30 03:34:15.000 2018 (UTC - 4:00)

System Uptime: not available

Process Uptime: 0 days 0:10:55.000



Loading unloaded module list


This dump file has an exception of interest stored in it.

The stored exception information can be accessed via .ecxr.

(3318.13ec): Access violation - code c0000005 (first/second chance not available)

*** WARNING: Unable to verify checksum for DXMD.exe

*** ERROR: Symbol file could not be found.  Defaulted to export symbols for DXMD.exe -


00000001`4317474c 488b4d08        mov     rcx,qword ptr [rbp+8] ss:00000002`22944ef8=????????????????

0:000> .excr

rax=0000000000000003 rbx=0000000000000000 rcx=0000000040000093

rdx=00000001e2944e70 rsi=00000001e2944e60 rdi=0000000148300010

rip=000000014317474c rsp=000000000014bfc0 rbp=0000000222944ef0

r8=0000000000000010  r9=0000000000000000 r10=0000000148300000

r11=0000000018dd4840 r12=0000000000000001 r13=0000000000000000

r14=0000000040000090 r15=00000001e2944e60

iopl=0         nv up ei ng nz na pe cy

cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010281


00000001`4317474c 488b4d08        mov     rcx,qword ptr [rbp+8] ss:00000002`22944ef8=????????????????


User Mini Dump File: Only registers, stack and portions of memory are available

************* Path validation summary **************

Response                         Time (ms)     Location

Deferred                                       srv*

Symbol search path is: srv*

Executable search path is:

Windows 10 Version 17134 MP (16 procs) Free x64

Product: WinNt, suite: SingleUserTS Personal


Machine Name:

Debug session time: Thu Aug  2 01:35:09.000 2018 (UTC - 4:00)

System Uptime: not available

Process Uptime: 0 days 0:01:43.000



Loading unloaded module list


This dump file has an exception of interest stored in it.

The stored exception information can be accessed via .ecxr.

(3bac.389c): Access violation - code c0000005 (first/second chance not available)


00007ffc`0003aa04 c3              ret

0:034> .excr

rax=0000000000000000 rbx=0000000000000001 rcx=000000018541db60

rdx=0000000000000000 rsi=0000000000000000 rdi=0000000015966610

rip=0000000144f6cc86 rsp=000000001404f8e0 rbp=000000001404fa60

r8=0000000015966610  r9=0000000000000000 r10=00000000ffffffff

r11=0000000000000000 r12=0000000008699fe0 r13=00000000ffffffff

r14=0000000008699fe0 r15=0000000198bd81e0

iopl=0         nv up ei pl zr na po nc

cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010246


00000001`44f6cc86 488b02          mov     rax,qword ptr [rdx] ds:00000000`00000000=????????????????

I had to Google around to check into that one, but it does seem to be part of AudioKinetic's Wwise audio pipe lining stuff. I'm not really sure what to make of this, I had expected these to be similar if it were the video driver which I usually suspect as an issue with things like this but Wwise shouldn't be touching that, I had even disabled all the audio devices and ran the game and had it crash so not sure on that front.

I'd like to see more data on Warframe's too as it's the third game crashing most commonly, but it has it's own crash handler which to my knowledge leaves no dumps for a debugger behind, only the game logs which I don't think I really saw a link to being the same thing each time it crashed though. It only saves one game log crash or not, each run though, so if it's crashing I have to save a copy before the next run of it and I don't have a crashing one to paste at the moment on that one, personally I didn't see anything that was a red flag in it, but I may be missing it staring me in the face too. It just seems a bit too convenient to me that 3 higher tier graphics games all do the same general protection fault crash to not be related ya know?


have you tried running DXDiag and see if it comes up with any errors?  If you make a copy of DXDIAG at the very bottom of the report it will mention any problems with installed programs or files. It can be useful at times.

Try running SFC /scannow in an a elevated COMMAND PROMPT just to be sure your Windows is not corrupted or missing files.

Also what are the temperatures for the GPU and CPU like while gaming?

This seems to be a difficult error to fix.

Try running a Clean Windows environment. This will run Windows Desktop without any 3rd party software running in the background. Just Microsoft related programs. It is similar to running Safe Mode in a Windows Desktop. Here is how to do it: .

This is a concise version. Follow the instructions on the above link to do it correctly.

To perform a clean boot in Windows 8 or Windows 10:

  1. Press the "Windows + R" key to open a Run box.
  2. Type msconfig and click OK.
  3. On the General tab, click Selective startup.
  4. Clear the Load startup items check box.
  5. Click the Services tab.
  6. Select the Hide all Microsoft services check box (at the bottom).
  7. Click Disable all.

I am not sure if games will be able to run under these conditions though.


Yeah DXDiag's got nothing wrong, I've already ran the full load of chkdsk/sfc/dism. The temps are fine, the CPU is usually 40-50C tops, GPU 55-70 tops, it usually doesn't hit the top unless I'm intentionally doing something like OCCT or something.

Haven't tried a clean thing yet, although I'm getting concerned after finding a big fat red flag popping up in my event viewer tonight, I think it's time for a VERY long memtest86:

Information    8/4/2018 11:04:50 PM    Memory-Diagnostic-Task-Handler    1001    None

Windows removed bad memory regions from this PC.

Yeaaaaaah I don't like that one bit


When you ran MEMTEST86 the first time, did you get any error at all or did it show ZERO errors after you ran the test?

If it showed at least one or more errors, you have a bad memory module.


Nope! If I saw ANY error in there I would have been RMAing it so fast heads would spin, but I've since ran memtest some more like probably 9-15 hours more and still not managed to get it to trigger


Sounds like your RAM is good.

To tell you the truth, I am out of ideas. Maybe someone more knowledgeable about this type of error might chime in and suggest something different.

I was wondering to eliminate SSD not being compatible, is it possible to remove your SSD and install a regular Hard Drive with the same version of Windows and see if you still get  the error?

SSD are kinda similar to RAM Memory.

See if this Microsoft Forum thread is of any help: Access violation error still occurring after clean reboot F156E954 - Microsoft Community

Copied from above link that Microsoft suggested: How To Fix Access Violation at Address Error - Software - Apps General Discussion

Copied from second link:

How Do You Fix the Access Violation at Address Error?

Install the program with a fresh start and see if it has helped. You could also try changing the settings for DirectX by switching between output and input. If your drivers are not the latest Windows Hardware Quality Labs certified drivers, you will need to download the appropriate soundcard for your system. When downloading them, you need to get them from the official site of the soundcard manufacturer. You may also have an issue with the branding of the memory drives, as they are not compatible. You can try third party tracking systems to see where the exact problem is coming from. has a good system to track the point of access violation, and it is completely free to use.

I have no idea about MADSHI.NET so use at your risk.

This is the software to used to detect crashes at MADSHI.NET: - madExcept description (The software is free for Non-Commercial use):

Copied from MADSHI.NET Link:


madExcept was built to help you locate bugs in your software. Whenever there's a crash/exception in your program, madExcept will automatically catch it, analyze it, collect lots of useful information, and give the end user the possibility to send you a full bug report. madExcept is also able to find memory leaks, resource leaks and buffer overruns for you.

some facts:

· no need to distribute additional files, cause madExcept is fully linked into your executable
· the size of your executable file grows only by some percent (usually single digit)
· you don't need to change a single line of code in your project
· there's no performance loss, as long as no exception occurs
· full support for multi threaded applications
· full support for third party translation tools
· full support for third party protection/compression tools
· email, web upload and printing functionality included
· free for non-commercial usage, inexpensive for commercial usage

A picture tells more than a thousand words. So please have a look at the screenshotsand videos sections.


I'll take a look at the link thanks, appreciate the try anyway. Yeah I've exhausted so many of my own ideas it's stumping me too. I almost wonder if it isn't legitimate issues and the games are just being shitty. I have actually found quite a few people voicing similar complaints over deus ex MD and Batman now, and back for over a year. Warframe, not so sure about. It makes me wonder if it's a specific piece of hardware or something doing it that's fairly common.

As for the HDD thing I'd kind of like to try that but it would be quite a hassle, yeah, if the OS wasn't on the SSD it'd make things easier for sure. If nothing else, your suggestion of the SSD made me check into that more and I did update the firmware on it which was out of date apparently, but, that didn't fix the problem unfortunately


ahall1983, if you have the Minidump folder with files, please compress the folder and attach to thread.  Please open Settings (WinKey-i) go to Apps-AMD software and click on Modify.  It takes a while but you should get a window like mine:


Please post this screenshot.  Close the window - suggest you do not Uninstall anything.    Enjoy, John.

EDIT: Please open a Run dialog or a Command prompt and type winver and post the screenshot.


Hey there, yeah the Windows version is the most up to date, it's 1803 Build 17134.191 64 bit. As for that driver image you have it's not possible for me to post that. I'm guessing that's part of Adrenaline but whatever that is the regular chipset drivers don't install that if you have an Nvidia GPU it would seem. Outside of the Radeon drivers listed there which I don't have the rest of my versions in the device manager match yours in your screenshot.

As for dumps, that would be a bit difficult, they're not BSODs they're regular crashes, so they're not mini dumps they're full size dumps so they're rather large. I'm also kinda getting a different variety of them lately, some are cleaning themselves up as they do take up a good chunk of space. I did post a couple debug analyze reports from the Superposition graphics benchmark and one from Batman on a thread I have on another forum though, which I'm going to link here instead of posting here because I just tried to paste them here and the text froze my browser up, this forum does not seem to handle large scale messages very well it would seem.​  You can find the couple dumps I posted over there in code boxes a few posts down.

So a weird new development since before too. I noticed the other day in the event viewer that Windows claims to have patched around bad memory regions. This is a weird message, my support GoogleFu is usually very good, however I've found almost no posts from anybody anywhere about this feature using the event source name or the full text of that event. It sounds like it thought some RAM was bad and made the OS start working around it. The thing is I've heard nothing about this feature before, the Windows Memory Diagnostic also has not been ran for a few weeks now, I haven't ran Windows' built in one a while so I'm not sure when or how it would have detected anything as I've found no logs otherwise of it attempting to reboot and run it itself. Also, the crashes haven't went away either, so if it patched around "bad memory" it didn't catch all of it or there's a deeper problem which I'm afraid this is. Honestly I'm really afraid this is the board I've not heard the best things about Asus' customer service or turn over time and I really don't want to rebuild this PC *sigh*. Screenshot of the event:


I was hoping it'd be something easy like video ram however, I stuck another video card in today that I had and unfortunately it seems nothing has changed, the crashes persist. Whatever this is is not the video card, unless it's the video card slot, and I doubt that. I guess we'll see I have to test this video card more Batman AK is easy to produce crashes on but that's partially because it's a terrible piece of software from a design point to begin with, but I know the old card is crashing on quite a few games, emphasis on only games, regular software is only crashing once in a blue moon as expected.

I've also ran more memory tests since before as well I've ran the regular memtest86 as well as 86+ as well as a popular online one, HCI Memtest, however as it's 32 bit I had to run like 6 instances to catch all the RAM. Regardless, they all came back clean.

Back on the video front though I've used OCCT's GPU error checker. Both cards I've tried exhibit errors, sometimes it takes a while, sometimes it doesn't. I've heard this test is a bit odd as it doesn't directly try to test the GPU memory so much as it tests what's on the screen to see if it rendered what should have been rendered though. I guess this puts the possibility of the regular RAM back into light? On the other hand, that test only uses 56mb of RAM to run, and out of ~16000 that keeps failing to do bad on a memory test, I doubt that chosen 56mb magically is bad either.

At this point I'm grasping at straws, I just don't know what's going on. It seems like I can get error counts out of OCCT's graphics test, sure, but I'm not really sure if the average user gets 0 on this consistently or not. It's weird though, the big game crashes only seem to happen when the PC is under reasonable stress, which regular software doesn't normally do. The CPU itself is barely stressed at all on most of these games, it barely ever goes over 30-40% at most, I have 16gb of RAM and I've barely seen that even come close to filling up, either. I'm getting stumped at this point, the only other little thing I can think of that was slightly different in the crash reports was that the Superposition benchmark I tried out crashed with a heap corruption once instead.


AMD CHIPSET has a bug that prevents it from installing it on a computer system with a Non-AMD GPU Card. This thread will explain how to work around that issue and get the AMD CHIPSET to install on your Nvidia GPU card computer system:

This is the fix for that particular issue. Copied from above link thread:

I edited the /config/InstallManager.cfg file to include "CHIPSETBUILD=true":








I have a Asus Motherboard 990FX Gen 2.0 (AM3+) with a Asus GTX 1070 GPU card. When I run OCCT, I get ZERO ERRORS when running the GPU with ERROR test.

Found this website that explains about Windows Memory patching bad memory regions: What is the meaning of: Windows removed bad memory regions from this PC. .

Could be a BAD DIMM Motherboard slot causing the problems. Try running with just One RAM Memory module (if 8 gigabytes) or two 4 gigabyte Modules and see what errors you get.

NOTE: As a last resort, you can try a Ingrade Windows 10 Repair. This will reinstall Windows 10 without losing any personal data. It is the same procedure for upgrading a Windows 7 or 8 to Windows 10. This should be performed in case your Windows 10 OS is corrupted.

Run your Windows 10 Installation either from a USB or DVD and start it while you are on your Windows Desktop. Make sure to check "Save personal data" or something like that and follow the instructions. When finished, you will have a newly installed WIndows 10 with all your personal data and programs intact. Then you can use Windows Cleanup (Right click on your C Drive) to delete WINDOWS.OLD to regain that hard drive space.


Yeah I've been debating if I want to waste a ton of time to find out a Windows reinstall/refresh/whichever doesn't work.

Thanks for the info on the errors that definitely makes me think something is broke. I've actually already tested single dims and shifting slots which made no difference. I've also heard that turning off power and gear down on the ram stabilized things for some people. I really hope the gfx cards aren't damaged too but the first two have significant usage so it's possible those ones were on the verge as well.

As for the chipset drivers, yeah it's disturbing to me that AMD still hasn't acknowledged properly that those don't install entirely without radeon video. That post is over 6 months ago and needs properly addressed. Anyway, I'd already hand repaired it before to no avail, I don't have that app that checks versions, but I had previously noticed the one sata driver didn't update and one of the system ones too, a GPIO one I think but I directed windows to the extracted drivers for each and had hand updated them fine. Made no difference though.

Corsair is pretty staunch that they don't think their RAM is damaged. I may have to agree after all those tests. However Corsair is also very irresponsibly selling different "version" numbers of this ram under the same SKU. Which is super irresponsible as if I wanted to upgrade in the future and didn't want to waste money of a full set of expensive DDR4 dimms since the same SKU isn't identical. I'm finding that I made my QVL buy based on a version "3.x" of this ram while I received version "5.x" I've heard these are different enough that some versions have hynix dies and some have Samsung. This is extremely concerning as hynix dies all have a bad rep working right with Ryzen the first time.

So I'm kind of wondering if there isn't a chance I may need custom timing to make this ram work at all even on stock 2133? I'm really not sure this is my first ddr4 machine and I didn't think ryzen was still this picky about timings.

There's also the possibility of the psu drooping (doubt it) or a bad mobo, or cpu or both. I had tried the Prime 95 stress test as well I'm not sure what to think about that. I ran the small test (mainly cpu caches) and ran it about an hour fine. I ran the large test which uses cpu and a larger data set using a modest chunk of ram, this ran about 30-60 min with no errors before I tried others. Then there's the blend test, their default that tries a lot of cpu and ram at varying sizes. This test fails.

The original purpose of this program is helping mathematicians calculate prime numbers and check them against known good values from many users. Knowing that, they know what values should be returned. This is concerning because when I start the blend test, the app opens windows for every thread. Within 1 minute at most, most of the threads stop and fail from a rounding error vs the known good values.

So this cpu is absolutely not working correctly, but the test specifically for the cpu comes out fine. It seems to be an issue with interactions in high amounts of ram but not lower ones.

Amd have me go ahead on rma but I'm not sure it's not the board either  I wish these companies had better turnaround time on this stuff when things are broke on arrival  I didn't really have cash to build right now anyway, but my old pc gave out and needed replacing this is truly a nightmare. I literally have no entertainment at all at home without this operating 


Could all this be due to RAM MEMORY not being totally compatible with Ryzen CPU?

The RAM MEMORY may check good because it is good, but because it isn't totally compatible with the Ryzen it causes weird problems.

Have you tried to contact your motherboard's Support site to be sure your RAM is compatible or a motherboard issue?

BTW, Can you post the exact RAM MEMORY Part number - Make and model?


Yeah, I'm diligently working to try some things out right now again before support depts close for the day now. I have another new.... annoyingly fascinating discovery yanking my arm back in the memory direction also.

The ram is Corsair model CMK16GX4M2A2666C16. The problem with this as I mentioned above is Corsair's convoluted idea that putting multiple types of different RAM dies and what not under the same part number is ok. This is extremely bad in my eyes as these are not really the same parts. Corsair has a list of RAM they claim is fine for Ryzen and it's on it, as for the motherboard's QVL this is theirs, but with Corsair's version numbers it's gotten a tad convoluted, and you can't 'buy' what version you want, because it's all the same part number so a vendor just sells what they have. QVL link, warning it's a PDF:

Anyway the new thing yanking my arm back at memory is not just about timing. While I have juggled the sticks and ran tests solo for at least one pass in each configuration having them pass tests, I found out something interesting. The Prime95 test that wouldn't pass before? The heavy cpu and ram one that failed almost instantaneously? I took one of the RAM sticks out, and so far it hasn't failed. Also the OCCT graphics error test? It's not failing either. I still need to try single stick on the other and run some games and see what happens (Although in Batman's case it has issues of it's own that may cause crashes, some of the more common ones I can find out are common via Google, however) but I'm getting the idea it may have something to do with running two of these.

While they do indeed pass memtest in any configuration there seems to be some kind of issue with the CPU and RAM talking to each other in high stress situations if there's two sticks. Also when I put only one, I returned the settings back to default 2133 and also put gear down and power down back on Auto as well so this is completely stock. I think actually, turning those two off like someone else recommended may have actually stabilized some things more, but this is running on normal, and now I think I need to test this even more I'm very curious if this isn't actually Corsair's fault somewhat because of this not staying synced with two sticks. On the other hand, it could still be the memory controller, and I'm not sure what to think now. I wish I could get a hold of Corsair's email tech support guy on the phone instead as I think I could find out a lot more data, but unfortunately their phone center seems to go somewhere in India that's more about RMAs than attempting to fix things. hmmmm.


It is beginning to sound more and more like incompatibility issues with both RAM Memory installed.  You said your version of Corsair is 5.x while the QVL lists 3.31.  I don't see any 5.x except with slightly different gigabyte or part numbers on the QVL LIST.  None that end with C16.

If OCCT and Prime95 checks good with one RAM module installed it seems to indicate that the CPU, GPU and Motherboard and installed Memory are good.

Your Motherboard requires Dual Channel DDR4 correct?  So, I am assuming both of your RAM are Dual Channel.  But for Dual Channel to work the Memory must be installed in the proper DIMM Slots on the motherboard.

According to your manual A1 and A2 are Dual Channel  and B1 and B2 are Dual Channel. :

I purchased a set of four DDR3 Corsair Vengeance RAM MEMORY about 6 or 7 years ago. Last year found out one of the four RAM Modules went bad. I contacted Corsair to replace the single bad RAM module. They refused. They said they need the entire set to replace since they can't guarantee that the single RAM Module will be compatible with the rest of the set. Long story short, I ended up purchasing the same RAM Memory module with the same specs and part number except the last character was changed. Luckily it seems to be compatible and my computer is back to normal again. No more BSODs.

I mentioned to Corsair Support that I couldn't be without a computer for over a week or longer while waiting for the new set of Memory to arrive. That was the reason I decided to purchase the single DDR3 Module.


Yes the RAM should be dual channel DDR4. I'm going to try the other stick single here too soon as we go throughout the day we'll see what happens. If this is really a memory and Corsair can't sort this out or Newegg let me swap it or something I'm going to be pretty angry. At this point I'm probably not going to be buying Corsair's RAM in the future, their brand name does not mean enough to me to warrant the hassles involved in playing this version game when RAM shouldn't "have" versions they should have a different part number it's extremely unprofessional and unbecoming of a company of their size with as much experience as they have.

As for the RAM slots, yes, I do have them in the correct motherboard recommended slots. When I was doing the original memtest runs the REALLY long ones were in recommended slots with both sticks. However, I also ran single sticks in each slot and also did both in random slots with memtest as well for at least 1-5 passes without any errors found as well. But yeah I normally run them in A2 B2 as recommended in the manual. I suppose I could also try running them both in incorrect slots and see how the newer tests are fairing with OCCT and Prime95, could be interesting but also shouldn't work that way either, and if they're not in the right slots it'll probably screw the dual channel up.

But yes the QVL is a big mess. Corsair claims this SKU works with Ryzen in general, they have a forum post that shows what they officially consider for this. The motherboard is weird because if you look at the list you'll see different versions of Corsair RAM. You'll also see there's a Mhz column for Ryzen and for other stuff (Ryzen on the right) You see they have the part number I mentioned above, in the list, with NO version number also! Even though there's no version number it still says at least 2133 should work, and still it does not. So Asus could be partially to blame here as well. Although actually Asus in general needs to update that page, the memory test page has a QVL for Ryzen in general, Ryzen for 2000 series, and one, the one we both read off of says it's the QVL for x370-A, which is correct, but there's one that doesn't mention a model number also, and if you open that, you'll see in the URL bar that it's for the x370 Pro which is NOT the same motherboard and is bound to cause confusion


Oh whoops, can't edit these meant to drop this in, here's a line in the QVL for the motherboard showing just the part number with no version expectation, showing that it should at least run as 2133



This a copy from the latest QVL RAM MEMORY list from Asus 2666 speed RAM. Link in previous comment: Copied from link shows different versions.

CORSAIR CMU32GX4M2A2666C16(Ver4.31) 32GB(2*16GB) DS N/A Heat-Sink Package 16-18-18-35 1.2V 2666 2666 ●

● CORSAIR CMK32GX4M4A2666C16(Ver3.20) 32GB(8GB*4) DS N/A 16-18-18-35 1.2V 2666 2666 ●

CORSAIR CMK16GX4M2A2666C16(Ver3.31) 16GB(2*8GB) SS N/A Heat-Sink Package 16-18-18-35 1.2V 2666 2666 ●

● CORSAIR CMK32GX4M2A2666C16(Ver5.39) 32GB(2*16GB) DS N/A Heat-Sink Package 16-18-18-35 1.2V 2666 2666 ●

● CORSAIR CMK16GX4M4A2666C15(Ver5.20) 16GB ( 4GB*4) SS N/A Heat-Sink Package 15-17-17-35 1.2V 2666 2666 ●

● CORSAIR CMK64GX4M4A2666C16(Ver5.30) 64GB(16GB*4) DS N/A Heat-Sink Package 16-18-18-35 1.2V 2666 2666 ●


Yeaaaaaaaaaaaah I just found out about the error myself. It would seem that the one that doesn't mention a version is in the second half of the table, which changes Ryzen out for other stuff.

So yeah, I guess the non-versioned one is not in the top of the list with Ryzen. Regardless, it does not change that one cannot choose which version comes in the mail. Hmm this is problematic


just curious, but what does BIOS show when you have both RAM MEMORY installed?


Oh it's correct it says like Corsair 8192mb 2666Mhz for both slots. However I have finally cracked it, I believe we'll see I think I got it now!

While both RAM sticks continued to pass memory tests I decided once more to try them again solo and realized one was stable in games, one was not. I ran OCCT's graphics test again and Prime95's blend, one stick passes, the other does not. At first I thought it was just the timing incompatibility but either way, stuff is prepping for replacement and I'm running on the solo stick for now hopefully good news soon! Also, holy beans, let me tell you, not using the dual channel on the RAM is VERY palpable haha


great troubleshooting.

Troubleshooting RAM MEMORY can be a frustrating to say the least. I know it must have a been a pain in the rear installing, removing and testing each RAM module in every slot.

As I mentioned earlier, Corsair is going to ask you to turn in the entire set for replacement.

Also back to your original post, Are you still getting "Access Violations" with the one good RAM module installed?


Nope, no problems with one! Running only one worked for a few days, had to be THAT stick though the other one was not right. Also the Corsair RAM is just bad for Ryzen timing anyway since they have these 'versions' I ended up having Newegg swap it for some more expensive Gskill which is supposedly the best RAM you can buy for Ryzen whether it's on your QVL or not (it's not but Newegg said they'd be happy todeal with it if it didn't fix it because he was extremely confident it would, also it has the well spoken of Samsung 'B' dies that are supposedly the easiest to time well with Ryzen.) the 3200Mhz DOCP profile for this so far was unstable in Prime95 almost immediately like with the faulty Corsair stick! However, the stock has been stable in Prime 95 for an hour, so I think this may just be a clocking issue on this, I don't think my board likes this particular setup going as high as 3200.

I'm not generally an overclocker but I've kinda had to do some similar stuff because of way this Ryzen timing works. There's an engineer on an overclocker's forum whose made an app to calculate safe or powerful RAM timings specifically for Ryzen. Luckily it has the 'safe' setting, I may have to see if I can get this a lil bit closer to 3200 without going over, I've heard good things about his tool which is good because I generally don't like toying with that sorta thing. I didn't actually want to get RAM this pricey, I had to shell out a bit more but I've heard very good things about this RAM.

Thanks for the help though, hopefully I will be able to get this stable and worse case scenario it seems like it's stock clock (which is actually 2400 and not 2133) is clean at the moment. Also a shoutout to Corsair for asking Newegg to help with this a few days over the regular 30 day return policy because of compatibility, the version system they use is just an issue since you can't 'really' buy the perfect QVL for your board. Also shoutout to Newegg for their fantastic customer service also. Hopefully I can get this memory a tad bit faster and be stable still with that calculator, but if anyone else finds this having Ryzen RAM issues, be sure to check that OCCT GPU error checking test and the Prime95 blend test to see if your RAM can take the beating of heavy cpu and ram transactions, because walking down it byte by byte looking for problems like memtest86 and similar tools do, will NOT detect an issue this intricate without the PC under heavy load it would seem! But yeah Prime95 is VERY picky about those prime numbers, in my current experience, the blend test fails in under 5 minutes if the RAM is even a hint unstable, I do recommend trying it, it's also good for using in the 'small' test to just test your CPU and not the RAM too!

At another Forum this RAM Memory tester MEMTEST was recommended to be very good. Similar to MEMTEST86 but can be used in a Windows environment. Says it is good to check when you install new RAM or OC . I opened a thread concern MEMTEST here: FYI: MEMTEST by HCIDESIGN checks RAM Memory in Windows Environment

From link above:

By running MemTest you can ensure that your computer's RAM correctly functions. It is wise to test this when you buy a new computer, install new RAM, or change the configuration of your machine (for instance, to overclock it).  Are you the sort of user who likes to push the performance of your machine to the edge? Relying upon whether your machine will boot after your new BIOS tweaks is a poor way to determine the safety of your new settings. Use Mem Test as a true test of stability.


Yep I've done all the troubleshooting already for weeks and have narrowed it to the cpu if anything. Like I said, I have a separate new computer at this point from replacing everything, this is about the warranty process.


Make sure you try all the tests on Prime95. Blend is the harshest and would cause failure quickly for me. The small test pushes the CPU hard but the RAM is barely touched.

I found Prime95 to be a huge help in finding out that one of my RAM sticks was bad. Memtest came back clean because all it does is walk down the memory and check for specific responses to things slowly. The RAM I had only failed if it was used in a stressful situation and memtest86 is a solid test but it's not a stress test


Yeah for me my issue persisted through RAM swaps, and passed blend tests. So i think it is a CPU issue, which I'll be getting today. I bought a specific RAM that IS on my mobo QVL, so I really hope the processor was the problem because the RAM says it is compatible. But for you it was RAM.


Journeyman III

Hey man, I'm having the same issue. Getting access violations in The Witcher 3 and in Overcooked.

I've replaced my entire computer at this point, and am waiting on a new CPU to fix the problem. I bought a very specific RAM module on the QVL and it still was causing the errors.

Were you able to find the solution?


Hey did the problem go away after getting a new CPU? Cheers


Hmm looks like a long time ago I missed replying to that other message you replied to. I'd like to hope evastonian figured it out by now, but, either way to both of you I'd recommend doing the RAM stuff I mentioned in the other posts above. QVL or not, doesn't matter if the stick is damaged.

I'd actually aimed for QVL myself, though turned out it really wasn't QVL. Turns out those lunatics at Corsair, sell the same RAM module in different "version numbers" like software, which it obviously is not, on the same SKU, even if the RAM dies are from different companies and stuff, it's ridiculous and breaks any hope of QVL when you order that ram and find out the version number you got is different, mine were like 3 versions newer but being sold on the same SKU. Corsair needs to get their crap together.

Annnnnyway, it was totally the RAM for me, I'd check that yourself. I ended up using the software I'd mentioned in other posts above to test as they tended to force the fail rate regularly, which allowed me to produce a reproducible test case which is the best way to be able to test these things, also Batman Arkham is also really good at forcing this to happen Prime95 aside as it's notoriously wasteful with RAM. I'd tried juggling my RAM sticks around, and running solo on each stick in varying slots, eventually I found the pattern that when only running one stick, regardless of slot, the same stick always caused failure when the other did not (even if games were slow, because I was low on RAM, of course) Also in Prime95, I'd never get computing errors unless that stick was in, you'll see more on what I did with P95 in the other posts above.

Memtest was never able to detect this in a normal memory test as it seemed to only collapse under hard stress and not small computations though, anything that wasn't gaming would never crash. I suppose something like a hard 3D or video render may have but it wasn't something I was doing at the time.

One other thing I will mention though too, is read into what your mobo is designed for to take on the RAM too, and maybe at least for diagnostics, run the speed on the ram kinda low. DDR4 is goofy in that much anything over, what is it, I think 2100mhz or so, is considered an overclock, while much RAM for gaming is built expecting you to exploit that and shows higher numbers that's not spec on the package, the board may have it's own stability issues as well, I know my replacement ram now, is expected to go to 3200mhz and it's built in overclocking profile is for that, but it won't work for me because it's too high, this board was never designed with that in mind so I have it around something like 2400-2700 or some such I believe.

As for RAM timings too, if you have a case like mine where your board isn't really meant to take more and the RAM's built in timer is for something ridiculous high, you'll have have to play with the timings to get something right. If you google Ryzen DRAM calculator, that little app can give you all the numbers for your RAM to get the other timings generally right for each mhz if you end up needing to do this. But I'd worry about trying that other stuff in my earlier posts first and seeing if you have a failure before you play with this (outside of turning the speed down, first, anyway)

I suppose whether you find something with that or not, it wouldn't hurt to run any host of memory tests for a few hours after each time you tweak to see if things start coming back bad over time. If you change those timings upward, check memtest for a couple hours each step and see if anything bad happens, the higher that goes, the more likelihood your ram will show bad in memtest.

This is part of what threw me off at first, was for me, it could have been plenty of things that weren't the RAM. It could have also just been my bad ram timings, as the timings being bad will also throw memtest into a tizzy over time too, but nope, was definitely a faulty ram stick!