Showing results for 
Search instead for 
Did you mean: 


Adept I

3700x X570 rebooting in light usage, no event log errors. System was stable for 2 months.

  • AMD Ryzen 7 3700X
  • Team Group Dark Pro "8Pack Edition" 16GB (2x8GB) DDR4 PC4-28800C16 3600MHz Dual Channel Kit
  • Samsung MZ-V7S1T0BW 970 EVO Plus
  • EVGA SuperNova P2 650 W Platinum
  • SAPPHIRE NITRO+ Radeon RX 580

Today I've had 10 reboots in light usage (e.g. browsing the web with spotify playing). They are so sudden I thought the first was a powercut. The first few happened about once an hour, but they've since happened at various intervals from seconds to a few hours.

Event viewer doesn't show any errors from just before the system restarting. There are some from sometime earlier but they don't always precede the reboot. I'll document them if anyone is interested.

This instability doesn't follow an update or hardware change. I did update my bios and chipset back in August, and I risked doing it again today but it didn't resolve the issue. The only hardware change I'd made since the PC was built is swapping a USB mouse.

I tried setting the memory profile back to auto where it clocked at 2.4 Ghz, and then I removed one stick, and then swapped the sticks, all to no avail. I haven't run memtest yet.

I ran a couple of benchmarks for long enough to get the CPU and GPU up to 80C and 70C respectively to see if power draw or temperatures would quickly trigger a reboot but they didn't.

I unplugged the front reset and power buttons, and it still rebooted.

I haven't yet tried changing the powerplan but I checked it and it was set to Ryzen Performance.

I initially did have more drives plugged in but I unplugged them and it still rebooted.

In the past week I've been using it for a fix of factorio with youtube playing in a second monitor, so it's had plenty of usage.

The power supply and 580 were in my last PC for 2 years without problems. I have ordered a new power supply because I wanted one for the remains of my old computer, so I'll try swapping that when it arrives.

Now for the BUT. I remember I had a random restart on the windows log in screen several days ago, and I had the same thing happen today (just after another restart). So although it's only become this unstable today, the issue could be linked to something like a windows update. Tomorrow I'll check the logs to get the date of that and see if it was after an update.

Aside from swapping the power supply and running memtest86 what else should I try to diagnose this?

1 Solution
Adept I

A replacement CPU resolved the issue. Thank you

See my other reply for the further diagnosis I did.

View solution in original post

16 Replies
Journeyman III

I am having the same issue. Before it looked like it was doing it just watching web videos, but now they are more random and more frequent ever since i updated the BIOS to ABBA. I have the AMD R5 3600 and X570 MSI A Pro. No BSOD or anything just a quick restart.

Adept I

The new power supply turned up and it appears to be DOA, as neither machine will boot with it. I went with a slightly cheaper one and instantly regret it.

So I'm still on the old PSU and running memtest86. It's over two hours in and has just finished the third pass with 0 errors so far.

I did notice that when I unplugged my other drives I left them powered, so I've corrected that and fingers crossed I can pin down the cause.

I'm also thinking of doing a clean install or possibly a linux install and see what happens then.


It passed memtest86. But started crashing again once I went back into windows. It will sit for several minutes on the desktop without crashing, but will crash shortly after starting a video on youtube.

I loaded Ubuntu 19.04 off a memory stick and it crashed after 30 minutes of youtube.

Update 2019-09-21:

I've now tried:

The graphics card in another PCIE slot.

The windows default power plan with a 5% minimum CPU power state. The system restarted a few times while I was trying to do this.

A third power supply (known good) and my old HD7950.

The above but in Ubuntu again.

I'm going to have to try swapping out the motherboard and/or processor but I don't have access to another Ryzen system.

Update 2019-09-25:

I can rule out it being the result of the processor switching from low power to high power or boosting. I let prime 95 run for a bit, and left it running as I loaded the browser and it quickly rebooted thereafter.

Another Update 2019-09-25:

I actually got a quick response from AMD technical support, but it got flagged as junk mail! They've suggested this is a problem with the BIOS or the CPU and I need to test CPU in another computer.

Update 2019-09-28:

I removed the motherboard from the case and tested it again, and the reboots still occurred.

I then removed the CPU and visually inspected it and all the pins were fine. I put it back, retested it and the reboots still occurred.

Update 2019-10-09:

I returned the motherboard and CPU to the retailer who tested them. They confirmed it rebooted with the original CPU and didn't with their own 3600X, so I'm getting a replacement CPU.

Journeyman III

change power plan setting in control panel, 

create new power plan 

example my name : cpu 99  

i used balance 

go to advance power setting

processor power management

set to 0% minimum processor state


set to 99% maximum processor state 

if you more low temp , you can drop 80% for better temp and voltage 

i use this option to browse internet, watch youtube, read, and when i play the game i choose to be balance 

set to 0% minimum processor state ,set to 100% maximum processor state 

create shortcut power option to desktop to make easy changing power plan that you have made

sorry for my bad english


Try a little more dram voltage in bios... I know you're running mem test and its passing but I've noticed this faster memory 3600mhz likes a little more voltage than 1.35v, try 1.36 and see if that does anything for you.  I'm running 32gb of the gskill royal and at 1.35 dram voltage I get blue screens about once a day, at 1.36 its rock solid..

 Years ago I had a Sapphire nitro fury and it had anomalies when I used youtube, it was something with html5 and the way the drivers were handling it or something.. I deleted the youtube video of the fury anomalies a few months ago.  I would randomly get a bunch of static looking lines appearing in youtube and eventually it would get worse and worse, got so bad you couldnt even watch a youtube video. I narrowed it down to the gpu itself,as a gpu swap fixed the issue..

I returned the gpu as faulty and got a new one and sold the unopened one and went to an nvidia gpu and never seen the issue again.  I am serious, do you have an nvidia gpu for comparison..

Thinking about it, as I'm old and this was a while back.. I had two amd cards that had the exact same issue and got nothing from amd, they were a fury and rx480.. Your driver might be crashing,  Check your event log and see if it says anything..

Run DDU in safe mode, completely wipe your gpu drivers and do a 100% fresh driver install using the latest drivers..  Is the 7950 at end of life, I dont think I would trust the drivers with that gpu, It might be ok in ubuntu, but I think windows would be iffy..


Increasing the dram voltage to 1.36v didn't help.

The 7950 is still used regularly in another PC without issue. The fact the machine has the same problem with either card in two different operating systems makes me doubt it's a graphics driver, particularly when the machine is simply restarting without errors or blue screens.


There is a whole thread of people dealing with this issue: 

I have had this issue since upgrading to the 3900x. I have changed motherboards, RAM, and PSU and the issue still happens (random restarts).

AMD Customer Support has been nonexistent and of no help. I am in the process of RMAing the CPU. If the replacement CPU has the same issue (my gut feeling is it will), then I will have to escalate and get a refund from AMD.

It is beyond ridiculous that this is happening on brand new CPUs. But if you do a Google search, these issues are happening a lot to Ryzen customers (all the way back to the first gen). AMD knows how to make a CPU on paper, but once they release, they are filled with driver and stability issues.


I use extreme Corsair power supplies mainly as the tend to last a very long time and with 1000W of power, I am not worried about video cards with three 8-pin power connectors.

I suggest to never cut corners on the PSU to eliminate risk to a box of expensive hardware.

Journeyman III

I'm having a similar issue:

3700x + X570 AORUS ELITE + Micron Ballistic Elite 3600mhz RAM

Narrowed the issue down after testing PSU, RAM, New Windows Install etc.

I'm consistently getting blue screens with 'core performance boost' enabled.
With it on, I get Win10 blue screens - mostly at low workloads. BUT: With the cores manually set to 3.6 or 4.1 it's perfectly stable.
Temps seem fine, 65 Degrees during a stress test @ 4.1ghz (crashed at 4.2ghz, but was only set to auto voltage)

Tried multiple bios's - it used to run with boost enabled fine...worried the chip is sickly.... 

Adept I

A replacement CPU resolved the issue. Thank you

See my other reply for the further diagnosis I did.


cyx wrote:

A replacement CPU resolved the issue. Thank you


See my other reply for the further diagnosis I did.

That is uncommon that a CPU has failed. 


Given the many thousands of processors AMD is shipping, you'd expect a handful to be bad wouldn't you?

There's perhaps a dozen people on this forum with the same symptoms, and three or four where the issue has now been resolved by a new CPU. It's not a very common problem because there's little to no mention of it on other tech forums.

We're also within the first few months of launch; in six months time failures should be even rarer.


my cpu worked fine on several motherboards I have tried it on

Adept I

SOLVED: same problem. I think it's Asus firmware over clocking the processor too much (turbo). That processor is rated for 3800Mhz. I noticed in Armory Crate it sometimes went to 4400Mhz. I changed the processor clock ratio from auto to 33 and changed the system base frequency from 100 to 98. System became rock solid. I will be tweaking the settings up from here, but this 100% solved the problem. I think the firmware is being too aggressive with turbo and the processor is resetting. I had previously tried many other things including new bigger PSU, memory, memory speed, Windows reinstall, other bios tweaking.
UPDATE: I changed the base clock back to 100 and clock ratio to 38.  Still rock solid.  This pegs the CPU clock at 3799, but I'd much rather have a slightly slower stable system than a faster glitchy system.  I am convinced the turbo feature of the chip is being tweaked beyond the designed performance envelope OR the chip has a flaw making it susceptible to glitching/resetting when clock/voltage is dynamically changed too much.

CORRECTION: my CPU is model 3900X.


@fhricpthanks for figuring this out! I've tested every other part and never thought it could be the ryzen  boost being too aggressive.

+2 for this solution

Hey I have the same issue with my ryzen 5 5600 and ryzen 7 5800x with gigabyte b450m rev1.x and gigabyte ds3h respectively. But I am new to PC's and don't understand your solution. Can you ease it for me? I shall be very thankful to you.