Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

System crashing when gaming 7900XTX

Every time I game, sometimes before I even get into the game, I get a hard crash and black screen/reboot. No idea what is doing it. Here’s my system specs;

7950x CPU
7900XTX GPU (Latest drivers 23.5.2)
Asrock x670e Taichi mobo, (BIOS 1.24 latest)
32GB g-skill expo 6000mhz kit
Windows 11 latest and greatest 

I have spent every hour for the past 2 days trying to solve this and I am at my witts end. I have gone so far and as drastic to do the following…

re-flash bios, set all to defaults
CLEAN/WIPE hard drive entirely
re-install windows 11 using the bypass network requirement trick, local admin account, no updates
disable automatic driver installation, connect to internet
install all AMD drivers through the amd auto install tool (grabs audio, gpu, chipset)
Download and launch diablo IV on a literal fresh windows install, latest version of windows, latest drivers–same thing. Black screen, reboot after a bit. Does the same for world of warcraft too. I haven't tried any other non-blizzard games because those are all I really play. 

Reliability history has no log event other than unexpected loss of power. No blue screens, no crash dump files, no error codes. I have reset everything in bios to stock even though I have a rock solid OC (8 hour gold stability cert from OCCT). Overclocked or stock, same results. I don't know what else to try and I am going insane. 

Temps are not an issue, these are all water cooled. CPU stays in the 60s, GPU in 40s. 

5 Replies

You didn't list your power supply make/model

Are you running separate power cables from your PSU to each power input on your GPU?

What model/timings Gskill RAM? (Samsung or Hynix kit?)

what drives are you using?

What case?

How is your airflow thru your case? You have to keep your VRM's and RAM cool too 

ThreeDee PC specs

PSU: Thermaltake Toughpower GF3 1650W

Yes each cable is a separate power connector

Timings don't matter, happens at stock or expo or 1 stick. 

Using a samsung 1tb NVME, 950 pro. 

Case/airflow is irrelevant, it's a custom hard tubed water cooled build, water cooled cpu and vga. Temp monitoring shows GPU never goes over 45c.

stress test passes 20 loops in 3dmark, temps are fine.

3dmark score is good, hardware is behaving as expected.


OCCT power supply test ran for 30 mins with no issue. This one is really bizarre and bugging me, I cannot get a grip of what it could be. I am starting to honestly think motherboard. It is so sudden and leaves no log it has to be hardware, but the gpu/cpu pass all tests and the PSU as well. Just don't know what else to think of. 


Nothing showing up in event log is quite puzzling. That says to me that it is triggering a hardware safety feature perhaps. Double check power supply. Also, run full power load test (gpu and cpu at 100% load) for a minutes in OCCT. That should verify power at least.


Its your psu/cables. 

Adept I

Hey just an update for people--after working my way through several vendors troubleshooting, PowerColor determined it was the GPU--and it was. replaced, solved.