Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Fullscreen games get stuck at 30Hz independently of used resolution


When i play a game in fullscreen, the framerate gets stuck at 30Hz and if it plays in windowed mode the framerate is smooth. I've tried with several games, and this behaviour is allways the same.

I've been having this problem constantly since i installed a rx5700, i´ve tried with different resolutions (1080p, 1440p, 2160p), with different display cables and different monitors (all 4k btw) and it happens allways...

My windows resolution is 4k@60Hz and everything is smooth but as soon as i start a game in fullscreen, the smoothness ends.

My Oculus Rift S dont have this problem and strangely if i use my small monitor (24") conected through hdmi, the games run well in fullscreen, but this is just a support monitor, i intend to run games on one of the 28" monitors.
At the moment this is my system:
- Ryzen 5 5600 (no OC)
- Asus Strix B550-F Gaming 
- G.Skill 32GB DDR4 4400MHz
- Asus rx5700 (Adrenalin 23.5.2)
- Kingston Fury Renegade 1TB nvme
- Windows 11 PRO (updated)
- Asus PB287Q 4k (main and connected by displayport)
- Asus VP28UQG 4k (connected by displayport)
- HP 24w (connected by hdmi)
- Oculus Rift S (connected by displayport)

Already did:
- updated everything that i could think of
- only one monitor conected
- different displayport cables to that monitor
- tryed gaming in each of the 28" monitors
- different displayport outputs in the GPU

What can be the reason for this behaviour? I've been searching for a fix but i couldn't find any that would work for me. I'm getting desperate and starting to plan to sell this GPU...

1 Reply
Journeyman III

Well i think i discovered the problem... In AMD Adrenalin, i selected the factory reset option and proceeded with the process. As soon as it finished i tried a random game in fullscreen and it was no longer stuck at 30Hz... At this time, after the factory reset, every option in Adrenalin's GPU tab were disabled, so i tried enabling Radeon Super Resolution (RSR) and starting again some game, and there it was, stuck again at 30Hz...

I would like to use this AMD feature because my GPU cant run well at 4k, but it can play smooth at 1440p upscaled to 4K through RSR.

I know RSR plays at the monitor's native resolution, which in my case is 4K but i am using a displayport 1.2 monitor, cable and GPU capable, in fact, my windows resolution is 4K@60Hz, so i believe this configuration is not a problem for this hardware.

Can anyone help me with this?