Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

RX6900XT causes pc to shutdown

Hey guys,


I have seen similiar topic here, which for some reason was closed...

I purchased RX6900XT today this version, swapped with  my RX6800 which had zero issues

Now, whenever I try to load any type of benchamrk, Time Spy or Fire Strike, PC just shuts down with some RGB lights still on.

I tried: updating MOBO bios, resetting it to stock settings without any OC

Uninstalled driver using DDU, installed the latest version Adrenalin 21.11.3 Optional, then using DDU again, tried Adrenalin 21.10.2 Recommended (WHQL), no joy, same issue.

I thought it might be PSU (EVGA850GA GOLD), but saw others swapping theirs for 1200W and issue persists.

Unfortunately I found no solution in this topic as well :

Any solution? Thanks..

10 Replies

I am having the same issue my 6900 is on a liquid cooled setup so I know I’m not overheating and my psu is an evga g2 1300 so not overloading … I’ve tried turning of resize bar and enabling csm in bios with no luck … are you by chance running windows 11? Because I didn’t start having issues till I installed win 11


Actually I was thinking about upgrading to W11, but wont now lol

Running W10 which I installed like 2 months ago, dont think reinstalling it gonna help.

It's so frustrating, I bought this card for benchmarking purposes mostly but still...

Weird fact: card almost can finish Time Spy's graphics test, but shuts down PC when trying to run Fire Strike instantly.



Update: I was running all benchamrks while monitoring it with MSI aferburner. I disabled it and I was able to run benchmarks I was not before: Time Spy and even Fire Strike was not even starting but causing PC to shut down instantly.

Then I did a small OC, PL 15% and max Core clock 2700 and symptoms were same. I refuse to believe that my card is not able to run at these clocks.


I ran Time Spy Extreme stress test, 20 loops roughly 15min and no issuesIMG_2929.JPEG


stress test passed.PNG

Still feels it is not 100% stable.
We need better driver AMD.


I think I found a solution through these forums… set Radeon chill fps min to 140 and max to 180 , go to tuning and set the 3D clock to min 2000 max 2200 , Atleast in gaming this seems to have solved the issue 


Soo, after all, it just was PSU...

Power spikes of 600+ watts, which EVGA 850 just cant handle

Upgraded to 1000W and all works really really well


I can confirm that...had a similar Problem because i used the daisy chained standard PCI-E cable from my HX850i.

OCCT Powertest causes the PC to reboot instantly and sometimes it rebooted while gaming.

Works fine after i changed the powersupply of the GPU from one  to two cables...

Thank you so much. Just bought a 6900XT from ASROCK and I was having issues where Oculus Home was glitchy and some games would cause my computer to power off. 1050W supply and GPU has 3 8-pin ports and I was using 2 split cables (1 12-pin port on power supply = 2 8-pin PCIe plugs) so after seeing your solution I connected my spare cable to the last port and connected one each to my GPU. Seems to have fixed it since the VR glitches are gone and Blade & Sorcery no longer kills my computer.


Don't be to quick to say its fixed i did the same as you. The problem will return as the main problems are the Adrenaline software/drivers. If it returns you need to run an older adrenaline.

Journeyman III

Are there two GPU connectors on a single GPU power cable, or are there two separate cables? Because you run the risk of overloading one of the PSU rails with a GPU that powerful. If possible, switch to 2 cables with a single connector each.

Adept II

Check if the PCIe connectors from PSU are sepparated and no Daisy-Chained, because 1 cable separted in 2 only can handle 200w+-. Also, check temperatures as well, who knows.

And... if u can, try w/ OCCT PSU test for a while, just to discard a PSU issue. During test, check tmps as well.

AMD Ryzen 5800X3D |MSI X570 Unify| PowerColor Red Devil RX6750 XT | 32GB RAM 3200 Mhz