cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Toast21
Adept I
Adept I

6900XT causing PC to reboot while gaming

Ever since I upgraded my gpu from 2080super to 6900xt I get random reboots when gaming. I can be fine for 3 hours and it will reboot the system without warning. At first I thought it was the psu (750w Corsair) but I upgraded that to a 1000w Corsair psu and same problem. Gpu temps stay below 85c and cpu stays below 55c. When I had my 2080 I never experienced such problems. I deleted the nvidia drivers before installing the 6900xt too.

msi z490 gaming edge wifi 

i7 10700k

corsair rm1000 psu

gigabyte 6900xt

32gb Corsair vengeance 

Any help? I don’t know what else to do to trouble shoot this, I get no warning when it reboots, when it is running it runs great. 

28 Replies
marko021994
Journeyman III
Journeyman III

Re: 6900XT causing PC to reboot while gaming

Hello! I have the same problem as you, have you solved it by chance?

0 Kudos
mackbolan777
Forerunner
Forerunner

Re: 6900XT causing PC to reboot while gaming

I have the RX 6800 and no issue so far. However, the basics apply. Did you use DDU to remove the Nvidia and now the AMD drivers in safe mode? Have you looked in "Event Viewer" to see what crashed? Error code, etc. Start there and post back.

"It worked before you broke it!"
0 Kudos
ninja750
Journeyman III
Journeyman III

Re: 6900XT causing PC to reboot while gaming

any game the same issue?

0 Kudos
Toast21
Adept I
Adept I

Re: 6900XT causing PC to reboot while gaming

What exactly should I post from event viewer? I’m unfamiliar with that or how to use it.

I erased all drivers earlier with ddu and the amd tool and reinstalled, and still have the same problem. I only play cod modern warfare right now, I don’t have any other games to test it on. it’s really weird because I can play for like 3 hours straight no problem and out of nowhere this happens!! I’m thinking of reinstalling windows but I don’t know if that’s even a possible solution at this point 

0 Kudos
delevero
Adept III
Adept III

Re: 6900XT causing PC to reboot while gaming

I have the excact same problem with computer that during gameplay turn it self off without warning..
And its not a heating issue and i also ran stability tests, bechmark test ect but they do not crash the computer so my system is able to handle max load and so on.. but though it turn off randomly in all games.    my gpu 6900xt and cpu 5900x cpu .

one thing that help a little was to disconnect my vr headset from the computer ( pull out all cables ) then i could play for longer before the crash.

I have now reverted to a bios named F30 from F31 hoping that the computer maybe be more stable now.

I read on the forum that people are talking about a new bios update on the way that should fix some kind of hybrid sleep mode s3 so maybe they have a fix.  https://www.techpowerup.com/276833/amd-announces-agesa-1-1-9-0-firmware-updates-improve-fclk-oc-stab...
So i think check if there are bios update and apply it when avaliable that is properbly the only thing that will fix this problem
( and maybe your video card drives as well ).
My guess is that the problem we experience could be releated to some kind of sleep mode that have a bug and trigger a shutdown

Unfortunatly a Bios update is not avaliable for my motherboard yet
https://www.gigabyte.com/Motherboard/X570-AORUS-PRO-rev-10/support#support-dl-driver

0 Kudos
mackbolan777
Forerunner
Forerunner

Re: 6900XT causing PC to reboot while gaming

You're looking for the error code that will be about a minute prior to the probable code 41, Kernel-Power System, which indicates a hard reboot happened or crash. The should be a code like "bug check 1001" that would be a driver failure or it may actually say that it was AMD Radeon that crashed. You'll find it under "Event Viewer, Local", look for critical errors in the last hour to 24 hours and warnings that coincide with the time of the crash or slightly before. "Windows Logs" has tabs for "Application" and "System", both would have the same type of info to look for. 

However, you can try this. These cards have a wide GPU clock range and sort of "wonky" settings out of the box in general. Go into the Adrenaline software to the "Tuning" area. Select "Automatic" in the overclocking part and accept the meaningless warning. No fear, nothing bad will happen. Select "undervolt GPU" and write the number down. Select "overclock GPU" and write that number down. 

Select "Manual" in the same area and enable all the disabled settings. Now manually enter the lower voltage in the box for it or slide the bar until it matches what you wrote down. Set the max GPU clock to that overclock number you got before. Set the minimum to 100Mhz less than the max. You can do this with stock clocks as well, just make sure the min clock is within 100Mhz of the max. Select the "power limit" and slide that to max. This will allow the card to add more voltage if needed under load only. Finally adjust your fans to disable "zero RPM" and you can move the curve up some or leave it be for now. Just make sure the "zero RPM" is off.

So what we did is minimize the clock fluctuation and voltage spiking that occurs during clock speed cycling, which should stabilize the card. It will also make the card really work as intended. I included a Screen shot of my settings for my RX 6800, which is just to show the screen you will be working with. My settings will be different than the 6900 obviously, however the screen and opRX 6800 Settings.pngtions are identical.

"It worked before you broke it!"
0 Kudos
Coffeecat
Adept II
Adept II

Re: 6900XT causing PC to reboot while gaming

mackbolan777
Forerunner
Forerunner

Re: 6900XT causing PC to reboot while gaming

@Coffeecat  has an idea too. Test the RAM. Not the first time corsair had a botched stick. Run Memtest X64 or swap sticks out until you find the bad ones.

"It worked before you broke it!"
0 Kudos
delevero
Adept III
Adept III

Re: 6900XT causing PC to reboot while gaming

I had some success using an older bios update, and in windows 10 power management plan i selected standard/normal and entered into advanced mode and disabled some hybrid power saving.
I was able to play for 2 houres without a  crash.
I dont know if this solved the problem or if i was just lucky.