Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

RX 6800 XT Micro Stuttering

Hello guys,

since I got my RX 6800 XT I got a lot of problems with micro stuttering in all games. (from Warzone to CS:GO to PUBG)
playing onlinegames with this makes almost no sense.

I tryed everything but I cant find a solution....

I also reinstalled my computer, installed windows etc. the only thing i could fix was flimmering of my monitors enableing fTPM in BIOS.
However I cant fix those stuttering and I am freaking out.....


Like I said windows is fresh installed, drivers etc. BIos is also updated

  • Prozessor (CPU): AMD Ryzen 7 3700X
  • Arbeitsspeicher (RAM): 32GB
  • Mainboard: Gigabyte X470 Aorus Gaming 5 WIFI AMD
  • Netzteil: Gigabyte P850GM 850W ATX Netzteil, 80+ Gold, voll modular
  • Gehäuse: …Lian Li
  • Grafikkarte: … RX6800XT
  • HDD / SSD: HDD 500GB / SSD 500GB / SSD 1000GB
  • Bildschirme: 1: AOC Gaming CQ27G2U 27 Zoll QHD Curved Monitor 144Gh, 1ms, FreeSync Premium / 2: AOC Gaming CU34G2... (Free-Sync...)

Does someone has a solution for this?


Im living with this more then 1 year but now the only thing I see is to sell my RX 6800 XT and go back to Nvidea if I cant find this.....

Please help.



6 Replies

The stutter was introduced several driver updates ago and has not been corrected.  My AIB 6900 xt also stutters constantly while gaming which is very annoying.  I have filed multiple bug reports with AMD using their reporting tool but they never seem to care as they same issues continue to carry over with each subsequent driver revision. 

I can play the same games on my laptop that has a rtx 3060 and everything is fine with the game play and display quality.  AMD can't even release a driver to fix the overlay corruption they created after 22.5.1 but they did fix the font corruption that was shown in kodi.

I'm on a notification list for the rtx 4090 so I might just go ahead and jump back then sell this card and eat the difference to stop this junk.  I'm also going back to Intel for my next cpu as I've put up with more than enough junk with the issues with my 5950x and its x570 motherboard with their lack of AGESA updates.




Hello, try downloading the latencymon utility and run for 10 -15 seconds (during PC downtime, that is, turn on the PC, let the components boot up and run latencymon and press the play button, wait 10-15 seconds and stop, if there are no problems in the software or drivers, the readings should be in the green zone and the delay should be minimal if some driver behaves badly, the utility will show a delay. If everything is normal, you need to look for the reason further. I have disabled fTP M in the bios, since amd had problems with it, it seems like they were solved, but I don't risk turning it on, I installed windows 10 pro before, I didn't like it because of staters, installed ltsc assembly, and configured it for myself on the Internet there are type guides for system settings. There may also be a problem in software that displays statistics about components and FPS (such as msi afterburner) if you enable the display of statistics for each of the cores, staters are possible, and if you check the box showing only the processor as a whole and not for each of the cores, staters disappear. The fewer statistics and the less frequently they are updated, the less the CPU is loaded. Again, staters can be associated with any utilities, or steam origin overlay. I had staters after buying rx6900xt, at first then, I just used the utility to switch the bios (there are two of them on the video card from my vendor) quiet and productive, and the problem went away, the stater was due to the fact that the frequency every 5-10 seconds dropped to 50 MHz, regardless of the load, and again boosted to 2000+ and so on indefinitely, there are no problems now. Surprisingly, there is such a game dying light the first part, surprisingly it works sooo stable, again I limit the performance to 117fps (120hz monitor) and the frame-time schedule is very direct, although the game works on direct x 11. Try unplugging one of the monitors and completely unplugging the cord from the graphics card.1.jpg


Are you perhaps using Instant Replay and or/ Recording Desktop while gaming? 

Just something I found out brother, TURN OFF INSTANT REPLAY, TURN OFF RECORD DESKTOP. 

AMD Encoders are completely borked right now. Enhanced Filtering Setting especially causes stuttering at the moment.

Download and install WHQL AMD Adrenaline driver and MINIMAL INSTALL until next driver which should be fixing the issues.

Adept I

hello guys, I had the same problems and tested everything out, really everything until I found out that rolling back to amd adrenalin 22.5.1 fixed my issues and not only that you need to set your min frequency (MHz) in the amd software to the right as much as you can, in my case after I apply it it changes automatically to 2500, dont forget to apply! all my lags stutter whatever are gone, I had massive stutters in all games it was unplayable, destiny 2 was the worst experience ever 



some people say you need at least have it over 1500 MHz, I just let it completely to the right. Also you can disabling HPET just try it on and off what works better for you. if you want donwload msi afterburner and go to the settings and scroll down until you see amd compatibility properties and check disable ULPS, just try it and see what works best for you on or off. disable svm in the bios, try it off/on. in the bios you can also try to put your pcie 1 where you graphic card is set from auto to gen3/4 you need to try again what works best for you, set your xmp profile in your bios for your ddr4 module to gain the maximum performance out of your ddr4 module and update your bios to the latest, my last tip is disable fTPM/tmp/secureboot, again try what works best for you on/off, but for me the roll back to 22.5.1 and the min frequency change was my savior. also when your game is crashing dont forget to set the min frequency again and apply it! it sets to default when amd adrenalin/game is crashing


my system: amd 5600 with the box cooler // radeon rx asrock phantom gaming 6800 // msi b550 gaming plus // 16gb ddr4 3600 patriot viper // psu coolermaster 700 watt power supply // Western Digital WD_BLACK SN850X NVMe SSD 1TB M.2 2280 // Samsung 860 Evo 500GB 2.5 - SSD

Adept I

Hello guys, I tried everything like from morepowertool, disable ulps, changing adrenalin settings and reinstall/deinstall adrenalin/chipset driver and so many other things and nothing helped, but finally I found the problem! It was in the bios settings of my msi b550 gaming plus motherboard, press F7 or click on advanced in the top and go into overclocking\advanced cpu configuration\amd cbs and disable global c-state control, this crap caused so many problems for me like dips in fps stutters lags and so on, also you can go into device manager\system devices\high precision event timer\ right click\disable device. And you can run your minimum frequenz (Mhz) clock 100 lower than your max frequenz (Mhz) clock in the adrenalin settings. I tested elden ring 60 fps drops to 34 fps and so on, gpu load dropped to 0%. With that disabled elden ring runs perfect at 60 fps and my gpu load dont fall into 0% anymore, sure elden ring drops sometimes to 59 fps or could drop a little bit below in some scenes but thats normal! My cpu load is now by 30-60%, before it was by 4%. I hope i could help you with that.