cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

alseu
Challenger

RX 5700 XT memory clock stuck causing high temps when idle

My RX 5700 XT memory clocks are stuck at 875 mhz (according to wattman) and 1750 mhz (according to gpu-z) at all times - when gaming and when idle in windows with nothing running on the background. Problem persists on a fresh adrenalin driver install without any changes made after installation. Memory being stuck on it's max state causes higher power consumption than intended when system is idle and it leads to 58-68 celcius temperatures even when nothing is running on a system (not even a movie or youtube). Gpu fan is running at 600-700 rmp at that time on a well ventilated system (2* 140mm fans intake +2* 140 mm exhaust), ambient temperature is 24 celcius. I tried clean driver installation, used DDU (display driver uninstaller) and AMD cleanup utility the other time, another displayport cable, tried to disable all windows fancy effects - all that to no avail. Manually changing refresh rate on the monitor to 120 hz from 144hz fixes the issue and gddr6 memory get's unstuck and becomes able to clock down when idle - from 875 mhz to 100 mhz (according to wattman). The monitor is 2560*1440 144hz connected via displayport 1.2. Manually changing refresh rate to 100hz or to 75hz using 2560*1440 resolution still leads to gddr6 memory clocks being stuck at their max state.
Steps to reproduce:
1) download windows 10 install files from Microsoft official site, create bootable usb drive and perform fresh system installation.
2) download radeon software adrenalin edition 19.7.2 and install the driver
3) install the monitor driver from the official site
4) restart computer after driver installation get's completed
5) open wattman in radeon settings
6) make sure there are no background processes that could be demanding on graphical side
7) check memory clock and temperatures of the card in wattman - gddr6 memory clock is at 875 mhz and temperatures are at nearly 60 degrees celcius mark
8) open windows settings - display - additional display properties and set monitor refresh rate down to 75 hz or 100 hz (2560*1440 resolution)
9) check memory clocks and temperatures in wattman - there are no changes, memory is still at 875 mhz
10) open windows settings - display - additional display properties and set monitor refresh rate to 120hz 2560*1440 resolution
11) check memory clocks and temperatures in wattman - memory is now able to clock down to 100 mhz , power consumption in idle state has significantly dropped too, temperatures are slowly going lower, gpu fan remains 600-700 rpm speed.
Turning freesync, gpu scale on/off, changing colour depth leads to no avail. 
I reported about the issue directly to AMD but would like to know if anyone with a similar problem has found better solution than turning down native monitor refresh rate.
1 Solution
Matt_AMD
Community Manager

I checked with the product team and their feedback is that depending on specific display configurations (resolution and refresh rate combinations) and background tasks, RX 5000 Series GPUs may maintain memory frequency to ensure an optimal user experience. This behavior is expected and does not impact the RX 5000 GPU in any way.

View solution in original post

186 Replies

I have already tried with 1.5 DisplayPort cable - no changes.

0 Likes

On 19.8.2 the memory and temp is normal for me on 19.10.2 it raises to maximum... Maybe try 19.8.2 if you want, even it isnt the right solution long term. To be honest if you still can rma the card i would do it.

0 Likes

I'm not very technical, but in my case it had to do with using two monitors. Both connected via displayport. If I only use one monitor the memory clock is unlocked. If I use both, memory clock is locked at 875 even at idle. Currently, I'm only using my 144hz monitor until there is is true fix for this issue. Using adrenaline 19.10.2, non-optional version.

0 Likes
oğuz
Adept I

After some research, I found out that this has been around for years. I have learned that this is necessary for the 144 Hz and 240 Hz frequency. So this is not a problem, just a necessity. If you're having trouble with this, I suggest you run it at 120 Hz.
You can also look here;

https://linustechtips.com/main/topic/355108-144hz-monitor-causing-max-memory-clock/ 

Is it also necessary for 75 Hz frequency? 

0 Likes

No, Only 144 Hz and higher frequencies.

0 Likes

So why it happens when I set 75hz on my monitor ? (on 60hz everything is fine).

0 Likes

Reset all radeon settings and restart your pc

0 Likes

Didn't helped

0 Likes

120hz doesnt work, 60hz doesnt work. And no my Vega 64 never had problem.

Nor rtx 2080.Only gtx 1080 for a while but nvidia fixed it.

0 Likes
drallim
Elite

Guys check out this reddit thread. People are reporting success vs this issue with single monitors. Dual monitor issue is not addressed though.

https://www.reddit.com/r/Amd/comments/dr5bxt/i_solved_my_max_memory_clocks_at_144hz_problem/ 

Thank you drallim, this has fixed the issue for me

0 Likes

Confirm, it works. I use LG 32gk650f and RX 5700 XT. Maybie AMD can implement this in their drivers somehow.

0 Likes

On my aoc c24g1 and RX580 work for my   .

I created a new resolution of 144 Hz in the CPU program with the LCD standard parameter, memory clock speed decreased

RX 7900 GRE, I5 13600K, asrock Z690, 32gb ddr4 4000mhz.
0 Likes
oğuz
Adept I

Permanently Solution; Set 120 Hz.

0 Likes
phill4444
Adept I

If i set my Monitors from 60 to 55 hz, it clocks down, which is an unfortunate solution.

0 Likes

Hopefully this will be fixed once and for all by AMD in next driver revision.

0 Likes

Yep, i also hope they noticed that i did not had this problem with an earlier driver (19.8.2), with that, i could run both on 60hz with normal values. Any driver above, the memory runs up to maximum.

0 Likes
phill4444
Adept I

My workaraound for now is to run the second monitor on the IGPU, i can now use both monitors on normal values...but yea...not the ideal solution i hope amd will do something

0 Likes
Matt_AMD
Community Manager

Driver engineering have looked into this and confirmed that it is expected behaviour for the memory clock of the 5700 XT to run at 875Mhz when using 144HZ refresh rate.

0 Likes

It's not normal... also Drallim gave us fix for this issue. 

Hi Matt,

On my monitor (75Hz AOC Q3279VWF) memory clocks are stuck at 875 Mhz (when I lower the refresh rate to 60hz memory clocks idle at 100mhz).

Could you please ask the driver engineering team if this kind of behaviour is also expected on 75hz monitors?

My GPU is Sapphire RX 5700 XT NITRO+

Thanks in advance.

Can you send me a private message with the EDID information for your monitor and i will look into it?

0 Likes

Done.

0 Likes

Hey Matt,

Any news from driver engineering team?

My sapphire rx5700xt nitro+ memory is stuck at 875mhz on all refresh rates. (144hz,120hz or 60hz) with acer ed323qurabipx.

I can say thats incorrect. My 144hz monitor in both standard and HDR has a 100mhz memory idle only when used alone. When my 2nd monitor is powered on, memory runs at the max set speed.

2019.11.06-21.57.png

2019.11.06-21.59_01.png

0 Likes

This is an issue, and need a drivers fix. It's not accetable this solution.
144hz is a standard for gaming monitor and at idle the memory clock must goes down, come on  !

Yeah it's normal when running a 3D app or something, but this is not normal when i'm just sitting on my desktop and browsing the web or doing nothing. My computer just sitting on idle doing nothing and the memory is running maxed out 1750MHz to the point that the fans start spinning like i'm in a game...the memory temp reaches almost 75 C just with the card sitting idle. Don't insult our common sense with this kind of treatment telling us that this is expected behavior. This is a bug with 75Hz and 144Hz on some monitors and your QA team must do a better job.

You are absolutelly right. On my previous GTX 1060 there is no issuies on 144 Hz, power consumption was the same or almost the same as 60 Hz.

0 Likes

Yeah, I think this is a lazy workaround in their drivers in their attept to fix flickering on some 144Hz monitors. Surely it's not supposed to run at Max memory clocks, wasting energy (it draws 30w instead of ~6w) causing to card to run hot when idling. This is expected behavior in the way that it was designed to run like this to prevent some other issues but it's not an acceptable solution imho. They need to proper fix the 144hz memory clocks.

0 Likes

This is definitely not the normal behavior of AMD graphics cards, the above method results in a decrease in memory clock speed at 144 Hz.
On my RX580 I also dropped to 300MHz

RX 7900 GRE, I5 13600K, asrock Z690, 32gb ddr4 4000mhz.
0 Likes

Is there a reason why, though?   I can understand that this is not a bug or glitch or anything, but why would this card need to run like this, in this situation?  Surely it's powerful enough to run 144hz without maxing out the memory clock constantly.

0 Likes
nin
Adept II

i like this "its an expected behavior" more than i should , its quiet funny how often i read this about the new navi gen

chyang
Journeyman III

Just confirming what everyone else is seeing.   And reporting my own issue.   I have a Gigabyte 5700XT Gaming OC.   I am using the latest driver 19.11.3. 

I run a dual monitor setup.   32" 4K 60Hz refresh rate  + 27"  2K 60Hz refresh rate.   MCLK is stuck at 875MHZ.  The GPU temperature at idle is between 50-60C.   The fan spins off and on to bring is to the low 50s or if am lucky down to 49. 

When using either monitor at single monitor setup,  the MCLK drops to 100-300mhz.   However, temperature stays 50-55C.  The fan does not spin at all, so the idle temperatures stays above 50.   


Curiously when I am gaming in 4K 60Hz, temperature ranges 70-75C, which is quite good.   But for whatever reason the idle temperature could never go down to the low 40C even with a single monitory setup. 

It seems like there is an issue with the driver which causes the MCLK to get suck at maximum.   But still high idle temperature (50C +) even when MCLK drops to 100Mhz?  Maybe there is a problem with my card.   

There is no problem with your card. All the cards behave this way when using a dual monitor setup or single monitor with 144Hz refresh rate.

The official response from the software engineering team is that this is the expected behavior and I think this this is bulls@#$.

I don't even have words to express my disappointment, never gonna buy a gpu again in the first month the reviews were all pointless none saw this problems none are talking about them, they are probably using rtx cards and don't care about amd they just test them in a few games and that's why they miss all the problems that come with using them everyday or they are just plain stupid and don't see high mem clocks and high temps at idle.

Two monitors do not configure at all, what would the frequencies work correctly?

0 Likes

Techpowerup tests multi-monitor power usage but you're right, most reviews are worthless, they just bench tomb raider and far cry and call it a day. None of them tested the AA modes to see if they worked (they don't), none of them mentioned that display scaling and VSR was completely broken (now fixed), etc.

0 Likes

My card doesnt downclock memory even after disconnecting second monitor and lowering refresh rate to 100hz or 60 hz. So yeah unless so called expected behavior is idling at 60w+ they just ignoring it. As lets be honest there are still more concerning bugs 5 months after release.Funny thing is nvidia used to have same problem in 2015 and fixed it with driver update causing all my freesync monitors to run at 143hz ever since.(gtx 980,1080 or rtx 2080)

0 Likes

Yeah also having two monitors connected seems to max out the memory clock...I also tried to put refresh rate of my monitor to 143Hz with CRU but it didn't work, the screen goes black....also tried from the radeon settings with custom resolution but that says something about custom resolution not supported. Probably i'm a noob and don't know how to input all the correct timings and values. But than again i shouldn't  know all these things, AMD is supposed to make it work.

0 Likes

I tried custom refresh rates as well,no change.However i found out that if i run 1, 2 or 3 monitors at 1080p @ 60hz memory will downclock to 200mhz. But if run native 1440p even with one monitor memory will never downclock no matter what refresh rate.

0 Likes