Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Record doesn't work

I haven't been able to get record to work since the February drivers. 5 Drivers in a row without working record and no one seems to give a damn because I can't get anyone to even answer my question? 

I get better support for my cable TV company ..... and they are one of the worst rated in the US 

How can you expect me to buy into Navi 2 when you still can't get Navi 1 to work right? And I can't get any support for what I just bought last November

12 Replies
Adept I

Welcome to the club

I found lots of posts online of people having the same problem. I also tried to find out if anyone at all is able to record with Radeon software at the moment – I never got a positive reply to that question online, and every friend with an AMD card that I asked to try it, said that it doesn't work for them either.

It really seems completely broken, and for many months now as you say. Maybe AMD doesnn't hear or care about the bug because barely anyone even tries using the feature? I think most people who record use OBS or some other software anyway.

Are you sure you could still record with January drivers? For me, it's been broken for much longer, probably as far back as early 2019. Maybe it's a configuration problem that just breaks the feature at some point, and then you can't get it back to working.


I can confirm that the record feature works for me.

Only setting I need to turn on to enable it is Record Desktop.

The setting is found under Setting > General > Recording

This is with the latest 20.8.1 drivers and the latest windows version.


OK, so it works at least for some people, that's good to know. What kind of video card do you have?

I have drivers 20.8.1, Windows 10 version 2004, and a Radeon RX 590. Record Desktop is active, the setting doesn't make a difference. It creates a video file with a few Bytes of header information, then stops and crashes.

Screenshots work fine, by the way.


I'm using a 5700 XT.

If your happy enough playing with the registry you can enable logs to try and find the issue.

1. Start regedit and go the following key (or path): Computer\HKEY_CURRENT_USER\Software\AMD\DVR\

2. Right click DVR and create a key (Using New -> Key), name it LOG

3. Go into the 'LOG' key (should look like a folder), right click New -> DWORD (32-Bit) value.

4. Set the name to log_enabled, double click it and set it to 1, hex or decimal, it's the same in this case.

5. Repeat the step 3 and 4 but instead of naming the dword value log_enabled, name it log_minpriority and set it to 0 by double clicking it as in the step before
6. Open task manager and kill the following processes in this order: amdow.exe (AMD ReLive: Desktop Overlay) and amddvr.exe (AMD ReLive: Host Application).

7. Open Radeon Settings and head to the ReLive section, then in the ReLive tab section, toggle ReLive by setting it off and on so amddvr starts up

8. Head to the following directory: C:\Users\YourUserName\AppData\Local\AMD\CN (%userprofile%\AppData\Local\AMD\CN) and order the logs by date (most recent).

Open the log and you should see what's causing your ReLive to not record.


Thanks for the logging hint. In a thread about the same bug that I found a few months ago, someone gave the same suggestion, and people posted their logs. From what I remember all of them, including mine, showed that recording just silently crashed right after it started, without logging anything suspicious.

I re-enabled logging again to see once more what the log looks like (I think your instructions are slightly outdated, "ReLive" as such doesn't exist anymore in the driver UI, and I can't find amddvr.exe either) but here's the log:

Thread Id:4156 2020:08:16-01:34:35 DEBUG dvrmanager_component Toggle Recording r - 

And there it just stops, some non-critically-sounding warnings and no entry about why the recording stopped. An .mp4 file gets created in the target directory every time I try to record, but it's always only 44 Bytes in size, and this is all it contains:

Imgur: The magic of the Internet 

This has been the exact same for me for much more than a year now.


There is an audio warning right before it ends and your recording 6 audio channels so it might be the same issue longjohn had.

Have you tried setting the audio recording to stereo?

Well, fancy that! Thus ends a year-long odyssey, it works on Stereo. Thank you for that!

I even remember googling that audio warning (it was still in my search history) and concluding that it's a non-critical thing that can commonly happen at the beginning of a capture. The Core Audio documentation also doesn't imply that it's grounds for panic. If I understand it correctly, the flag is just set to notify that there might be audio glitches due to missing samples. The stickler in me also notes that if AMD is going to abort the capture, they should at least log explicitly when and why.

This might also explain the time at which the problem started for me, it might have been when I installed a new sound card (Sound Blaster ZxR), so my audio settings changed. Surround sound setups are not uncommon these days, and "Auto" is the default setting for AMD's audio recording feature, so now I wonder if this bug affects everyone with a surround setup or maybe just where Creative drivers are involved?

I still have no idea how to possibly report this as a bug to AMD, though the new feedback feature only covers game-specific issue, not generic drive ones.

But thank you for leading me onto the right track!


I'm having the same issue and after I changed the audio from Auto to Stereo in the settings as users below these recommendations suggested, and it still doesn't work. Here's what my log says:
I'm no computer fiend so I don't know what that problem could possibly be. Could someone help me decifer that?

Adept I

Actually all I had to do to make it work was go into Settings .... General Tab .... In the Audio Channels section change it from Auto to Stereo

Auto worked fine on all drivers through the February ones but all those after February if you have it set to Auto it kicks you out of the recording ..... Why AMD didn't know this is the EXACT reason I'm buying an Ampere graphics card for the new system I built as soon as it is released ..... I'm an Electronics Engineer (As well as an AMD stockholder) and this kind of Support is simply UNACCEPTABLE 

it works for me .. like the guy below said .. go to general / audio secction  change the audio chanel from auto to stereo . now im goodd.. i had that problem since the begining of my purchase. wich it was 10 month ago . now im good . thanks. dudeeee. im recording now

Journeyman III

Another thing to try is to reset to factory settings. It's under Settings -> System. This made the recording working for me.

Journeyman III

my recording tab disappeared completely and all of my hotkeys are gone unknown.png here u can see the recording tabhere u can see the recording taband here is my amd driver home page loooks likeand here is my amd driver home page loooks like