Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

[R7250X] Windows fails to load drivers / black screen



- AMD Graphics Card: Sapphire R7 250X 1GB

- Desktop

- OS: currently installed: Windows 8.1 x64 Pro, also tried Windows 10 x64 Pro

- Drivers installed: currently using:, also tried 17.7.1, also tried under Win10: 18.5.1

- Display: Samsung S32D850T; currently connected via DVI, also tried HDMI, DP

- Motherboard: AsRock 980DE3/U3S3; BIOS 1.60 (it was never flashed)

- CPU: AMD FX-6300; not overclocked

- PSU: Chieftec CTB-500S

- RAM: 4x4 GB Kingston DDR3-1333

- 1 HDD, 1 SSD, 1 floppy

Prior issues:

I have used the system for 3 years without much of a problem - I have had a few bluescreens (maybe 10 during this time), all related to AMD stuff. I have used Win 8.1 at the begining, then upgraded to Windows 10.

Current issue:

After a clean install of Windows late September, things started to fall apart. I have tried to clean install after that several times, both Win 8.1 and Win 10, with more or less the same results. The screen starts to flash on the login screen or immediately after logging in into Windows (automated login through netplwiz). A soft restart (restart from Windows) helps, but a hard restart (pressing the restart lid button) does not.

Under Windows 10 the R7250X seems to start giving signal at 1920x1080 (bottom and right sides are black), then it apparently rescales up to 2560x1440 (the entire desktop is visible for a short time), then goes back to black. These steps repeat in cycles. After 15-30 seconds the desktop remains either visible, but not reactive, or it remains black. Sometimes the Windows logo (Start menu) in the lower left is visible on this black background. More often, the login process does not finish, and I find my self on the login screen with these flashes. The mouse pointer is visible and movable. Sometimes there is a pop-up message, briefly visible, saying that the graphics drivers could not have been loaded. When I disconnect and reconnect devices, the Windows sounds can be heard, meaning that the system is up and running otherwise.

Under Windows 8.1 the system starts up seemingly in a normal manner, but using any kind of GPU acceleration (i.e. starting Steam, with GPU acceleration enabled, or starting Opera for browsing) brings up the flashing/black screen issue, as I have described in under Windows 10. The only difference is, that Windows does not eject me back to the login screen. Sometimes there is a pop-up message saying "unknown hard error", and nothing else. Sometimes the screen starts to flash during the login process.

The PC is usable after a soft restart both under Win 8.1 and Win 10.

I have tried the following (what comes to my mind):

- disconnecting the floppy drive, disabling floppy controller thru BIOS;

- disconnecting the HDD;

- clean install of Windows (Win10 three times, and Win 8.1 twice);

- reinstalling different GPU drivers over dozens of times;

- removing/reinstalling monitor driver...

to no avail.

There are newer BIOS versions available for the motherboard, but I do not wish to flash it, as it was working up until now with P1.60.

Any suggestions on how to proceed is appreciated.


The Windows 8.1 error message looks like this:


1 Reply
Journeyman III

Apparently, it was an overclocking issue nonetheless. Changing the northbridge frequency manually from the BIOS-offered default 2200 to 2000, and reducing its voltage from the BIOS-offered default 1.3V to 1.1V solved the problem. Never touched these settings before. I have found a hint that this might be the root of my problem on the Overclockers Forum under the thread name "FX-6300 with CPU NB Freq set to 2200 or 2400 causes video issues".