Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Problem with switchable graphics(fps problem)

Hello guys, im trying to run a very simple game which should run smoothly. The game is urban terror, a fps game with low requeriments.

This is kinda a new laptop,bought it whitout hardrive and added it mine from the old laptop.

Cleaned the hardrive and installed a new iso Windows.

Drivers are up to date, tried the vga recommended from acer website and the one recommended on amd's.

Also did all those options of high performance on cataclyst and amd settings. It shows the game as checked on high performance.

I have tried diferente configs with low resolutions and other low cfg tweaks.

It should get me the max 125 fps wih ease , and all it gives me are super unstable 30\40\50\60 fps.

What i feel is happening is all the work is being done by the integrated card(R4) and not by the adapted one (R5 m335). The info on the performance tab is confusing to me but it seems the r5 is not being used at all.

Can´t seem to disable the integrated card as seems the r5 can t be used whithout the r4.

Don´t know what to try next. Im a bit lost.
Any ideas guys? Thanks in advance.

Specs and screenshots below:


Acer aspire E5-722G-6403

Amd quad core processor a5-7310 up to 2.4ghz

Adapted : Amd Radeon R5 M335 2gb

Integrated one : AMD Radeon R4

4gb ram

Software :

Win 10

updated drivers

Version 24.20.11016.4 on both amd graphic cards


QUake3-urt.exe is the game

This is what appears on the performance tab :

Low config:


High config:

perform 3.PNGperform 3.5.PNG

0 Replies