Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

Bizarre vertical-screen depth issue with 7900XT

Hi folks, I am trying to get my head around a bizarre issue since I installed my new 7900XT this morning.

MY primary display is a Samsung U32H85X 4k, 32 in monitor, which operates at native resolution (3840x2160) and is connected via displayport.

I also use a Second monitor, which is a Sony Bravia 40in TV, which has a native 1080p resolution of 1920x1080). It is connected via HDMI (the only option)

Everything was working just fine until I installed the new card this morning. Since then, the 2nd display compresses the vertical aspect of the image into the top half of the screen (see image1). Interestingly, when I take a screenshot, it misrepresents that everything is OK and shows how it SHOULD be, not how it IS!

I have tried

- autodetecting and applying recommended resolutions
- disconnecting the second monitor, rebooting
- rebooting again
- reconnecting the monitor
- reinstalling drivers
- making sure that all old nVidia drivers were removed (and associated software), then reinstalling drivers
- re-disconnecting, rebooting and reconnecting 2nd monitor

Haven't yet run DDU (forgot as this is my first GC upgrade in almost a decade), but don't see it helping, I imagine this is a driver issue.

Suggestions welcome

1 Solution

I found a solution everyone, at least for me!

I had a new 7900XTX and was having this issue and I too was having it on my 3D capable TV. 

Try this:

Open Adrenalin software and go to Settings>Display>Arrange Displays 

Under Multiple Displays, turn on 3D display mode

It fixed the screen issue for me, shows 1920x1080.  Curiously, the input data on my TV shows it as 10-Bit 3D.  Definitely something with either the Adrenalin software or Windows after the drivers install.  It seems to be doing what it's supposed to do, just need to run some testing. 

Hope this helps others! 



View solution in original post

108 Replies

Page not updated since HD 7970


i'm having the same issue with an lg 42la6130 3d passive capable tv. i've reported this issue two times in the past months and nothing has changed



On my Sony TV (KDL-46HX729), I get no noticeable flicker but may be because it's active 3D.  I am locked to 30Hz though.  I am going to try troubleshooting more today since I am off.  I see one person found a "fix" but seems you may have to plug and unplug the HDMI sometimes which I rather find a more permanent solution.


I'll keep everyone updated with what I find but everyone should put a ticket in with AMD so their techs know of the software bug. 


YES , people sometime think amd read this forum to solve bugs , but there is a tool for that


My projector is also active 3D and it's possible to get a similar result to this by enabling top/bottom input and then disabling 3D output (pass single "eye" out). But looks like that results in the same problems in the end, you're seeing 30hz out (eek) so basically it's just not flickering because it's dropping the other 30hz of frames. Glad that works automagically for you, but I'd guess you've still got the same compressed resolution unless your TV and the GPU are negotiating frame-packed / sequential output because you're not using a windows version from 15 years ago like I am!

The only real fix I've had to get the display working at a reasonable frame rate (1080p60) is using some software to fool AMD's drivers into behaving like a proper display (like BlackVen0m is doing with displayfusion) or using a dongle to send an EDID without any 3d capability allowed. I'm just going to buy one off amazon and unfortunately strongly have to reconsider AMD for the rest of my build. If this kinda crap happens with simple display handling, I can't even imagine what kind of issues I'll run into trying GPU passthrough with an APU and rebar/sam etc.


Hey, what software are you using to fool AMD driver? I want to try it out as well. Even if i have my solution, i want to see how it works with your solution. Thanks


Can't believe it was as simple as this... didn't even know the TV I am using was 3D capable!

Agree that the resulting display is crap - I have very clear vertical lines on the screen making it appear that the interlacing has gone completely wrong, but it's better than half a screen!

Thanks for reporting your solution!


Nevermind, even with Convert 3D > 2D, there's still screen flickering issues, so this unfortunately is not a solution/workaround for me.  **bleep**! It looked so promising. 
[EDIT 2]
I noticed after turning this on in the windows settings, it downgrades the refresh rate from 60hz to 30hz, this is probably why I'm seeing flickering issues on some Youtube videos. 
Okay soo at the surface, this appears to fix the half screen issue. However, I noticed the image is low in brightness and in certain circumstances causes the display to flicker. However, if I go into the settings of my Samsung TV and set "Convert 3D to 2D" it immediately goes brighter like its normal and appears the flickering issues go away. I'm not sure if this can be accepted as an Accepted Solution but more of a legit workaround. Not everyone's tv may have the option to convert 3D > 2D?
Thank you for finding this workaround. I'm giving you a thumbs up but 100% AMD still needs to work on a solution for this within the drivers.


I also have the same result with telling the display to treat the 3D signal as 2D. From there it's up to your display device to figure out how to deal with the missing half of the data. Also why the display reports 30Hz content from a 60Hz source. Some of those tvs that have those awful frame interpolation modes (that make films and 24fps content look like soap operas) may be able to do a half decent job at rendering this all in 60Hz, but I'm still surprised if this 3D display option from windows actually changes the output signal into a proper full 1080p image and it's not the display that's dealing with it as top/bottom content and discarding the junk lower half.

@BlackVenom, I haven't found a piece of software yet to fool the driver, but that's what I would assume DisplayFusion is doing and how ultramon could do it. For what it's worth that's all eyefinity is doing I believe, setting it's own custom resolution and ignoring that the second display is reporting that it is 3D capable.

I've ordered 2 EDID emulators, one a simple forced 1080p60 (supposedly non-3d) dongle that I'll try first, and a more complex one that allows forcing a few different presets via a switch. If the first doesn't work, that should do it, it lists different 1080p modes with and without 3d explicitly. I'll report back when they arrive next week.

Can't wait until you get it, if it works, please go and see if VSR works also. it should give you more than 1080p resolutions in the window's resolution option menu. VSR is important for me because it helps me out, lessening the CPU bottleneck. It works on all other non-3D displays i tried it on, i get the option to go beyond 1080p.

I'm having the same problem but I am going from 1440p to 4k tv and I can't find a fix so annoying


Hi there,

I also had this exact problem and wanted to share that the listed solution is dangerous and can lead to you needing to reinstall Windows or rollback to a restore point if you have one.

I followed the instructions to turn on 3D mode and it immediately bugged out my system. I'm running a Samsung 4k 3D TV as my main monitor and a secondary 1080p standard monitor. After turning on 3D mode it bugged BOTH monitors (TV was just full black screen, secondary was intermittent and when it was displaying, the Windows GUI was intermittently functional to the point of not being able to scroll down a page, or type. Therefore I was unable to reach the 3D mode toggle to turn off 3D mode. There's no easy way of turning it back off if you can't get to that toggle switch.

So anyway, long story short, restoring from a restore point worked to turn it off.

I was able to get around the issue by using an HDMI to DisplayPort adapter. For some reason the driver doesn't seem to mishandle 3D TVs over DisplayPort like it does with HDMI.

AMD has responded to me about a ticket I opened with them and am currently letting them know the issue. Hopefully they'll fix it. But if you need a workaround, hopefully this works for you as well!


Update on the HDMI to DisplayPort adapter workaround: It does work but with some issues. My system intermittently decides not to POST with a VGA error while the adapter is plugged in. If it does pass POST the screen will go blank for a few seconds a few times after login in to Windows.

Also some good news, AMD support responded as follows about this issue to me:

"I am pleased to inform you that the AMD Driver team will be working on these issues in the graphics driver.
I request you to wait for the future update that resolves your issue."

So this will hopefully get fixed!

Good luck all!


This is a workaround, not a solution. In the activation of the 3D setting within windows to which in turn does display a true full screen on 3D TV at 1080p, however it then lowers the hertz to 24hertz. 

This is no doubt a driver issue and AMD are doing nothing about it, given how long reports of this known issue when connecting 3D capable TV's.

Never had this issue when i was on a NVIDIA GC.

It has become my mission to make AMD aware and to release a fix, i do not plan on selling my 3D TV nor do i plan on watching films streaming from my pc to the 3D TV at 24hertz. 

To pay £1600 for a 7900 XTX Liquid Devil to not be able to connect a 3D TV to it via hdmi and receive 1080p at 60hertz... are we asking too much here AMD? 

they need to fix this issue, otherwise i will be returning the 7900XTX and going back to Nvidia.



Hey. Wanted to let you know it should be fixed now with the most recent driver update 23.4.1.

Regards and good luck!


exactly the same for me perfect at boot then split screen! Yeah i can confirm its not related to 1080p monitors! i have a old full hd 1080p TV and its working perfectly! Its because of 3D TVs i am almost 100%. Maybe something that can be fixed through software drivers, or its something else going on with the signal because of 3D TV even if 3D is not enabled. When i have it connected to my 3D TV i get a option in windows where you change resolution it says 3D and you can flick it to ON or OFF, when i do that i get full screen but its on 30 hz or 50 hz and it looks like **bleep** because 3D is on! So AMD is sensing the 3D tv and giving you the option in windows, i do not get that option with nvidia card and i have zero issue with nvidiacard with that TV. So there must be something going on with the signal from the card to 3D TV. Some kind of bug or something. We need to tell AMD about the 3D TVs, that it might be related to that.

I have a fix (a workaround that works) so you get fullscreen!! Go up and read what i wrote, you will find it here! Just search for my name.

Adept I

So I spent a good few hours yesterday trying to solve this issue to no avail.  The frame rate and audio sync on YouTube was unbearable.  I ended up hooking up a portable monitor so I could stress test the GPU to make sure I didn't have one of the affected 7900XTX models.  Good news is that I don't.

Bad news is that I don't have a better solution.  My TV doesn't have a way to just turn off 3D or refuse the 3D signal.  I tried to enable a different driver than Generic PnP Monitor for the display but that didn't work.  Unfortunately, seems we are AMD's mercy for when they fix this issue.  There's probably a very small segment that is using high end cards on 11 year old 3D TV's but I'm sure with enough open tickets, they will fix it. 

My only saving grace is that this new build was to replace my current HTPC that has a 4790K and GTX 1650 when we got our new Sony A95K/L in a few months.  The old system is usable so it looks like I'm just going to be using that until I get the new TV. 

I think you spend more time on this issue than AMD (I didn't see any reply or drivers note on this issue). I hope AMD will show the same effort.

Your solution is temporary but the best available. Thank you for your time.


Yea this is so annoying. I submitted a bug report to AMD within the Adrenaline software. I linked both my original post as well as this one in the bug report for references.  The workaround works to go full screen, but the degradation in image quality and the flickering kind of make it unusable. Hoping they fix this sooner rather than later.

Adept I

Whelp AMD support wasn't helpful at all, this was their response after I provided my TV specs and computer specs, along with both dxdiag.txt and msinfo32.nfo files as requested:

Thank you for providing the details.

In order to narrow down the issue, I would suggset you to please perform the below troubleshooting steps.
1.Please perform the load default settings of your bios and make sure that your system is running on stock settings.
2.Please install latest chipset driver version in your system.
3.Please perform the clean boot of your OS.
4.Please install and run AMD cleanup utility  to remove the existing GPU driver from the system and please install latest GPU driver version 23.1.1 in your system.
Also if the issue still persist then please test your system with 850W PSU since the minimum recommended PSU for this GPU is 800W.
Also please try to connect your TV directly to the system without using receiver if it is feasible for you and let us know the issue status.

Thank you for contacting AMD.

Yes, simply hook up a bigger power supply because everyone has one laying around unused🤦.  They seem to not have really listened to my response at all and replied so generically.  This is my response to them originally:

Good morning,

I have attached a video of the issue as requested along with dxdiag and msinfo32 files while the machine is in 2D and 3D modes.  With the Adrenalin drivers not installed, the card displays the proper resolution.  This also occurs at boot before the driver's are active as BIOS and the Windows logo are full screen.  With Adrenalin drivers installed, this is when it does the half screen issue and the only fix to make it full screen is to enable 3D display in Windows.  The card seems to be sending it out as a 3D signal for some reason and the Adrenalin software has no option to disable it.  If the drivers are not installed, the TV receives a full screen 60Hz signal.  With the drivers installed, it does half screen at 60Hz or full screen at 30Hz with flickering as it is essentially doing every other frame as black (essentially transposing the bottom "blank" image every other frame).  I have also listed the other requested information below:

TV and Connection:  The TV is a Sony Bravia KDL-46HX729 connected through HDMI which first passes through a Sony STR-DN1070 receiver.

Graphics Card: PowerColor 7900XTX Reference Card

Power Supply: Corsair SF750 750W SFX

Motherboard: ASUS ROG STRIX X670E-I GAMING ITX (BIOS: 0822 with a release date of 11/24/2022)

Guess we'll have to wait and see if the next driver fixes it.

EDIT: this was my reply, a bit harsh, but I think justified for spending $1000 on a card I have no use of currently:

Good Morning, 

This is, in all honesty, one of the worse replies I've gotten from a tech company ever.  This is clearly a driver issue with the GPU and has been documented by multiple users on the thread I provided.  This was a fresh install of Windows with a new system, which works fine without the Adrenalin drivers, but has this issue when installed.  There is no other troubleshooting required. It even works fine with the integrated graphics on the CPU if the HDMI cable is hooked into the motherboard itself. 

To suggest using a bigger power supply as a possible fix is just lazy to say the least.  First, a power supply isn't going to be causing a driver issue.  Second, the 800W is RECOMMENDED, not required.  The Corsair SF750 is able to easily push past 750W and is under rated as tested by multiple independent reviewers.  Third, the other components in the build don't get over 300W, and the 7900XTX with my own stress testing never went over 375W, so 750W is plenty of power.

I can install the new driver which is only 3 days newer than the one currently installed, but I can assure you the effects will be the same.  For the record, I used my older GTX 1070 with this new system and guess what?  It works as intended. 

Please, for the sake of everyone experiencing this issue, please escalate to your driver team for a fix.

Thank you for your time

What a godawful response from AMD! I guess they are busy putting out fires (literally) from the current 7900 issues, but seriously, they could take 1 look at this thread and see we've done all the troubleshooting for them and found the cause.


"Support" like that is just sending me ever further away from buying from them again honestly. Absolute pet peeve of mine to be treated like an idiot after spending so much time debugging a problem.

ANYWAY... @BlackVen0m and all, the EDID adapters arrived this morning and I just tried the simplest one. Works. Flawlessly. VSR too. I get a crisp fullscreen 1080p60 and with VSR on, options for 1440p, 3200x1800, 3840x2160 and 5120x2880.

To make it easy for anyone else interested: this simple adaptor is made by "EVanlak". Amazon ASIN is "B07YMS18T7". Searching for that will give some other options, but I just got the 1x 1080p emulator adapter to test. 17euro hardware fix for an AMD driver bug, but hey, at least I can use the card now, and can use the EDID emulator later for something else if they fix it.

Let me know if need any help!

Sorry for being too lazy to scroll up, it's 4:20am and I can't sleep, is this plug and play hardware or do I need any other software/driver?


I already ordered, arriving tomorrow. 

Great! delivery is always a little slow here, but Amazon seem to have it in stock in all their core markets so hopefully this will at least save us pulling our hair out until AMD ever get around to fixing it!

As I stated on another reply, no other software or drivers needed, just plug and play.


Thanks for the info. Ordered a similar adapter and hopefully works for me too. Can't really wait to see if it takes a week or a year for AMD to fix the bug.

I really hope they fix it. And YESSS!! IT WORKS! Great! Thanks for buying and trying! I will order one right away!

Can you please take a screenshot of the one you bought from amazon, take a screenshot of the amazon link and post here, there are so many different ones i cant decide which one that would work.


Do you think this would work? It says 4k 60hz, is that ok even if i only have 1080p native? would this block 3d signal? Skärmbild 2023-01-20 121530.pngSkärmbild 2023-01-20 121755.pngSkärmbild 2023-01-20 121838.png


I had this available locally so got it myself. Works fine for the use I/we needed it for - in the default mode it uses its own general EDID and bypasses the buggy 3D stuff - Also just for science: when used to copy the information from my 3D -capable display it shows the forced buggy top half of the image etc. just like the adapter wouldn't be there at all (good thing in theory).

But in its default mode it works fine and the display works as I'd hope with no downsides apart from needing to pay 25 € for something I shouldn't need to pay a penny and more so needing to spend time troubleshooting.

Thanks again to Osaru for giving this workaround - otherwise I'd already most probably had returned the 7900XTX and switched to a 4080 instead.. for reals.

I think i found the exact model you bought? I searched for "B07YMS18T7" and only this one came up, so i guess its the exact one you use. But maybe the other one i found that is 4k 60hz is a better option? Skärmbild 2023-01-20 123617.png

I was about to say, just copy and paste the number they gave you in Amazon as I did.  That's why they provided it lol

From osura:

To make it easy for anyone else interested: this simple adaptor is made by "EVanlak". Amazon ASIN is "B07YMS18T7".

Amazon Standard Identification Number (ASIN) is a ten-digit alphanumeric code that identifies products on Amazon. It's unique for each product and is assigned when you create a new product in Amazon's catalog.

Sorry, just getting back to this thread now, yeah that EVanlak one is the exact one.

I specifically wanted one that didn't pass any 3D capable information to the GPU and that was one of the most simple I could find. For instance, when I used my other EDID emulator (I think that delock one and mine are the same, exact same housing and packaging just a different brand logo) it is "too clever" and clones the exact EDID that is passed, so it would just continue the problem. The EVanlak one sends its own data (I'll hook it up in a bit to my other machine and decode it) which, as I was hoping, seems to provide no 3D capable information, so all works first time, no software anything else required.

Just plug the dongle directly into the GPU, connect a normal HDMI cable to the end of it, and the cable into your display.

If you have a 4k display I guess would make sense to try the 4k60 part, my projector is only 1080p60 though and I wanted to reduce the amount of possible variables. EVanlak documentation is pretty non-existent too, I just couldn't find anything mentioning 3D at all (a lot of other EDID emulators specifically say they support it, because typically that's what you'd want!), so I thought why not give it a shot and it's worked out. I don't remember if I saw anything about 3D on the 4K dongle, but I would triple check that if you decide to get it instead.

Ok, thanks! I'll just go with the one you bought, I'm not taking any chances! Does the quality drop in any way?


Ok cool, quality is great, no issues there at all.

Really all these devices should do is intercept (maybe disconnect in this case) the DDC (Display Data Channel) line in the HDMI signal that is providing EDID data from the display back to the GPU, and inject their own EDID data stored on a small chip in the dongle itself. I'm no HDMI expert, but as far as I understand it; with the (now fake) knowledge the GPU has about the display, it is responsible for deciphering the data, choosing the resolution and frequency (based on what the user wants), encoding the signal and sending the transmission itself, so the dongle should not affect the image in any way.

I mean, theoretically some bad contact or issues with extremely long cables could occur (for 1080p on cheaply shielded HDMI cables around 10m+), but in that case, not likely related to adding 3cm of signal length in the chain.

(In fact, where before the GPU was having trouble determining that my projector actually works best with locked 60Hz for 1080p and kept defaulting to 59Hz along with the broken image, it happily defaulted straight to 1080p60 and has remained locked there, eliminating some screen tearing I was having with it at 59Hz and 3D mode on but discarded.)

That's GREAT about the 59 now being solid 60, because i ahte that part, my tv wants 59.97 hz something. But i can put it in 60 but it keeps reverting from time to time. Im glad we are getting that fixed finally! 

What do you think AMD can do to fix this issue? It's interesting to know what they need to do to fix it, because right now we need this dongle to do that thing you talked about, but how is that possible through a driver fix, and is it even possible by a software fix? That's the question, what is your guess? First and foremost, They need to bring in a 3D TV to test/recreate this in their office.


Agreed, before this I'd not had troubles with not being able to hit the correct refresh clock for over a decade and a half, going back to CRT days.

As a software engineer of 25+ years, with zero experience in writing drivers, to me the issue is a bug somewhere in the driver package. There will be a check for the properties of a display, setting a flag to say "this is 3d capable", and elsewhere it will be reading that in the pipeline that generates the output signal. Here, instead of checking whether the source content to be displayed should be 3D or not, it's just either forcing the output to always show as Top/Bottom 3D.

Yeah, because i have this option now when it was never there with a RTX 2080 or 1080 TI. So it means it knows its a 3D TV like you said. Skärmbild 2023-01-16 164046.png

Although the EVanlak unit works perfectly for me, I ordered 2 separate devices and have now tested the second one a little over the past couple of days. I need to follow up with this more, will probably document it somewhere that is easier to present than just in this forum, but it has yielded some interesting results, that I wasn't quite expecting.

Simply put, the second device produces the correct signal ALL of the time when generating it's own EDID, even when I choose to generate a 3D capable 1080p EDID! The only one that still has a broken display, is when it clones the EDID from the display. It also doesn't work as elegantly as the EVanlak type for most of my use cases, for instance it will not stay visible as an active display even with the power to the display off.

So I need to spend some time examining the EDIDs and find the difference if there is one, between the emulated 3D capable data and the native 3D capable data from the projector.

Adept I

After my harsh reply, this is what they said.  I guess they're done helping me :

I apologize for the inconvenience caused to you.

I would request you to please submit a bug report to AMD by using AMD bug report tool and please wait for future driver releases: