cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

toby3
Journeyman III

AMD Radeon 7800XT

Hello

I have recently built a new PC. Specs are as follows:-

  • MB AORUS Elite B650 AX
  • Processor Ryzen 7 7800x3D 8 Core
  • 32 Gb RAM
  • Radeon AMD 7800XT 
  • 750w Gigabyte power supply

Every thing has been running smoothly until this afternoon when the screen went black and no output on the monitor.

Cables ok as i am running off another monitor connected to the IGC.

Re-installed AMD drivers.

Also the fans are not running.

The red Sapphire light is  on

I have changed the power cables from one tewo put lead to two sigle leads.

Can anyone help me please!!!

0 Likes
7 Replies
zellith
Adept II

Are you using the HDMI or Display Port?  Could be related to a known issue (which AMD doesnt talk about).  Could just be a wonky cable.  Not sure!

0 Likes

I have tried both

0 Likes
FunkZ
Paragon

If you open Windows Device Manager or an app like GPU-Z does it detect the card?

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT
0 Likes

Yes i can see the card in device manager

0 Likes

I would contact Sapphire support, you may have to RMA the card.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT
0 Likes

Actually no it doesnt i got confused because my on board card is also a Radeon AMD

 

0 Likes

Ok, so 7800XT was working fine, stopped working, power checks ok, lights on but no fans, not showing up as detected hardware in Windows? And there's no "unknown device" or warnings about a device with problems?

Only other thing I can think to check is in BIOS make sure primary graphics is set to Auto or PCIe and not forced on integrated. Otherwise contact Sapphire about an RMA.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT
0 Likes