Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept III

5700xt Crashing

Have been having issues since day with my 5700xt, it should be noted that I have two identical builds (one for me, one for my wife). Her system has been issue free without a single crash, where as mine has crashed in every game I play (Fornite, WoW, LoL, Rust, Stardew Valley). The crashes are either full system crashes (causes EZ Debug LED which forces you to clear/jump the CMOS) or more recently crashes to desktop and the system will reboot automatically. 

Other forums are reporting multiple users experiencing this issue due to AMD Radeon VSR (virtual screen resolution) being enabled via setting adviser. The problem is when you disable it, the bug will persist though the setting is off and the only way to undo the setting is by DDUing the GPU driver.

To do so, DDU (while in windows safe mode) the GPU driver, then reinstall the 5700xt driver (Adrenaline). Upon reinstallation DO NOT enable any settings Radeon adviser suggests. I personally have done these steps and have not crashed (yet) but others are stating they are still having issues with older motherboards. Since doing the DDU I have ran Heaven on ultra settings and scored 2845 with 112.9 frames (43 min / 210 max), I will reply back here if I crash again.


X570 MSI Gaming Pro Carbon (Bios MFlashed to 7B93v11)
5700xt Sapphire


G.Skill Ripjaw V 3600 CL16 

XF270HU WQHD IPS 144hz


1 Solution
Adept III

Potential Solution:

Wanted to get a comment in here to mark as solution, as myself and others seem to have stable systems. Here are the steps we took:

UPDATE 1: I got stuck in a BSOD boot loop and had to move my M2 drive & reinstall Windows 10 - This is an unrelated issue to the 5700xt

UNTIL THERE IS A BIOS UPDATE (to DO NOT install an NVMe M2 SSD into a M2 slot that DOES NOT also accept SATA - instead, install the drive into the M2 slot that does accept SATA. For the X570 MSI Gaming Pro Carbon M2 #1 does not have SATA where #2 does. So I believe some (if not almost all) of my random crashes were due to the Samsung 970 EVO Plus NVMe drive being inserted into M2 #1, because once I moved the drive and reinstalled windows I have not had a SINGLE WHEA 17 PCIe error in event viewer.

  1. Start with a fresh install of Windows 10 version 1903 (Solution should work regardless of this, but use as last resort)
    1. I had ethernet unplugged as I did the install
  2. Update your motherboard BIOS (My X570 came with a bios more than a month old)
    1. Usually requires FAT32 flash drive
    2. Check in your motherboard manual for appropriate steps
  3. Disable Microsoft Automatic Updates
    1. Type Check for updates
    2. Click Pause Update
  4. Install motherboard CHIPSET driver from (Chipsets > AMD Socket AM4 > Choose your board type) 
    1. DO NOT install the chipset driver from your motherboard manufacturer
  5. Restart
  6. Plug ethernet cord in
  7. Download and install Processor driver from (Processors > Ryzen Master)
  8. Restart
  9. Download and Install C++ in sequential year order (I did a fresh install, so I did not already have these)
    1. 2010 C++ (x64)
    2. 2015 C++ (x64)
    3. 2015-2019 C++ (x64)
  10. Restart
  11. Download and Install Adrenalin 19.7.3 from (UPDATED due to new driver)
    1. 420mb version - DO NOT use Auto detect & DO NOT update within Adrenalin
  12. Restart
  13. Check for Windows Updates
    1. Repeat until your fingers are numb & restart after each update is installed
  14. Enable Microsoft Automatic Updates
    1. Type Check for updates
    2. Click Check for Update

You'll want to run the following everyday until your issues stop

  • Check for Windows Updates
  • DO NOT allow Radeon adviser to enable settings
    • Specifically Virtual Screen Resolution (VSR) and Enhanced Sync - leave these OFF
  • Run DirectX Diagnostic Tool - Type DXDIAG in the start menu and run
    • click next page and exit when done
  • Run system file checker periodically in CMD as admin: SFC /scannow
    • If you have issues that are not resolved, online repair SHOULD correct the issues
  • Run the online repair periodically dism /online /cleanup-image /restorehealth
  • Avoid using multiple programs at the same time to monitor temps/utilization
  • Avoid clicking on Windows notifications while in-game
    • You can fully disable these within Windows settings
  • Avoid using MSI Afterburner

Use Event Viewer (Run as Administrator) to find errors:

  • In start menu, type Event Viewer
  • Right click, run as administrator
  • On the right side click
    • Create Custom View 
    • Event Level: Critical, Warning, Error
    • Choose Event Logs:
      • Windows - Application
      • Application & Services: Hardware events
    • Click OK, and name this filter Summary of Errors or whatever you want
      • This is how I am able to spot application errors after computer restarts or BSOD
  • Repeat and make a second filter
    • Create Custom View
    • Event Level: Critical, Warning, Error
    • Choose Event Logs:
      • Windows - Application
    • Choose Event Sources
      • Application Hang
    • Click OK, and name this filter Game Errors or whatever you want
      • This is how I am able to spot the r5apex.exe errors

PS: - If Adrenalin 19.7.3 doesn't work - DDU the driver and start again

DDU Link

  • Launch Option: Safe Mode
  • Upon restart, choose GPU driver
  • Select Remove and Restart
  • Upon restart, reinstall 19.7.3

#solution #support #help #5700xt #AMD #x570 #AM4

View solution in original post

130 Replies

The New update 19.7.3 is working for me and is stable, it appears like they have fixed some errors as I can now run the Overlay in gaming as well as FreeSync and other suggested display settings in 19.7.3. I know one night of gaming does not mean consistency LOL but I will take what i can get at this point:)

I ran the DDU tool and re-installed AMD Chipset drivers however, I still need to run my PCIE in GEN3 mode.

I have not experienced any changes in temperature improvement:(

**One fix for my system stability was my memory... I "downclocked" my G.Skill Trident 3600mHz-CL17-1.35v to 3400mHz-CL15-1.3v and have not experience any more crashes, I did this a few days ago for 19.7.2 and it was very successful as well.

There are too many posts, time and energy for the X570 and 5700 product launch. I am glad AMD is stepping up their game and the new products are promising, however team green and blue are pretty good at plug and play with little adjustments. I also find it funny that Windows would release an update (Windows 1903) at the same time that causes driver issues with AMD products.

Still team Red!


Helo! My friends gpu is crashing frequently with tons of errors on device manager-display adapter-events. New 5700xt gigabyte oc 

Adept I

I'm also having stuttering and crashes. The crashes are mostly alt tabbing from fullscreen games. Its runs ffxiv pretty well I suppose but every other game I throw at it doesn't break 40-45 fps. I've tried Dauntless and Destiny 2 at 1140p. For reference my gtx 1080 did a little worse in ffxiv but around 60-70 fps in Dauntless and Destiny.  The GPU is almost always averaging 50-60% utilization outside of ffxiv.

Im using:

I7 7700k 4.2 OC 4.8 turbo

Asrock z270 extreme 4 mobo

16gb DDR4 3200mhz

5700XT AE with the Arctic accelero extreme iv

19.7.2 Drivers

Adept II

My blackscreen + reboot issue was RAM related, had to downclock it from 3200 to 3000.

Still better then 2133mhz when i had a Ryzen 2600, this 3600 seems to like my RAM much better.

So i'm keeping the card, i was about to give up.

Hm. My ram is 2133 but I could try reducing it. 


I was mistaken. For some reason my ram was set to 2133 but its actually 3200. I set it to 3200 and saw a dramatic decrease in performance in FFXIV. I set it down to 3000 and still saw the same decrease in performance. Waiting to test other games at various frequencies.


That seems really weird, are you on Ryzen? it should increase performance, not decrease.

But are you getting these blackscreen > reboot during gaming? in my case it wasn't related to the GPU thankfully.

Adept II

This solution does not work.

Works for most people and me included.

Your issue may be different from mine. If I install the 19.7.1/19.7.2 driver in any capacity (with or without Adrenalin, directly through Devices Manager), the PC will crash and will be unable to boot into Windows. This will only occur if I am using a 3700X but not the 2700X, indicating there is a driver issue with 3000 series on my platform (X470). The 5700 XT runs flawlessly if I use my 2700X.


Then it's best to make your own thread if the issue is different.

Already did so but I was looking for other potential solutions. Amazing how glitched AMD's stuff is.

Adept III

And just crashed 5 times in a row at an idle desktop, didnt change anything so I have no idea whats going on. Tons of WHEA 17 (PCIe errors) - So I forced PCIe Gen3 mode only, hopefully that fixes it.. 

I did reach out to MSI and they are aware of issues with the BIOS and plan to release a new update "soon"

Edit: It didnt, the crashes got worse and turned into BSOD "Critical_Process_Died" - and couldnt get out of a BSOD loop.. ended up reformatting my drive and reinstalling windows on my SSD. Apparently the WHEA errors were from my SAMSUNG M.2 NVMe 970 Evo Plus boot drive and its due to the motherboard bios. 

Adept III

Soooo as for the WHEA 17 errors - I moved my 970 Evo Plus to the M.2 #2 slot on my X570 board and do not see anymore WHEA 17 errors!!! Literally zero! I checked my 2nd computer and I believe it hasnt been as impacted (it had around 30x WHEA 17 errors) by the issues PC1 has been plagued with mainly bc its off 98% of the time whereas the other is on almost all day everyday, it slow ate away and corrupted my windows install. 

Per MSI:

M2_1 slot (from AMD® Processor) supports PCIe 4.0 x4 (3rd Gen AMD Ryzen™ Desktop Processors) or PCIe 3.0 x4 (2nd Gen AMD Ryzen™/ Ryzen™ with Radeon™ Vega Graphics and 2nd Gen AMD Ryzen™ with Radeon™ Graphics) 2242/2260/2280 storage devices

M2_2 slot (from AMD® X570 Chipset) supports PCIe 4.0 x4 (3rd Gen AMD Ryzen™) or 3.0 x4 (2nd Gen AMD Ryzen™/ Ryzen™ with Radeon™ Vega Graphics and 2nd Gen AMD Ryzen™ with Radeon™ Graphics) and SATA 6Gb/s 2242/ 2260/ 2280/ 22110 storage devices

Adept I

Today I just gave my radeon to shop , I am taking something else  

Adept II

Just updated to 19.7.3 and everything seems to be fine. The stuttering and crashing seemed to stop when I went from 144hz to 120hz which I dont really mind, and disabled Enhanced sync and freesync.

A new driver than 19.7.2? I switched back to my 1080 because my 5700 has been trash.

Yeah, I was troubleshooting when I went on AMDs website and noticed that the driver was 19.7.3

19.7.3 Adrenaline is definitely available now.  Also, I installed it and my systems works better than it ever has.  Thank you AMD for getting this resolved.  Please continue to improve it!


I expect they will improve the drivers on a regular basis for the next few months while they squash each bug as they appear. It's good to see improvement in every release though!

Adept II

Installed them, i still had a crash in BF5 but not sure what caused it, it was either the Radeon wattman overlay or Radeon Image Sharpening.

Disabled both to be sure and had a full match without crashing luckily.

EDIT: Played some more with MSI Afterburner and overlay running without issues, so i'm happy.

Adept III

Installed 19.7.3, everything was going great until I got a BSOD for atikmpag.sys

which correlates TO MORE GPU DRIVER ISSUES...


The 19.7.3 was improving(ed) but not perfect yet...

The atikmpag.sys error is not really related to this driver, it happed to me way before this model even with different brand GPU.

It is a common error for GPU not only AMD also happen for Nvidxx too.  There is a quick fix guide at following

Adept II

Yep same problem, atikmpag.sys blue screen, I have noticed a pattern that everyone having issues seems to be running a ryzen 1000 series or 2000 series processor, maybe its an issue with b450 and x470 compatibility.

Well at least I'm not alone - For the record I'm on a Ryzen 5 3600x on a X570 Gaming Pro Carbon board, with QVL ram G.Skill DDR4 3600 Cl16 :/

Journeyman III

Me too with m'y rx 5700 xt. I've the same issues. On dcs, Resident evil 2 i've a black screen and pc reboot. My pc freeze ramdomly. GTA V don't boot with a direct x 9 error.

It's the same issues with 19.7.1, 19.7.2 ans 19.7.3 drivers. I'd used ddu to install driver but nothing change. I'd tested a rtx 2080 and all was going great.

My config:

Windows 10 1903 build

Asus prime b350 plus with 5007 bios.

Ryzen 1600x

16 go DDR 4 3200 corsair Vengeance lpx

Enermax 700w

I'd Always buying AMD but now i decide to return this graphic card and i decide to buy a rtx 2080.

Adept III

Got these yesterday, really losing patience:

PAGE_FAULT_IN_NONPAGED_AREA Caused by ntoskrnl.exe


DRIVER_IRQL_NOT_LESS_OR_EQUAL Caused by atikmdag.sys & ntoskrnl.exe

VIDEO_TDR_FAILURE Caused by atikmdag.sys


Think I might just return it and go with Nvidia, I logged a ticket with AMD about 6 days ago, still not had a response. Terrible company.

I got my issue fixed via BIOS update. However, I did submit a Support ticket as well as a return request for 5700XT. Didn't hear back on either front. They have really bad customer service.


Yea I’m pretty sure it has to do with MSI AGESA and not AB or ABA versions for the motherboard. I know for a fact that’s the issue with the NMVe drive, wouldn’t be surprised it’s affecting the GPU too. Someone posted saying their Aorus master /5700xt 50th hasn’t had a single BSOD - that Aorus master has had the AB bios since launch.. need MSI to step up now

Adept II

I just got a BSOD, this is the error i got: Bug Check 0x192 KERNEL_AUTO_BOOST_LOCK_ACQUISITION_WITH_RAISED_IRQL - Windows drivers | Microsoft Do... 

Has this anything to do with the GPU?

Adept II

Black Ops 4 is currently causing driver crash on win 10 and freezes entire screen on windows, game however still runs fine but entire windows become unusuable
Black Ops 1 is unplayable due to insane stuttering, GPU usage keep dropping to 0%
Many users are getting game crashes or bluescreens in Apex Legends, Overwatch and R6 Siege
RX 5700s are unusuable on Windows 7, monitor just goes back and displays NO HDMI SIGNAL in random moments
Card has currently VRAM leak, every single game uses more VRAM on this card than it should. Me and my friend are both UNABLE to play BO4 with textures on V.High because card runs out of VRAM, game stutters and eventually freezes.... We both have a GTX 1080 which also has 8GBs of VRAM and game runs fine on V.High, also windows doesn't freeze....
Even ''turn off screen'' option doesn't work properly in windows 10. Monitor doesn't turn off but instead is keep displaying black image.. What a disaster. I wonder if the windows 10 is a total failure currently in terms of supporting new hardware or the drivers for new RX 5700XT are that bad... I started RMA process, I'm done. Three drivers and both Black Ops games are still unplayable due to issues, VRAM leaks, VSR doesn't work, Enchantment sync doesn't work, GPU culling also doesn't work, turning ON freesync or even changing fan curve can cause issues LOL. What the hell


You LITERALLY Couldn't of said it better dude. Microsoft are just rubbish at operating systems now, Making me want to go back to Linix. AMD make fantastic hardware but I am PRETTY sure by this point there software team is some dude sitting in a room using fkn notepad to code their drivers. Imagine AMD hardware, with Intel and Nvidia software teams? the world would be FANTASTIC xD

Adept III

Update: 19.7.4 was released this morning, I have not installed it yet but it looks like it has some more 5700 fixes implemented - I may try it out later but probably wont until I encounter another issue.

I do want to note that I had to reinstall Windows AGAIN because the Insider build (fast group: build 10001) wouldn't let me open ANY games. For whatever reason, this time around I have not had any issues. I was able to play all of my games without any crashing. But I am also NOT touching ANY setting within Radeon settings/Wattman nor am I using ANYthing to monitor temps/utilization - I'm wondering if I was getting a race condition with too many programs monitoring temps. 

Also on Reddit AMD_Robert is going to be talking about the WHEA 17 errors which coincides with release timing of the 19.7.4 update


I wonder if AMD should do a Chipset Driver update for X570 systems, it is still the same revision since 7-7-19?

I did the latest 19.7.4 drivers last night and still unable to run PCIE for my 5700XT in GEN4.

The new driver 19.7.4 seems more stable on my system, however i did see some artifacting for the first time(only once), so i may do another clean install later today.

Unfortunately there has been much frustration with this launch, which is unfortunate. This hardware has great potentional but most of the public is not willing to troubleshoot nonstop.


Theres actually a chipset driver that just released a few hours ago that I didn’t list, but this update should help out. The PCIE issue still exists and won’t be fixed until your motherboard sends out

I must have missed this, can you clarify which chipset driver was just released?  I don't see any new chipset drivers on AMD drivers/support section for X570.


Sure - they aren’t on the site under drivers yet. The downloads are at the bottom of the page 


So if its not on the drivers section yet does that mean it is a beta for all us current navi beta testers =P

All that aside I hope AMD continues to improve their drivers since many early adopters are or have already lost faith.


Today Asrock released Bios update 1.70 for the Taichi X570 and for now it is working perfectly. I am able to run all benchmarking software and I can leave PCIE settings on AUTO (GEN4)!!!! 19.7.4 is running cooler in the 70s.

The only thing that needed adjusting was the DDR4 memory. I had to clock at 3200mHz  CL14 and however it is very stable.


MSI released the new AGESA AMD ComboPI1.0.0.3ab on 7/15 for X470 Gaming M7 AC and I saw considerable improvements as far as CPU overclocking.   
I considered this BIOS update having no effect on my RX 5700 XT Anniversary that was working fine with a Wattman configuration on Radeon 19.7.1 and 19.7.3 , I had nothing but crashes with 19.7.2. I been fine for a week until yesterday crashes that have prevented me of making any changes with in Wattman or otherwise experience a crash.

I tested 19.7.1 good with Wattman profile configuration

19.7.2 crash prone with Wattman profile configuration.

19.7.3 good with optimum Wattman profile configuration for a week.  

19.7.4 tried it on other systems and experienced freeze crash, so skipped this on 5700 XT AE test

19.7.5 installed this yesterday after experiencing my first crash in over a week on 19.7.3.    It crashed more with this update, so I don't see any benefits of these newer versions other the games they fixed issues with.

I'm seeing a small artifact appear in game during the loading intros that never was there before yesterday's first crash in a week which makes me think these issues are hardware related. 

No amount of uninstall, clean, reinstall seem to fix this card which appears to have got less stable.   I hope this isn't something serious to a bad batch release of RX 5700 XT, but I won't be surprised if this turns out to be true.    Never had this much instability with a brand new graphics card.   Not even my two VEGA 56s that I use on my Threadripper Core P5 have these issues when I run benchmarks on them, and I use those cards to heavily crypto mine on, and they were bought USED.